Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перевод формата тект во время - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перевод формата тект во время (Формулы/Formulas)
Перевод формата тект во время
El23 Дата: Пятница, 05.02.2016, 13:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Данные по продолжительности выведены в текстовом виде, как (4 мин, 25 сек) или 25 сек. Можно ли их перевести в обычный формат времени (мм:сс) формулой?
 
Ответить
СообщениеДобрый день.
Данные по продолжительности выведены в текстовом виде, как (4 мин, 25 сек) или 25 сек. Можно ли их перевести в обычный формат времени (мм:сс) формулой?

Автор - El23
Дата добавления - 05.02.2016 в 13:43
китин Дата: Пятница, 05.02.2016, 13:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3433
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
без примера, ради тренировки
Код
=ЕСЛИОШИБКА(--ЛЕВБ(A1;ПОИСК("мин";A1)-2);0)&":"&--ПСТР(A1;ПОИСК("сек";A1)-3;2)

если не так, без примера переделывать не буду :p


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениебез примера, ради тренировки
Код
=ЕСЛИОШИБКА(--ЛЕВБ(A1;ПОИСК("мин";A1)-2);0)&":"&--ПСТР(A1;ПОИСК("сек";A1)-3;2)

если не так, без примера переделывать не буду :p

Автор - китин
Дата добавления - 05.02.2016 в 13:54
El23 Дата: Пятница, 05.02.2016, 14:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Китин, вот что вышло.
Спасибо, хотя не совсем понимаю, как у вас это вышло.
К сообщению приложен файл: 4235943.xls(26Kb)
 
Ответить
СообщениеКитин, вот что вышло.
Спасибо, хотя не совсем понимаю, как у вас это вышло.

Автор - El23
Дата добавления - 05.02.2016 в 14:13
buchlotnik Дата: Пятница, 05.02.2016, 14:14 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ну если именно время нужно
Код
=ВРЕМЯ(0;ЕСЛИОШИБКА(ЛЕВСИМВ(A1;ПОИСК("мин";A1)-2);0);ПСТР(A1;ПОИСК("сек";A1)-3;2))
К сообщению приложен файл: 5508245.xls(28Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 05.02.2016, 14:15
 
Ответить
Сообщениену если именно время нужно
Код
=ВРЕМЯ(0;ЕСЛИОШИБКА(ЛЕВСИМВ(A1;ПОИСК("мин";A1)-2);0);ПСТР(A1;ПОИСК("сек";A1)-3;2))

Автор - buchlotnik
Дата добавления - 05.02.2016 в 14:14
SLAVICK Дата: Пятница, 05.02.2016, 14:26 | Сообщение № 5
Группа: Модераторы
Ранг: Старожил
Сообщений: 1839
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Как вариант UDF из этой темы - может работать до недель ;)
К сообщению приложен файл: 1452723-2-.xls(42Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеКак вариант UDF из этой темы - может работать до недель ;)

Автор - SLAVICK
Дата добавления - 05.02.2016 в 14:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перевод формата тект во время (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!