Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать дубликаты по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать дубликаты по условию (Формулы/Formulas)
Как посчитать дубликаты по условию
KAZANOBA Дата: Суббота, 13.02.2016, 21:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый вечер Знатоки , очень нужна ваша помощь . Суть проблемы следующая , необходимо посчитать кол-во дубликатов (номер а/м ) по условию ,в данном случае условия это дата
К сообщению приложен файл: 9109516.xls(24Kb)
 
Ответить
СообщениеДобрый вечер Знатоки , очень нужна ваша помощь . Суть проблемы следующая , необходимо посчитать кол-во дубликатов (номер а/м ) по условию ,в данном случае условия это дата

Автор - KAZANOBA
Дата добавления - 13.02.2016 в 21:59
buchlotnik Дата: Суббота, 13.02.2016, 22:08 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2616
Репутация: 746 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Вам просто сколько штук? или их выделить надо как в файле?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеВам просто сколько штук? или их выделить надо как в файле?

Автор - buchlotnik
Дата добавления - 13.02.2016 в 22:08
KAZANOBA Дата: Суббота, 13.02.2016, 22:14 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Нет , просто посчитать сколько дубликатов за конкретное число
 
Ответить
СообщениеНет , просто посчитать сколько дубликатов за конкретное число

Автор - KAZANOBA
Дата добавления - 13.02.2016 в 22:14
buchlotnik Дата: Суббота, 13.02.2016, 22:18 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2616
Репутация: 746 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
я бы сводную сделал
К сообщению приложен файл: 9109516-2-.xls(35Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениея бы сводную сделал

Автор - buchlotnik
Дата добавления - 13.02.2016 в 22:18
KAZANOBA Дата: Суббота, 13.02.2016, 22:24 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо , я так делал. А другие есть варианты ?
 
Ответить
СообщениеСпасибо , я так делал. А другие есть варианты ?

Автор - KAZANOBA
Дата добавления - 13.02.2016 в 22:24
buchlotnik Дата: Суббота, 13.02.2016, 22:25 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2616
Репутация: 746 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
KAZANOBA, сводная таблица самое прострое, быстрое и первое приходящее на ум решение - объясните, чем оно не устраивает


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 13.02.2016, 22:31
 
Ответить
СообщениеKAZANOBA, сводная таблица самое прострое, быстрое и первое приходящее на ум решение - объясните, чем оно не устраивает

Автор - buchlotnik
Дата добавления - 13.02.2016 в 22:25
KAZANOBA Дата: Суббота, 13.02.2016, 22:34 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Хотел сделать так , забил дату любую а формула на основании даты подтянула кол-во дубликатов из массива
 
Ответить
СообщениеХотел сделать так , забил дату любую а формула на основании даты подтянула кол-во дубликатов из массива

Автор - KAZANOBA
Дата добавления - 13.02.2016 в 22:34
buchlotnik Дата: Суббота, 13.02.2016, 22:36 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2616
Репутация: 746 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ну вот что мешает сразу задачу нормально формулировать:
Код
=СУММПРОИЗВ(($C$2:$C$93=E2)*(СЧЁТЕСЛИ($A$2:$A$93;$A$2:$A$93)>1))
К сообщению приложен файл: 7325039.xls(32Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениену вот что мешает сразу задачу нормально формулировать:
Код
=СУММПРОИЗВ(($C$2:$C$93=E2)*(СЧЁТЕСЛИ($A$2:$A$93;$A$2:$A$93)>1))

Автор - buchlotnik
Дата добавления - 13.02.2016 в 22:36
_Boroda_ Дата: Суббота, 13.02.2016, 22:40 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(--(СЧЁТЕСЛИМН(C2:C93;E1;A2:A93;A2:A93)>1))
К сообщению приложен файл: 9109516-1.xls(31Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(--(СЧЁТЕСЛИМН(C2:C93;E1;A2:A93;A2:A93)>1))

Автор - _Boroda_
Дата добавления - 13.02.2016 в 22:40
KAZANOBA Дата: Суббота, 13.02.2016, 22:44 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Оба варианты верны спасибо , а можно сделать так чтобы он считал только дубликаты . т.е в нашем случае это 2 а не 4 ? Это конечно не очень принципиально , можно и на 3 разделить
 
Ответить
СообщениеОба варианты верны спасибо , а можно сделать так чтобы он считал только дубликаты . т.е в нашем случае это 2 а не 4 ? Это конечно не очень принципиально , можно и на 3 разделить

Автор - KAZANOBA
Дата добавления - 13.02.2016 в 22:44
KAZANOBA Дата: Суббота, 13.02.2016, 22:45 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
пример за 10 число . Описался , разделить на 2 а не на 3 :)
 
Ответить
Сообщениепример за 10 число . Описался , разделить на 2 а не на 3 :)

Автор - KAZANOBA
Дата добавления - 13.02.2016 в 22:45
KAZANOBA Дата: Воскресенье, 14.02.2016, 21:31 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Господа , подскажите , как посчитать кол-во повторяющихся значений по двум условиям , в данном случае это город и дата ?
 
Ответить
СообщениеГоспода , подскажите , как посчитать кол-во повторяющихся значений по двум условиям , в данном случае это город и дата ?

Автор - KAZANOBA
Дата добавления - 14.02.2016 в 21:31
Pelena Дата: Воскресенье, 14.02.2016, 21:35 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10999
Репутация: 2456 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
в нашем случае это 2 а не 4
Почему это?

кол-во повторяющихся значений по двум условиям
Добавьте ещё одно условие в функцию СУММЕСЛИМН (или СУММПРОИЗВ для первого варианта)
Без файла только общий ответ


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
в нашем случае это 2 а не 4
Почему это?

кол-во повторяющихся значений по двум условиям
Добавьте ещё одно условие в функцию СУММЕСЛИМН (или СУММПРОИЗВ для первого варианта)
Без файла только общий ответ

Автор - Pelena
Дата добавления - 14.02.2016 в 21:35
KAZANOBA Дата: Воскресенье, 14.02.2016, 21:37 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Прикрепил :)
К сообщению приложен файл: 7325039-2-.xls(27Kb)
 
Ответить
СообщениеПрикрепил :)

Автор - KAZANOBA
Дата добавления - 14.02.2016 в 21:37
KAZANOBA Дата: Воскресенье, 14.02.2016, 21:50 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Надеюсь на помощь
 
Ответить
СообщениеНадеюсь на помощь

Автор - KAZANOBA
Дата добавления - 14.02.2016 в 21:50
buchlotnik Дата: Воскресенье, 14.02.2016, 21:57 | Сообщение № 16
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2616
Репутация: 746 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
это мы уже проходили - где в вашем файле описание предполагаемого результата?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеэто мы уже проходили - где в вашем файле описание предполагаемого результата?

Автор - buchlotnik
Дата добавления - 14.02.2016 в 21:57
Pelena Дата: Воскресенье, 14.02.2016, 22:03 | Сообщение № 17
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10999
Репутация: 2456 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Если всё-таки нужно, чтобы каждое повторяющееся значение учитывалось один раз
Код
=СУММПРОИЗВ((C2:C93=F2)*(D2:D93=G2)*(СЧЁТЕСЛИ(A2:A93;A2:A93)>1)*(ПОИСКПОЗ(A2:A93;A2:A93;0)=СТРОКА(A2:A93)-1))
К сообщению приложен файл: 0212533.xls(34Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли всё-таки нужно, чтобы каждое повторяющееся значение учитывалось один раз
Код
=СУММПРОИЗВ((C2:C93=F2)*(D2:D93=G2)*(СЧЁТЕСЛИ(A2:A93;A2:A93)>1)*(ПОИСКПОЗ(A2:A93;A2:A93;0)=СТРОКА(A2:A93)-1))

Автор - Pelena
Дата добавления - 14.02.2016 в 22:03
KAZANOBA Дата: Воскресенье, 14.02.2016, 22:31 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Круто , большое Вам спасибо !!!! Респект и уважуха , именно то что надо , а именно повторяющееся значение посчитать один раз
 
Ответить
СообщениеКруто , большое Вам спасибо !!!! Респект и уважуха , именно то что надо , а именно повторяющееся значение посчитать один раз

Автор - KAZANOBA
Дата добавления - 14.02.2016 в 22:31
KAZANOBA Дата: Воскресенье, 14.02.2016, 23:52 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Парни не поймите что я такой тупой , но все же спрошу , переношу формулу в итоговый файл куда мне необходимо , и она показывает какой то бред . Вставляю эти же данные в файл от Pelena и все четко работает . Что могу делать не так ? Все проверил сто раз , ошибки быть не должно . Формула у меня в файле вот так выглядит
Код
=СУММПРОИЗВ(('Отчет по разнарядкам'!$N$2:$N$2540=$B$37)*('Отчет по разнарядкам'!$O$2:$O$2540=$C$36)*(СЧЁТЕСЛИ('Отчет по разнарядкам'!$M$2:$M$2540;'Отчет по разнарядкам'!$M$2:$M$2540)>1)*(ПОИСКПОЗ('Отчет по разнарядкам'!$M$2:$M$2540;'Отчет по разнарядкам'!$M$2:$M$2540;0)=СТРОКА('Отчет по разнарядкам'!$M$2:$M$2540)-1))

[moder]Хорошо, парни не поймут.
А вот то, что Вы Правила форума не читали - это парни (и даже девушки, наверное) поймут.
Поправил Ваше сообщение и первое предупредительное замечание ловите.


Сообщение отредактировал _Boroda_ - Воскресенье, 14.02.2016, 23:56
 
Ответить
СообщениеПарни не поймите что я такой тупой , но все же спрошу , переношу формулу в итоговый файл куда мне необходимо , и она показывает какой то бред . Вставляю эти же данные в файл от Pelena и все четко работает . Что могу делать не так ? Все проверил сто раз , ошибки быть не должно . Формула у меня в файле вот так выглядит
Код
=СУММПРОИЗВ(('Отчет по разнарядкам'!$N$2:$N$2540=$B$37)*('Отчет по разнарядкам'!$O$2:$O$2540=$C$36)*(СЧЁТЕСЛИ('Отчет по разнарядкам'!$M$2:$M$2540;'Отчет по разнарядкам'!$M$2:$M$2540)>1)*(ПОИСКПОЗ('Отчет по разнарядкам'!$M$2:$M$2540;'Отчет по разнарядкам'!$M$2:$M$2540;0)=СТРОКА('Отчет по разнарядкам'!$M$2:$M$2540)-1))

[moder]Хорошо, парни не поймут.
А вот то, что Вы Правила форума не читали - это парни (и даже девушки, наверное) поймут.
Поправил Ваше сообщение и первое предупредительное замечание ловите.

Автор - KAZANOBA
Дата добавления - 14.02.2016 в 23:52
KAZANOBA Дата: Воскресенье, 14.02.2016, 23:58 | Сообщение № 20
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Понял , учту замечания.
 
Ответить
СообщениеПонял , учту замечания.

Автор - KAZANOBA
Дата добавления - 14.02.2016 в 23:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать дубликаты по условию (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!