Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение цифр в числе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение цифр в числе (Формулы/Formulas)
Сложение цифр в числе
stria Дата: Вторник, 23.02.2016, 17:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Например: ЧИСЛО 62142. Складываем 6 и 2 — получается 8; 2 и 1 — получается 3; 1 и 4 — получается 5; 4 и 2 — получается 6. ОТВЕТ 8356
КАК ЭТО ПЕРЕВЕСТИ В ФОРМУЛУ?


Сообщение отредактировал stria - Вторник, 23.02.2016, 17:08
 
Ответить
СообщениеНапример: ЧИСЛО 62142. Складываем 6 и 2 — получается 8; 2 и 1 — получается 3; 1 и 4 — получается 5; 4 и 2 — получается 6. ОТВЕТ 8356
КАК ЭТО ПЕРЕВЕСТИ В ФОРМУЛУ?

Автор - stria
Дата добавления - 23.02.2016 в 17:08
buchlotnik Дата: Вторник, 23.02.2016, 17:17 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
а что должно получиться для числа 8356 - 8+3 =11; 3+5 = 8;5+6 = 11 - 11811?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеа что должно получиться для числа 8356 - 8+3 =11; 3+5 = 8;5+6 = 11 - 11811?

Автор - buchlotnik
Дата добавления - 23.02.2016 в 17:17
stria Дата: Вторник, 23.02.2016, 17:30 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
а что должно получиться для числа 8356 - 8+3 =11; 3+5 = 8;5+6 = 11 - 11811?

Нет - Это условие такое. Используется в психологическом тесте - определения "оперативной памяти"
 
Ответить
Сообщение
а что должно получиться для числа 8356 - 8+3 =11; 3+5 = 8;5+6 = 11 - 11811?

Нет - Это условие такое. Используется в психологическом тесте - определения "оперативной памяти"

Автор - stria
Дата добавления - 23.02.2016 в 17:30
vikttur Дата: Вторник, 23.02.2016, 17:51 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

В разные ячейки.
Если известно количество разрядов:
Код
=ПСТР(A1;СТОЛБЕЦ(A:K);1)+ПСТР(A1;СТОЛБЕЦ(B:L);1)

Для разного количества разрядов (в примере - до 12)
Код
=ЕСЛИОШИБКА(ПСТР(A1;СТОЛБЕЦ(A:K);1)+ПСТР(A1;СТОЛБЕЦ(B:L);1);"")
К сообщению приложен файл: 1529620.xlsx(9Kb)
 
Ответить
СообщениеВ разные ячейки.
Если известно количество разрядов:
Код
=ПСТР(A1;СТОЛБЕЦ(A:K);1)+ПСТР(A1;СТОЛБЕЦ(B:L);1)

Для разного количества разрядов (в примере - до 12)
Код
=ЕСЛИОШИБКА(ПСТР(A1;СТОЛБЕЦ(A:K);1)+ПСТР(A1;СТОЛБЕЦ(B:L);1);"")

Автор - vikttur
Дата добавления - 23.02.2016 в 17:51
stria Дата: Вторник, 23.02.2016, 18:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
В разные ячейки.

В одну ячейку не получиться?
 
Ответить
Сообщение
В разные ячейки.

В одну ячейку не получиться?

Автор - stria
Дата добавления - 23.02.2016 в 18:02
jakim Дата: Вторник, 23.02.2016, 18:28 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Код
=CONCATENATE(LEFT(A1)+MID(A1;2;1);MID(A1;2;1)+MID(A1;3;1);MID(A1;3;1)+MID(A1;4;1);MID(A1;4;1)+RIGHT(A1))
 
Ответить
Сообщение
Код
=CONCATENATE(LEFT(A1)+MID(A1;2;1);MID(A1;2;1)+MID(A1;3;1);MID(A1;3;1)+MID(A1;4;1);MID(A1;4;1)+RIGHT(A1))

Автор - jakim
Дата добавления - 23.02.2016 в 18:28
stria Дата: Вторник, 23.02.2016, 18:33 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
jakim,
ЗДОРОВО.
ПРЕМНОГО БЛАГОДАРЕН


Сообщение отредактировал stria - Вторник, 23.02.2016, 18:33
 
Ответить
Сообщениеjakim,
ЗДОРОВО.
ПРЕМНОГО БЛАГОДАРЕН

Автор - stria
Дата добавления - 23.02.2016 в 18:33
stria Дата: Вторник, 23.02.2016, 18:44 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
jakim,
Вот с этим числом 41752 почему то сбой в расчете.
К сообщению приложен файл: 2201895.xlsx(11Kb)


Сообщение отредактировал stria - Вторник, 23.02.2016, 18:47
 
Ответить
Сообщениеjakim,
Вот с этим числом 41752 почему то сбой в расчете.

Автор - stria
Дата добавления - 23.02.2016 в 18:44
Nic70y Дата: Вторник, 23.02.2016, 18:54 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3492
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
4+1=5
1+7=8
7+5=12
5+2=7

где?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение4+1=5
1+7=8
7+5=12
5+2=7

где?

Автор - Nic70y
Дата добавления - 23.02.2016 в 18:54
jakim Дата: Вторник, 23.02.2016, 19:02 | Сообщение № 10
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Вам нужно подбирать такие цифры, чтобы в сумме они были меньше 9.
 
Ответить
Сообщение
Вам нужно подбирать такие цифры, чтобы в сумме они были меньше 9.

Автор - jakim
Дата добавления - 23.02.2016 в 19:02
stria Дата: Вторник, 23.02.2016, 19:46 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010

Исправил ... Вместо 41752 должно 41725

Вам нужно подбирать такие цифры, чтобы в сумме они были меньше 9.

СПАСИБО, ЕЩЕ РАЗ.
 
Ответить
Сообщение
Исправил ... Вместо 41752 должно 41725

Вам нужно подбирать такие цифры, чтобы в сумме они были меньше 9.

СПАСИБО, ЕЩЕ РАЗ.

Автор - stria
Дата добавления - 23.02.2016 в 19:46
AlexM Дата: Вторник, 23.02.2016, 20:10 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Еще формула
Код
=СУММПРОИЗВ((ЛЕВБ(ПРАВБ(A1;СТРОКА($1:$4)))+ЛЕВБ(ПРАВБ(A1;СТРОКА($2:$5))))*10^(СТРОКА($1:$4)-1))
и еще
Код
=СУММПРОИЗВ((ПСТР(A1;СТРОКА($1:$4);1)+ПСТР(A1;СТРОКА($2:$5);1))*10^(4-СТРОКА($1:$4)))
К сообщению приложен файл: 2201895_1.xls(36Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 23.02.2016, 20:17
 
Ответить
СообщениеЕще формула
Код
=СУММПРОИЗВ((ЛЕВБ(ПРАВБ(A1;СТРОКА($1:$4)))+ЛЕВБ(ПРАВБ(A1;СТРОКА($2:$5))))*10^(СТРОКА($1:$4)-1))
и еще
Код
=СУММПРОИЗВ((ПСТР(A1;СТРОКА($1:$4);1)+ПСТР(A1;СТРОКА($2:$5);1))*10^(4-СТРОКА($1:$4)))

Автор - AlexM
Дата добавления - 23.02.2016 в 20:10
_Boroda_ Дата: Среда, 24.02.2016, 11:37 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А вот так не пойдет?
Код
=ЛЕВБ(A1;4)+ПСТР(A1;2;4)

Код
=ЛЕВБ(A1;4)+ПРАВБ(A1;4)
К сообщению приложен файл: 2201895_1_1.xls(44Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА вот так не пойдет?
Код
=ЛЕВБ(A1;4)+ПСТР(A1;2;4)

Код
=ЛЕВБ(A1;4)+ПРАВБ(A1;4)

Автор - _Boroda_
Дата добавления - 24.02.2016 в 11:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение цифр в числе (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!