Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упорядочить значения в строках - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упорядочить значения в строках (Формулы/Formulas)
Упорядочить значения в строках
GAPAGAPA Дата: Суббота, 09.04.2016, 17:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Не получается решить вроде простую задачку.
Пример прилагаю
Исходная таблица - в ней колонки с именами и значениями для каждого имени по строкам (где-то есть, где-то нет)
В результате надо получить таблицу (в примере видно) чтобы в каждой строке по возрастанию числового значения были сначала имя чье значение, потом само значение
А те у кого нет значений

Заранее спасибо.

Если эта задача выполнима, то прошу помочь с ее более сложной версией: все тоже самое что в предыдущей + упорядочить по номеру и удалить пустые строки (пример2) прилагаю
К сообщению приложен файл: 7148685.xlsx(10Kb) · 1214033.xlsx(10Kb)


Сообщение отредактировал GAPAGAPA - Суббота, 09.04.2016, 17:36
 
Ответить
СообщениеДобрый день. Не получается решить вроде простую задачку.
Пример прилагаю
Исходная таблица - в ней колонки с именами и значениями для каждого имени по строкам (где-то есть, где-то нет)
В результате надо получить таблицу (в примере видно) чтобы в каждой строке по возрастанию числового значения были сначала имя чье значение, потом само значение
А те у кого нет значений

Заранее спасибо.

Если эта задача выполнима, то прошу помочь с ее более сложной версией: все тоже самое что в предыдущей + упорядочить по номеру и удалить пустые строки (пример2) прилагаю

Автор - GAPAGAPA
Дата добавления - 09.04.2016 в 17:30
buchlotnik Дата: Суббота, 09.04.2016, 17:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
монструозно, но тягабельно B) (массивка)
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЕСЛИ(ЕНЕЧЁТ(СТОЛБЕЦ());$B$2:$G$2;$B3:$G3);ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");ОКРВВЕРХ(СТОЛБЕЦ(A1)/2;1));ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");0));"")
К сообщению приложен файл: 9214225.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениемонструозно, но тягабельно B) (массивка)
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЕСЛИ(ЕНЕЧЁТ(СТОЛБЕЦ());$B$2:$G$2;$B3:$G3);ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");ОКРВВЕРХ(СТОЛБЕЦ(A1)/2;1));ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");0));"")

Автор - buchlotnik
Дата добавления - 09.04.2016 в 17:40
GAPAGAPA Дата: Воскресенье, 10.04.2016, 10:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо большое. Вроде работает
 
Ответить
Сообщениеспасибо большое. Вроде работает

Автор - GAPAGAPA
Дата добавления - 10.04.2016 в 10:58
GAPAGAPA Дата: Воскресенье, 10.04.2016, 15:41 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
нашел одну неточность. Некорректно работает если одинаковые значения в одной строке. К примеру 10 у Андрея и Дмитрия. В итоге выдает два раза Андрей
 
Ответить
Сообщениенашел одну неточность. Некорректно работает если одинаковые значения в одной строке. К примеру 10 у Андрея и Дмитрия. В итоге выдает два раза Андрей

Автор - GAPAGAPA
Дата добавления - 10.04.2016 в 15:41
KuklP Дата: Воскресенье, 10.04.2016, 16:38 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1994
Репутация: 435 ±
Замечаний: 0% ±

Давайте ссылки на кроссы, Вам же объяснили:
http://www.planetaexcel.ru/forum....trokakh


Ну, с НДС и мы чего-то стoим! kuklp@mail.ru
WM Z206653985942, R334086032478, U238399322728
 
Ответить
СообщениеДавайте ссылки на кроссы, Вам же объяснили:
http://www.planetaexcel.ru/forum....trokakh

Автор - KuklP
Дата добавления - 10.04.2016 в 16:38
GAPAGAPA Дата: Воскресенье, 10.04.2016, 16:47 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
ссылка на кросс
http://www.planetaexcel.ru/forum....trokakh

в итоге нашел неточность:

Код
=ЕСЛИОШИБКА(ИНДЕКС(ЕСЛИ(ЕНЕЧЁТ(СТОЛБЕЦ());$B$2:$G$2;$B3:$G3);ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");ОКРВВЕРХ(СТОЛБЕЦ(A1)/2;1));ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");0));"")


Ошибка в том что Некорректно работает если одинаковые значения в одной строке. В итоге выдает два раза одно и тоже имя

И если нарушил какие-то правила, приношу извинения. Просто срочно нужно решить задачу, а не получается
 
Ответить
Сообщениессылка на кросс
http://www.planetaexcel.ru/forum....trokakh

в итоге нашел неточность:

Код
=ЕСЛИОШИБКА(ИНДЕКС(ЕСЛИ(ЕНЕЧЁТ(СТОЛБЕЦ());$B$2:$G$2;$B3:$G3);ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");ОКРВВЕРХ(СТОЛБЕЦ(A1)/2;1));ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3;"");0));"")


Ошибка в том что Некорректно работает если одинаковые значения в одной строке. В итоге выдает два раза одно и тоже имя

И если нарушил какие-то правила, приношу извинения. Просто срочно нужно решить задачу, а не получается

Автор - GAPAGAPA
Дата добавления - 10.04.2016 в 16:47
Pelena Дата: Воскресенье, 10.04.2016, 17:26 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Попробуйте так
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЕСЛИ(ЕНЕЧЁТ(СТОЛБЕЦ());$B$2:$G$2;$B3:$G3);ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3+СТОЛБЕЦ($B3:$G3)%%;"");ОКРВВЕРХ(СТОЛБЕЦ(A1)/2;1));ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3+СТОЛБЕЦ($B3:$G3)%%;"");0));"")
К сообщению приложен файл: 3045932.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте так
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЕСЛИ(ЕНЕЧЁТ(СТОЛБЕЦ());$B$2:$G$2;$B3:$G3);ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3+СТОЛБЕЦ($B3:$G3)%%;"");ОКРВВЕРХ(СТОЛБЕЦ(A1)/2;1));ЕСЛИ(ЕЧИСЛО($B3:$G3);$B3:$G3+СТОЛБЕЦ($B3:$G3)%%;"");0));"")

Автор - Pelena
Дата добавления - 10.04.2016 в 17:26
buchlotnik Дата: Воскресенье, 10.04.2016, 18:00 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Pelena, Елена, спасибо, а то на меня уже на планете ябедничают, мол "я в личку перешёл, а мне сразу не ответили"


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Воскресенье, 10.04.2016, 18:13
 
Ответить
СообщениеPelena, Елена, спасибо, а то на меня уже на планете ябедничают, мол "я в личку перешёл, а мне сразу не ответили"

Автор - buchlotnik
Дата добавления - 10.04.2016 в 18:00
Pelena Дата: Воскресенье, 10.04.2016, 18:12 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
[offtop]А у нас теперь мода пошла: чуть что не так - бегут жаловаться на Планету :D [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]А у нас теперь мода пошла: чуть что не так - бегут жаловаться на Планету :D [/offtop]

Автор - Pelena
Дата добавления - 10.04.2016 в 18:12
KuklP Дата: Воскресенье, 10.04.2016, 18:57 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1994
Репутация: 435 ±
Замечаний: 0% ±

бегут жаловаться
Пусть бегут. На Планете хитро..деланных любят так же. И форумчане те же :D


Ну, с НДС и мы чего-то стoим! kuklp@mail.ru
WM Z206653985942, R334086032478, U238399322728
 
Ответить
Сообщение
бегут жаловаться
Пусть бегут. На Планете хитро..деланных любят так же. И форумчане те же :D

Автор - KuklP
Дата добавления - 10.04.2016 в 18:57
GAPAGAPA Дата: Воскресенье, 10.04.2016, 19:24 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Теперь все работает корректно. Спасибо
 
Ответить
СообщениеТеперь все работает корректно. Спасибо

Автор - GAPAGAPA
Дата добавления - 10.04.2016 в 19:24
_Boroda_ Дата: Понедельник, 11.04.2016, 15:15 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Только заметил такую интересную тему
Еще вариант для первого файла (файл _1)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$G3;СЧЁТЗ($A$2:$A3)*ЕТЕКСТ(J3);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ($B3:$G3;$B3:$G3+СТОЛБЕЦ($B3:$G3)%%);ОТБР(СТОЛБЕЦ(B3)/2));1)/1%%+0,1);"")

И вариант для второго файла (файл _2)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$G$9;ПОИСКПОЗ($J3;$A$2:$A$9;)*ЕТЕКСТ(J3);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ($B$3:$G$9*($A$3:$A$9=$J3);$B$3:$G$9+СТОЛБЕЦ($B3:$G3)%%);ОТБР(СТОЛБЕЦ(B3)/2));1)/1%%+0,1);"")

Оба массивные (вводятся одновременным нажатием Контрл Шифт Ентер)
К сообщению приложен файл: 3045932_1.xlsx(12Kb) · 1214033_2.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТолько заметил такую интересную тему
Еще вариант для первого файла (файл _1)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$G3;СЧЁТЗ($A$2:$A3)*ЕТЕКСТ(J3);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ($B3:$G3;$B3:$G3+СТОЛБЕЦ($B3:$G3)%%);ОТБР(СТОЛБЕЦ(B3)/2));1)/1%%+0,1);"")

И вариант для второго файла (файл _2)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$G$9;ПОИСКПОЗ($J3;$A$2:$A$9;)*ЕТЕКСТ(J3);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ($B$3:$G$9*($A$3:$A$9=$J3);$B$3:$G$9+СТОЛБЕЦ($B3:$G3)%%);ОТБР(СТОЛБЕЦ(B3)/2));1)/1%%+0,1);"")

Оба массивные (вводятся одновременным нажатием Контрл Шифт Ентер)

Автор - _Boroda_
Дата добавления - 11.04.2016 в 15:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упорядочить значения в строках (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!