Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула СЧЁТЕСЛИ найти несколько значений в одной формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула СЧЁТЕСЛИ найти несколько значений в одной формуле (Формулы/Formulas)
Формула СЧЁТЕСЛИ найти несколько значений в одной формуле
mabpmabp1 Дата: Пятница, 15.04.2016, 18:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Ребята подскажите мне пожалуйста как создать такую формулу, в файле надеюсь понятно объяснил.
К сообщению приложен файл: 1-1.xlsx(12Kb)


Помогите, с формулой

Сообщение отредактировал mabpmabp1 - Пятница, 15.04.2016, 19:29
 
Ответить
СообщениеРебята подскажите мне пожалуйста как создать такую формулу, в файле надеюсь понятно объяснил.

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 18:22
Pelena Дата: Пятница, 15.04.2016, 20:25 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9849
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Нарисуйте в файле вручную, каким должен быть результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНарисуйте в файле вручную, каким должен быть результат

Автор - Pelena
Дата добавления - 15.04.2016 в 20:25
gling Дата: Пятница, 15.04.2016, 20:26 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
И Вам здравствуйте. А объединенная формула, что должна посчитать? Все 2 в столбце, 3 в столбце или 1 в столбце. При объединении получится одна формула. Объясните подробнее не ссылаясь на формулы, что Вам нужно суммировать? Не факт, что будут использованы Ваши формулы.
 
Ответить
СообщениеИ Вам здравствуйте. А объединенная формула, что должна посчитать? Все 2 в столбце, 3 в столбце или 1 в столбце. При объединении получится одна формула. Объясните подробнее не ссылаясь на формулы, что Вам нужно суммировать? Не факт, что будут использованы Ваши формулы.

Автор - gling
Дата добавления - 15.04.2016 в 20:26
mabpmabp1 Дата: Пятница, 15.04.2016, 20:30 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
gling, должна подсчитывать все вместе и 2, и3, и1


Помогите, с формулой
 
Ответить
Сообщениеgling, должна подсчитывать все вместе и 2, и3, и1

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 20:30
gling Дата: Пятница, 15.04.2016, 20:33 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Тогда может устроит
Код
=СЧЁТЕСЛИ(A1:A23;"<4")(
 
Ответить
СообщениеТогда может устроит
Код
=СЧЁТЕСЛИ(A1:A23;"<4")(

Автор - gling
Дата добавления - 15.04.2016 в 20:33
mabpmabp1 Дата: Пятница, 15.04.2016, 20:35 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena,
посмотрите, может как то так ;)
К сообщению приложен файл: 4238272.xlsx(12Kb)


Помогите, с формулой
 
Ответить
СообщениеPelena,
посмотрите, может как то так ;)

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 20:35
mabpmabp1 Дата: Пятница, 15.04.2016, 20:36 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
gling, нет, необходимо что бы основная формула работала


Помогите, с формулой
 
Ответить
Сообщениеgling, нет, необходимо что бы основная формула работала

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 20:36
Pelena Дата: Пятница, 15.04.2016, 20:40 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9849
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Я просила заполнить результат, потому что не понятен смысл задачи


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЯ просила заполнить результат, потому что не понятен смысл задачи

Автор - Pelena
Дата добавления - 15.04.2016 в 20:40
gling Дата: Пятница, 15.04.2016, 20:43 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
потому что не понятен смысл задачи
Мне тоже.
 
Ответить
Сообщение
потому что не понятен смысл задачи
Мне тоже.

Автор - gling
Дата добавления - 15.04.2016 в 20:43
mabpmabp1 Дата: Пятница, 15.04.2016, 20:51 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, :) может так
К сообщению приложен файл: 5052809.xlsx(12Kb)


Помогите, с формулой
 
Ответить
СообщениеPelena, :) может так

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 20:51
Pelena Дата: Пятница, 15.04.2016, 22:09 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9849
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Формула массива вводится нажатием клавиш Ctrl+Shift+Enter
Код
=СЧЁТЕСЛИ(A1:ИНДЕКС(A1:$A$23;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({21;22;23;11;12;13;31;32;33};A1:$A$23;);23)));"<4")
К сообщению приложен файл: 6920261.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива вводится нажатием клавиш Ctrl+Shift+Enter
Код
=СЧЁТЕСЛИ(A1:ИНДЕКС(A1:$A$23;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({21;22;23;11;12;13;31;32;33};A1:$A$23;);23)));"<4")

Автор - Pelena
Дата добавления - 15.04.2016 в 22:09
mabpmabp1 Дата: Пятница, 15.04.2016, 22:18 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, просто супер, класс, а можно еще вопросик
а вот допустим если данные в столбце читаются как текст, как тогда записать даную формулу, и в конце <4, для текста не пременить


Помогите, с формулой
 
Ответить
СообщениеPelena, просто супер, класс, а можно еще вопросик
а вот допустим если данные в столбце читаются как текст, как тогда записать даную формулу, и в конце <4, для текста не пременить

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 22:18
Pelena Дата: Пятница, 15.04.2016, 22:39 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9849
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=СУММ(СЧЁТЕСЛИ(A1:ИНДЕКС(A1:$A$23;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({21;22;23;11;12;13;31;32;33};A1:$A$23;);23)));{1;2;3}))
К сообщению приложен файл: 3385823.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММ(СЧЁТЕСЛИ(A1:ИНДЕКС(A1:$A$23;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({21;22;23;11;12;13;31;32;33};A1:$A$23;);23)));{1;2;3}))

Автор - Pelena
Дата добавления - 15.04.2016 в 22:39
mabpmabp1 Дата: Пятница, 15.04.2016, 22:51 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, На тексте не выходит, может как то столбец перевести в цифры???


Помогите, с формулой
 
Ответить
СообщениеPelena, На тексте не выходит, может как то столбец перевести в цифры???

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 22:51
mabpmabp1 Дата: Пятница, 15.04.2016, 23:05 | Сообщение № 15
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, вот у меня как получилось
Код
=СЧЁТЕСЛИ(DI10:ИНДЕКС(DI10:$DI$601;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({"*21*";"*22*";"*23*";"*11*";"*12*";"*13*";"*31*";"*32*";"*33*"};DI10:$DI$601;);601)));{"*03*";"*02*";"*01*"})
, только в конце он подсчитывает только первое значение в данном примере "*03*", а другие не видет
Как это сделать???
[moder]Оформляйте формулы тегами (кнопка fx)[/moder]


Помогите, с формулой

Сообщение отредактировал Pelena - Суббота, 16.04.2016, 07:47
 
Ответить
СообщениеPelena, вот у меня как получилось
Код
=СЧЁТЕСЛИ(DI10:ИНДЕКС(DI10:$DI$601;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({"*21*";"*22*";"*23*";"*11*";"*12*";"*13*";"*31*";"*32*";"*33*"};DI10:$DI$601;);601)));{"*03*";"*02*";"*01*"})
, только в конце он подсчитывает только первое значение в данном примере "*03*", а другие не видет
Как это сделать???
[moder]Оформляйте формулы тегами (кнопка fx)[/moder]

Автор - mabpmabp1
Дата добавления - 15.04.2016 в 23:05
Pelena Дата: Суббота, 16.04.2016, 07:47 | Сообщение № 16
Группа: Модераторы
Ранг: Экселист
Сообщений: 9849
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
На тексте не выходит

Приложите более реальный пример


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
На тексте не выходит

Приложите более реальный пример

Автор - Pelena
Дата добавления - 16.04.2016 в 07:47
mabpmabp1 Дата: Суббота, 16.04.2016, 08:25 | Сообщение № 17
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, это в принце пе и есть реальный пример. тегами не получиться надо что бы сама считала значения, а можно как то столбец который определяеться как текст, при ровнять к столбцу с цифрами???


Помогите, с формулой
 
Ответить
СообщениеPelena, это в принце пе и есть реальный пример. тегами не получиться надо что бы сама считала значения, а можно как то столбец который определяеться как текст, при ровнять к столбцу с цифрами???

Автор - mabpmabp1
Дата добавления - 16.04.2016 в 08:25
Pelena Дата: Суббота, 16.04.2016, 08:56 | Сообщение № 18
Группа: Модераторы
Ранг: Экселист
Сообщений: 9849
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
тегами не получиться

Когда пишете формулу в своём сообщении, её надо заключать в спецтеги

То есть у Вас просто числа сохранены как текст?
выделите любую пустую ячейку -- копировать -- выделите столбец -- специальная вставка -- сложить -- ОК
или формулу немного исправьте
Код
=СУММ(СЧЁТЕСЛИ(A1:ИНДЕКС(A1:A23;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({21;22;23;11;12;13;31;32;33};--A1:A23;);23)));{1;2;3}))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
тегами не получиться

Когда пишете формулу в своём сообщении, её надо заключать в спецтеги

То есть у Вас просто числа сохранены как текст?
выделите любую пустую ячейку -- копировать -- выделите столбец -- специальная вставка -- сложить -- ОК
или формулу немного исправьте
Код
=СУММ(СЧЁТЕСЛИ(A1:ИНДЕКС(A1:A23;МИН(ЕСЛИОШИБКА(ПОИСКПОЗ({21;22;23;11;12;13;31;32;33};--A1:A23;);23)));{1;2;3}))

Автор - Pelena
Дата добавления - 16.04.2016 в 08:56
mabpmabp1 Дата: Суббота, 16.04.2016, 09:04 | Сообщение № 19
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, Да просто цифры как текст..


Помогите, с формулой
 
Ответить
СообщениеPelena, Да просто цифры как текст..

Автор - mabpmabp1
Дата добавления - 16.04.2016 в 09:04
mabpmabp1 Дата: Суббота, 16.04.2016, 09:57 | Сообщение № 20
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Все работает спасибо всем!!! Вам Pelena, огромное спасибо!!!!
Тема закрыта.


Помогите, с формулой
 
Ответить
СообщениеВсе работает спасибо всем!!! Вам Pelena, огромное спасибо!!!!
Тема закрыта.

Автор - mabpmabp1
Дата добавления - 16.04.2016 в 09:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула СЧЁТЕСЛИ найти несколько значений в одной формуле (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!