Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборочное выделение повторов - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 2 из 3«123»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочное выделение повторов (Формулы/Formulas)
Выборочное выделение повторов
Palton Дата: Воскресенье, 29.05.2016, 14:00 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день Алексей,
Спасибо за Ваш ответ. Будет еще над чем разбираться дополнительно и по Вашему варианту.
Просто хотелось по СУММПРОИЗВ сначала освоиться,чего тоже пока не получается...

Относительно второго Вашего файла подумалось а возможно ли таким же способом большее количество условий задать но видно тоже чего то не так подхожу.Прилагаю файл

Спасибо огромное за помощь!
К сообщению приложен файл: 55555.xls(30Kb)
 
Ответить
СообщениеДобрый день Алексей,
Спасибо за Ваш ответ. Будет еще над чем разбираться дополнительно и по Вашему варианту.
Просто хотелось по СУММПРОИЗВ сначала освоиться,чего тоже пока не получается...

Относительно второго Вашего файла подумалось а возможно ли таким же способом большее количество условий задать но видно тоже чего то не так подхожу.Прилагаю файл

Спасибо огромное за помощь!

Автор - Palton
Дата добавления - 29.05.2016 в 14:00
AlexM Дата: Воскресенье, 29.05.2016, 14:08 | Сообщение № 22
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

При условии Должны выделяться блоки когда и OK и NO окрасить надо только блок Е, а у вас блоки А и В почему-то окрашены.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПри условии Должны выделяться блоки когда и OK и NO окрасить надо только блок Е, а у вас блоки А и В почему-то окрашены.

Автор - AlexM
Дата добавления - 29.05.2016 в 14:08
Palton Дата: Воскресенье, 29.05.2016, 14:27 | Сообщение № 23
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
AlexM, Алексей извините окраску забыл поменять по новому условию.
То есть блок выделяется при условии в его пределе всех трех: и OK и NO и YES

А у меня получается что при любых двух выделяется

Спасибо
К сообщению приложен файл: 55555.1.xls(30Kb)
 
Ответить
СообщениеAlexM, Алексей извините окраску забыл поменять по новому условию.
То есть блок выделяется при условии в его пределе всех трех: и OK и NO и YES

А у меня получается что при любых двух выделяется

Спасибо

Автор - Palton
Дата добавления - 29.05.2016 в 14:27
AlexM Дата: Воскресенье, 29.05.2016, 15:00 | Сообщение № 24
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Так?
К сообщению приложен файл: 55555.1_01.xls(30Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТак?

Автор - AlexM
Дата добавления - 29.05.2016 в 15:00
Palton Дата: Воскресенье, 29.05.2016, 15:14 | Сообщение № 25
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Да Алексей именно так.

Получается что можно добавлять столбец условие и увеличиваем > на один

Спасибо еще раз.Хорошего дня и настроения.
 
Ответить
СообщениеДа Алексей именно так.

Получается что можно добавлять столбец условие и увеличиваем > на один

Спасибо еще раз.Хорошего дня и настроения.

Автор - Palton
Дата добавления - 29.05.2016 в 15:14
Palton Дата: Воскресенье, 29.05.2016, 17:15 | Сообщение № 26
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
AlexM, Алексей сорри но опять те же грабли:
Цитата
1 Не учел что событий в блоке могут иметь место по несколько раз.


Если в каком то одном столбце имеет место больше раза вхождение,а в другом вообще пусто,то все равно происходит выделение

А необходимо только тогда,когда во всех столбцах условий имеет место событие.См.пример

Возможно как-то?
К сообщению приложен файл: 66666.xls(30Kb)
 
Ответить
СообщениеAlexM, Алексей сорри но опять те же грабли:
Цитата
1 Не учел что событий в блоке могут иметь место по несколько раз.


Если в каком то одном столбце имеет место больше раза вхождение,а в другом вообще пусто,то все равно происходит выделение

А необходимо только тогда,когда во всех столбцах условий имеет место событие.См.пример

Возможно как-то?

Автор - Palton
Дата добавления - 29.05.2016 в 17:15
AlexM Дата: Воскресенье, 29.05.2016, 17:26 | Сообщение № 27
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Так?
К сообщению приложен файл: 66666_01.xls(30Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТак?

Автор - AlexM
Дата добавления - 29.05.2016 в 17:26
Palton Дата: Воскресенье, 29.05.2016, 17:41 | Сообщение № 28
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Кстати пробовал через СУММПРОИЗВ та же ошибка
К сообщению приложен файл: 66666.1.xls(27Kb)
 
Ответить
СообщениеКстати пробовал через СУММПРОИЗВ та же ошибка

Автор - Palton
Дата добавления - 29.05.2016 в 17:41
Palton Дата: Воскресенье, 29.05.2016, 17:47 | Сообщение № 29
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Получил, спасибо
Вроде так, буду тестировать под числовые условия, потому что в формуле как я понимаю идет сцепка с текстом
 
Ответить
СообщениеПолучил, спасибо
Вроде так, буду тестировать под числовые условия, потому что в формуле как я понимаю идет сцепка с текстом

Автор - Palton
Дата добавления - 29.05.2016 в 17:47
Palton Дата: Воскресенье, 29.05.2016, 19:22 | Сообщение № 30
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Нет не выходит с числовыми условиями <_<
 
Ответить
СообщениеНет не выходит с числовыми условиями <_<

Автор - Palton
Дата добавления - 29.05.2016 в 19:22
AlexM Дата: Воскресенье, 29.05.2016, 19:26 | Сообщение № 31
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

не выходит с числовыми условиями
Это надо понимать очередные грабли.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
не выходит с числовыми условиями
Это надо понимать очередные грабли.

Автор - AlexM
Дата добавления - 29.05.2016 в 19:26
Palton Дата: Воскресенье, 29.05.2016, 19:34 | Сообщение № 32
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Да полные грабли....
Где то как бы что то ,а результата никакого.Видно не по мне это хобби...
 
Ответить
СообщениеДа полные грабли....
Где то как бы что то ,а результата никакого.Видно не по мне это хобби...

Автор - Palton
Дата добавления - 29.05.2016 в 19:34
AlexM Дата: Воскресенье, 29.05.2016, 19:45 | Сообщение № 33
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Совет. Тщательно продумайте задачу. Структура примера таблицы должна совпадать с реальной. Данные не абстрактные, а близкие к реальным, текст, числа, порядок. Об этом и в правилах форума есть.
Непродуманная задача - требует много времени, а результат ноль. :(


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеСовет. Тщательно продумайте задачу. Структура примера таблицы должна совпадать с реальной. Данные не абстрактные, а близкие к реальным, текст, числа, порядок. Об этом и в правилах форума есть.
Непродуманная задача - требует много времени, а результат ноль. :(

Автор - AlexM
Дата добавления - 29.05.2016 в 19:45
Palton Дата: Воскресенье, 29.05.2016, 20:03 | Сообщение № 34
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Алексей спасибо за совет и поддержку
Надо наверное кофейку и отвлечься а то весь азарт уходит в этом самообразовании.
А структура действительно состоит из одного числового и одного текстового условия
Просто надеялся , что у самого что то получится с числовыми . но не тут то было..
 
Ответить
СообщениеАлексей спасибо за совет и поддержку
Надо наверное кофейку и отвлечься а то весь азарт уходит в этом самообразовании.
А структура действительно состоит из одного числового и одного текстового условия
Просто надеялся , что у самого что то получится с числовыми . но не тут то было..

Автор - Palton
Дата добавления - 29.05.2016 в 20:03
Nic70y Дата: Воскресенье, 29.05.2016, 20:53 | Сообщение № 35
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3478
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Где-то я этот файл уже видел...
вариант, массивная:
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A1;ЕСЛИ((C$1:C$24<>"")*(D$1:D$24<>"");A$1:A$24);));"v";"")
или немассивная:
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*(C$1:C$24<>"")*(D$1:D$24<>"");B$1:B$24);"v";"")
К сообщению приложен файл: 66666.29.xls(29Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 29.05.2016, 20:57
 
Ответить
СообщениеГде-то я этот файл уже видел...
вариант, массивная:
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A1;ЕСЛИ((C$1:C$24<>"")*(D$1:D$24<>"");A$1:A$24);));"v";"")
или немассивная:
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*(C$1:C$24<>"")*(D$1:D$24<>"");B$1:B$24);"v";"")

Автор - Nic70y
Дата добавления - 29.05.2016 в 20:53
Palton Дата: Понедельник, 30.05.2016, 11:30 | Сообщение № 36
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Nic70y, Доброго дня Николай и всем гроссмейстерам екселя,
К сожалению ваш совет не годится потому что работает только когда построчно,а нужно когда в любой строке в пределах блока повторов событие случается
Цитата
Где-то я этот файл уже видел...

...если не затруднит хотелось бы посмотреть

Решение по этому вопросу и правильная критика были в сообщении 14 Еленой но появилась необходимость для дополнительного условия и дополнительного столбца И на этом спасибо

Еще раз приложу пример как использую по двум столбцам ,а предполагал одной формулой...

С Уважением
К сообщению приложен файл: 77777.xls(34Kb)
 
Ответить
СообщениеNic70y, Доброго дня Николай и всем гроссмейстерам екселя,
К сожалению ваш совет не годится потому что работает только когда построчно,а нужно когда в любой строке в пределах блока повторов событие случается
Цитата
Где-то я этот файл уже видел...

...если не затруднит хотелось бы посмотреть

Решение по этому вопросу и правильная критика были в сообщении 14 Еленой но появилась необходимость для дополнительного условия и дополнительного столбца И на этом спасибо

Еще раз приложу пример как использую по двум столбцам ,а предполагал одной формулой...

С Уважением

Автор - Palton
Дата добавления - 30.05.2016 в 11:30
_Boroda_ Дата: Понедельник, 30.05.2016, 11:40 | Сообщение № 37
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тему не читал, только последний пост
Так нужно?
Код
=ЕСЛИ(СЧЁТЕСЛИМН(A$1:A$24;A1;C$1:C$24;"OK")+СЧЁТЕСЛИМН(A$1:A$24;A1;D$1:D$24;">6")=2;1;"")

Для 2003
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*((C$1:C$24="OK")+(D$1:D$24>6)))=2;1;"")
К сообщению приложен файл: 77777_1.xls(34Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТему не читал, только последний пост
Так нужно?
Код
=ЕСЛИ(СЧЁТЕСЛИМН(A$1:A$24;A1;C$1:C$24;"OK")+СЧЁТЕСЛИМН(A$1:A$24;A1;D$1:D$24;">6")=2;1;"")

Для 2003
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*((C$1:C$24="OK")+(D$1:D$24>6)))=2;1;"")

Автор - _Boroda_
Дата добавления - 30.05.2016 в 11:40
Palton Дата: Понедельник, 30.05.2016, 11:55 | Сообщение № 38
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, Здравствуйте Александр!

Нет что то не так. Сразу тест : ввел условие в P2 значение 10
Т.е. для повторов В должно было выделение сняться (там 2,4,9) меньше чем 10

А выделение осталось...
 
Ответить
Сообщение_Boroda_, Здравствуйте Александр!

Нет что то не так. Сразу тест : ввел условие в P2 значение 10
Т.е. для повторов В должно было выделение сняться (там 2,4,9) меньше чем 10

А выделение осталось...

Автор - Palton
Дата добавления - 30.05.2016 в 11:55
Palton Дата: Понедельник, 30.05.2016, 11:58 | Сообщение № 39
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, Александр извините

Поспешил,не заметил что нет ссылки на ячейку , а условие прямо в формуле
Сейчас еще посмотрю...
 
Ответить
Сообщение_Boroda_, Александр извините

Поспешил,не заметил что нет ссылки на ячейку , а условие прямо в формуле
Сейчас еще посмотрю...

Автор - Palton
Дата добавления - 30.05.2016 в 11:58
_Boroda_ Дата: Понедельник, 30.05.2016, 12:00 | Сообщение № 40
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну не заметил я Вашу Р2, а прямо в формулу ввел шестерку. Замените 6 на Р2 и все хорошо будет.
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*((C$1:C$24="OK")+(D$1:D$24>P$2)))=2;1;"")

Вот так правильнее будет
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*((C$1:C$24="OK")+(D$1:D$24>P$2)))>1;1;"")


Не, тоже не то.

Вот так
Код
=ЕСЛИ((СУММПРОИЗВ((A$1:A$24=A1)*(C$1:C$24="OK"))>0)+(СУММПРОИЗВ((A$1:A$24=A1)*(D$1:D$24>O$2))>0)>1;1;"")
К сообщению приложен файл: 77777_4.xls(52Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Понедельник, 30.05.2016, 12:12
 
Ответить
СообщениеНу не заметил я Вашу Р2, а прямо в формулу ввел шестерку. Замените 6 на Р2 и все хорошо будет.
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*((C$1:C$24="OK")+(D$1:D$24>P$2)))=2;1;"")

Вот так правильнее будет
Код
=ЕСЛИ(СУММПРОИЗВ((A$1:A$24=A1)*((C$1:C$24="OK")+(D$1:D$24>P$2)))>1;1;"")


Не, тоже не то.

Вот так
Код
=ЕСЛИ((СУММПРОИЗВ((A$1:A$24=A1)*(C$1:C$24="OK"))>0)+(СУММПРОИЗВ((A$1:A$24=A1)*(D$1:D$24>O$2))>0)>1;1;"")

Автор - _Boroda_
Дата добавления - 30.05.2016 в 12:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочное выделение повторов (Формулы/Formulas)
Страница 2 из 3«123»
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!