Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор ячейки с нужным значением - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор ячейки с нужным значением (Формулы/Formulas)
Выбор ячейки с нужным значением
Dryha Дата: Пятница, 29.04.2016, 08:44 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!

Необходимо выбрать ячейку со значением "Ремонт" в строках и распределить в другую таблицу, с разбивкой по месяцам (в какой месяц и в какой год стоит ремонт).
К сообщению приложен файл: 0517715.xlsx(26Kb)
 
Ответить
СообщениеДобрый день!

Необходимо выбрать ячейку со значением "Ремонт" в строках и распределить в другую таблицу, с разбивкой по месяцам (в какой месяц и в какой год стоит ремонт).

Автор - Dryha
Дата добавления - 29.04.2016 в 08:44
Pelena Дата: Пятница, 29.04.2016, 09:16 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Если порядок номеров в первом столбце совпадает в обеих таблицах, то можно так
Код
=ЕСЛИОШИБКА(ЕСЛИ(ТЕКСТ(B$25;"ММГГ")=ТЕКСТ(ИНДЕКС($B$2:$DQ$2;ПОИСКПОЗ("Ремонт";$B4:$DQ4;0)-1);"ММГГ");"Ремонт";"");"")

Только во второй таблице вместо названий месяцев использовала даты в формате МММ
К сообщению приложен файл: 4486797.xlsx(30Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если порядок номеров в первом столбце совпадает в обеих таблицах, то можно так
Код
=ЕСЛИОШИБКА(ЕСЛИ(ТЕКСТ(B$25;"ММГГ")=ТЕКСТ(ИНДЕКС($B$2:$DQ$2;ПОИСКПОЗ("Ремонт";$B4:$DQ4;0)-1);"ММГГ");"Ремонт";"");"")

Только во второй таблице вместо названий месяцев использовала даты в формате МММ

Автор - Pelena
Дата добавления - 29.04.2016 в 09:16
Dryha Дата: Пятница, 29.04.2016, 09:20 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Pelena, Спасибо большое!!! Будем сейчас разбираться.
 
Ответить
СообщениеPelena, Спасибо большое!!! Будем сейчас разбираться.

Автор - Dryha
Дата добавления - 29.04.2016 в 09:20
китин Дата: Пятница, 29.04.2016, 09:25 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вот такая вот монструозная
Код
=ЕСЛИОШИБКА(ЕСЛИ(ТЕКСТ(ИНДЕКС($B$2:$DQ$2;;ПОИСКПОЗ("Ремонт";ИНДЕКС($B$4:$DQ$21;ПОИСКПОЗ($A26;$A$4:$A$21;0););0)-1);"МММ.ГГГГ")=ТЕКСТ(1&" "&B$25&"."&B$24;"МММ.ГГГГ");"Ремонт";"");"")

убрал объединение ячеек в строке год второй таблицы и поставил года в каждую ячейку [offtop]я кажется тоже начинаю в ТЕКСТ влюбляться :p
К сообщению приложен файл: rem.xlsx(31Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 29.04.2016, 09:32
 
Ответить
Сообщениевот такая вот монструозная
Код
=ЕСЛИОШИБКА(ЕСЛИ(ТЕКСТ(ИНДЕКС($B$2:$DQ$2;;ПОИСКПОЗ("Ремонт";ИНДЕКС($B$4:$DQ$21;ПОИСКПОЗ($A26;$A$4:$A$21;0););0)-1);"МММ.ГГГГ")=ТЕКСТ(1&" "&B$25&"."&B$24;"МММ.ГГГГ");"Ремонт";"");"")

убрал объединение ячеек в строке год второй таблицы и поставил года в каждую ячейку [offtop]я кажется тоже начинаю в ТЕКСТ влюбляться :p

Автор - китин
Дата добавления - 29.04.2016 в 09:25
_Boroda_ Дата: Пятница, 29.04.2016, 09:27 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у меня такая (файл _1)
Код
=СЧЁТЕСЛИМН($C4:$DQ4;"Ремонт";$B$2:$DP$2;КОНМЕСЯЦА(B$25&-ПРОСМОТР(;-1/$B$24:B$24;$B$24:B$24);0))
Покраска Условным форматированием, слово "Ремонт" - форматом ячейки

А если с датами в строке 25, то так можно (файл _2)
Код
=СЧЁТЕСЛИМН($C4:$DQ4;"Ремонт";$B$2:$DP$2;КОНМЕСЯЦА(B$25;0))


Обе формулы работают на несколько ремонтов в строке
К сообщению приложен файл: 0517715_1.xlsx(31Kb) · 4486797_2.xlsx(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА у меня такая (файл _1)
Код
=СЧЁТЕСЛИМН($C4:$DQ4;"Ремонт";$B$2:$DP$2;КОНМЕСЯЦА(B$25&-ПРОСМОТР(;-1/$B$24:B$24;$B$24:B$24);0))
Покраска Условным форматированием, слово "Ремонт" - форматом ячейки

А если с датами в строке 25, то так можно (файл _2)
Код
=СЧЁТЕСЛИМН($C4:$DQ4;"Ремонт";$B$2:$DP$2;КОНМЕСЯЦА(B$25;0))


Обе формулы работают на несколько ремонтов в строке

Автор - _Boroda_
Дата добавления - 29.04.2016 в 09:27
Pelena Дата: Пятница, 29.04.2016, 09:35 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё такой вариант, если ремонтов в строке может быть несколько
Формула массива
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ТЕКСТ(B$25;"ММГГ")=ТЕКСТ(ЕСЛИОШИБКА($B$2:$DP$2*("Ремонт"=$C4:$DQ4);0);"ММГГ"));"Ремонт";"");"")
К сообщению приложен файл: 2156758.xlsx(41Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё такой вариант, если ремонтов в строке может быть несколько
Формула массива
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ТЕКСТ(B$25;"ММГГ")=ТЕКСТ(ЕСЛИОШИБКА($B$2:$DP$2*("Ремонт"=$C4:$DQ4);0);"ММГГ"));"Ремонт";"");"")

Автор - Pelena
Дата добавления - 29.04.2016 в 09:35
Dryha Дата: Пятница, 29.04.2016, 09:38 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо всем огромное, буду сейчас подбирать лучший вариант!!!
 
Ответить
СообщениеСпасибо всем огромное, буду сейчас подбирать лучший вариант!!!

Автор - Dryha
Дата добавления - 29.04.2016 в 09:38
AlexM Дата: Пятница, 29.04.2016, 10:48 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

А если с датами в строке 3 и 25
Код
=ЕСЛИ(ВПР($A26;$A$4:$DQ$21;ПОИСКПОЗ(B$25;$A$3:$DQ$3;)+1;)>"z";"Ремонт";"")
Если в таблице вместо прочерка оставлять пустую ячейку, то можно убрать функцию ЕСЛИ(), а у ячеек сделать пользовательский формат тип ;;;@
К сообщению приложен файл: 0517715.xls(96Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 29.04.2016, 11:24
 
Ответить
СообщениеА если с датами в строке 3 и 25
Код
=ЕСЛИ(ВПР($A26;$A$4:$DQ$21;ПОИСКПОЗ(B$25;$A$3:$DQ$3;)+1;)>"z";"Ремонт";"")
Если в таблице вместо прочерка оставлять пустую ячейку, то можно убрать функцию ЕСЛИ(), а у ячеек сделать пользовательский формат тип ;;;@

Автор - AlexM
Дата добавления - 29.04.2016 в 10:48
Dryha Дата: Пятница, 29.04.2016, 11:31 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
AlexM, Спасибо!
 
Ответить
СообщениеAlexM, Спасибо!

Автор - Dryha
Дата добавления - 29.04.2016 в 11:31
qasder Дата: Вторник, 03.05.2016, 00:07 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Dryha, как тут все понять?
 
Ответить
СообщениеDryha, как тут все понять?

Автор - qasder
Дата добавления - 03.05.2016 в 00:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор ячейки с нужным значением (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!