Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как перемножить значения и получить список всех комбинаций? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как перемножить значения и получить список всех комбинаций? (Формулы/Formulas)
Как перемножить значения и получить список всех комбинаций?
Mikez Дата: Среда, 18.05.2016, 07:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть два столбца: список городов и список категорий.
Как сделать на отдельном листе все комбинации этих значений? По сути - перемножить.
Только чтобы город был в одной колонке, а категория во второй. Вот так:
город 1 категория1
город 1 категория2
город 1 категория3
город 2 категория1
город 2 категория2
город 2 категория3

Можно руками, но очень долго копипастить. Да и списки регулярно обновляются и каждый раз нужно получать все комбинации столбца 1 и 2.
Во вложении подопытный экземпляр. Только категорий и городов там будет больше 100 каждого.

Можно ли формулой решить?
К сообщению приложен файл: 5130783.xlsx(12Kb)
 
Ответить
СообщениеЕсть два столбца: список городов и список категорий.
Как сделать на отдельном листе все комбинации этих значений? По сути - перемножить.
Только чтобы город был в одной колонке, а категория во второй. Вот так:
город 1 категория1
город 1 категория2
город 1 категория3
город 2 категория1
город 2 категория2
город 2 категория3

Можно руками, но очень долго копипастить. Да и списки регулярно обновляются и каждый раз нужно получать все комбинации столбца 1 и 2.
Во вложении подопытный экземпляр. Только категорий и городов там будет больше 100 каждого.

Можно ли формулой решить?

Автор - Mikez
Дата добавления - 18.05.2016 в 07:21
Nic70y Дата: Среда, 18.05.2016, 07:29 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Можно ли формулой
если сильно хочется, то можно.
Код
ИНДЕКС();СТРОКА()
так нужно?
К сообщению приложен файл: 8872553.xlsx(13Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Можно ли формулой
если сильно хочется, то можно.
Код
ИНДЕКС();СТРОКА()
так нужно?

Автор - Nic70y
Дата добавления - 18.05.2016 в 07:29
китин Дата: Среда, 18.05.2016, 07:35 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в одной ячейке
Код
=ИНДЕКС('для выборки'!$A$2:$A$4;((СТРОКА(A1)-1)/СЧЁТЗ('для выборки'!B:B)-1)+2)&" "&ИНДЕКС('для выборки'!$B$2:$B$7;ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

каждое слово в ячейке
Код
=ИНДЕКС('для выборки'!$A$2:$A$4;((СТРОКА(A1)-1)/СЧЁТЗ('для выборки'!B:B)-1)+2)
и
Код
=ИНДЕКС('для выборки'!$B$2:$B$7;ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

Добавлено:
Все тоже самое только с динамическими диапазонами на Листе для выборки (можно добавлять города и организации не меняя формулы)
Код
=ИНДЕКС('для выборки'!$A$2:ИНДЕКС('для выборки'!$A:$A;СЧЁТЗ('для выборки'!$A:$A));((СТРОКА(A1)-1)/СЧЁТЗ('для выборки'!B:B)-1)+2)&" "&ИНДЕКС('для выборки'!$B$2:ИНДЕКС('для выборки'!$B:$B;СЧЁТЗ('для выборки'!$B:$B));ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

файл №2
К сообщению приложен файл: 513078.xlsx(14Kb) · 513078-2.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 18.05.2016, 07:59
 
Ответить
Сообщениев одной ячейке
Код
=ИНДЕКС('для выборки'!$A$2:$A$4;((СТРОКА(A1)-1)/СЧЁТЗ('для выборки'!B:B)-1)+2)&" "&ИНДЕКС('для выборки'!$B$2:$B$7;ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

каждое слово в ячейке
Код
=ИНДЕКС('для выборки'!$A$2:$A$4;((СТРОКА(A1)-1)/СЧЁТЗ('для выборки'!B:B)-1)+2)
и
Код
=ИНДЕКС('для выборки'!$B$2:$B$7;ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

Добавлено:
Все тоже самое только с динамическими диапазонами на Листе для выборки (можно добавлять города и организации не меняя формулы)
Код
=ИНДЕКС('для выборки'!$A$2:ИНДЕКС('для выборки'!$A:$A;СЧЁТЗ('для выборки'!$A:$A));((СТРОКА(A1)-1)/СЧЁТЗ('для выборки'!B:B)-1)+2)&" "&ИНДЕКС('для выборки'!$B$2:ИНДЕКС('для выборки'!$B:$B;СЧЁТЗ('для выборки'!$B:$B));ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

файл №2

Автор - китин
Дата добавления - 18.05.2016 в 07:35
buchlotnik Дата: Среда, 18.05.2016, 07:40 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как-то так
К сообщению приложен файл: 1583998.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениекак-то так

Автор - buchlotnik
Дата добавления - 18.05.2016 в 07:40
Mikez Дата: Среда, 18.05.2016, 07:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Благодарю! То, что нужно!
 
Ответить
СообщениеБлагодарю! То, что нужно!

Автор - Mikez
Дата добавления - 18.05.2016 в 07:54
китин Дата: Среда, 18.05.2016, 07:59 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Mikez, я в свой пост выше добавил формулу и новый файл


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеMikez, я в свой пост выше добавил формулу и новый файл

Автор - китин
Дата добавления - 18.05.2016 в 07:59
_Boroda_ Дата: Среда, 18.05.2016, 09:59 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант для
Все тоже самое только с динамическими диапазонами на Листе для выборки (можно добавлять города и организации не меняя формулы)

Код
=ИНДЕКС(A:A;(СТРОКА(C1)-1)/(СЧЁТЗ(B:B)-1)+2)&" "&ИНДЕКС(B:B;ОСТАТ(СТРОКА(C1)-1;СЧЁТЗ(B:B)-1)+2)

китин, Игорь, у тебя со скобками все так, как ты задумал?
К сообщению приложен файл: 5130783_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант для
Все тоже самое только с динамическими диапазонами на Листе для выборки (можно добавлять города и организации не меняя формулы)

Код
=ИНДЕКС(A:A;(СТРОКА(C1)-1)/(СЧЁТЗ(B:B)-1)+2)&" "&ИНДЕКС(B:B;ОСТАТ(СТРОКА(C1)-1;СЧЁТЗ(B:B)-1)+2)

китин, Игорь, у тебя со скобками все так, как ты задумал?

Автор - _Boroda_
Дата добавления - 18.05.2016 в 09:59
китин Дата: Среда, 18.05.2016, 10:14 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
со скобками все так


Да вроде бы так. Считает правильно . :'(
неправильные скобки поспешил-насмешил . так надо
Код
=ИНДЕКС('для выборки'!$A$2:ИНДЕКС('для выборки'!$A:$A;СЧЁТЗ('для выборки'!$A:$A));(СТРОКА(A1)-1)/(СЧЁТЗ('для выборки'!B:B)-1)+1)&" "&ИНДЕКС('для выборки'!$B$2:ИНДЕКС('для выборки'!$B:$B;СЧЁТЗ('для выборки'!$B:$B));ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)
К сообщению приложен файл: 513078-2-2.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 18.05.2016, 10:48
 
Ответить
Сообщение
со скобками все так


Да вроде бы так. Считает правильно . :'(
неправильные скобки поспешил-насмешил . так надо
Код
=ИНДЕКС('для выборки'!$A$2:ИНДЕКС('для выборки'!$A:$A;СЧЁТЗ('для выборки'!$A:$A));(СТРОКА(A1)-1)/(СЧЁТЗ('для выборки'!B:B)-1)+1)&" "&ИНДЕКС('для выборки'!$B$2:ИНДЕКС('для выборки'!$B:$B;СЧЁТЗ('для выборки'!$B:$B));ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('для выборки'!B:B)-1)+1)

Автор - китин
Дата добавления - 18.05.2016 в 10:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как перемножить значения и получить список всех комбинаций? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!