Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отловить одинаковые кабели(строка) и записать общею длину - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отловить одинаковые кабели(строка) и записать общею длину (Формулы/Formulas)
Отловить одинаковые кабели(строка) и записать общею длину
Yarik Дата: Вторник, 31.05.2016, 10:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте! Задано N-ое количество кабелей (N - произвольно) с тремя значением столбцов. 1 столбец содержит названия кабеля, 2-ой столбец сечение кабеля, 3-столбец длину кабеля. Необходимо отловить одинаковые названия кабелей и сечения, просуммировать их длину и записать в новой строке.
Смотрим пример в закрепленном файле
К сообщению приложен файл: 2929621.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте! Задано N-ое количество кабелей (N - произвольно) с тремя значением столбцов. 1 столбец содержит названия кабеля, 2-ой столбец сечение кабеля, 3-столбец длину кабеля. Необходимо отловить одинаковые названия кабелей и сечения, просуммировать их длину и записать в новой строке.
Смотрим пример в закрепленном файле

Автор - Yarik
Дата добавления - 31.05.2016 в 10:09
китин Дата: Вторник, 31.05.2016, 10:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну вот такой монстр выбирает уникальные (массивная)
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$34;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$3:$A$34&$B$3:$B$34;$A$3:$A$34&$B$3:$B$34;0)=СТРОКА($A$3:$A$34)-2;СТРОКА($A$3:$A$34)-2);СТРОКА(A1)));"")
а другая формула считает метраж
К сообщению приложен файл: 159951.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену вот такой монстр выбирает уникальные (массивная)
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$34;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$3:$A$34&$B$3:$B$34;$A$3:$A$34&$B$3:$B$34;0)=СТРОКА($A$3:$A$34)-2;СТРОКА($A$3:$A$34)-2);СТРОКА(A1)));"")
а другая формула считает метраж

Автор - китин
Дата добавления - 31.05.2016 в 10:16
_Boroda_ Дата: Вторник, 31.05.2016, 10:38 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А сводной таблицей не хотите? Это прямо классический пример для нее. И для больших диапазонов скорость несоизмеримо большая, нежели формулами.
В файле сделал на 9999 строк
Для обновления результата нужно топнуть правой мышой на сводную - обновить

Добавлено
А формулой можно еще так:
для типа и сечения
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ($A$3:$A$99&$B$3:$B$99;$E$2:$E3&$F$2:$F3;));A$3:A$99);"")

Для сумм
Код
=СУММЕСЛИМН(C$3:C$99;A$3:A$99;E4;B$3:B$99;F4)

Файл перевложил. Там оба варианта
К сообщению приложен файл: 2929621_2.xlsx(17Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА сводной таблицей не хотите? Это прямо классический пример для нее. И для больших диапазонов скорость несоизмеримо большая, нежели формулами.
В файле сделал на 9999 строк
Для обновления результата нужно топнуть правой мышой на сводную - обновить

Добавлено
А формулой можно еще так:
для типа и сечения
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ($A$3:$A$99&$B$3:$B$99;$E$2:$E3&$F$2:$F3;));A$3:A$99);"")

Для сумм
Код
=СУММЕСЛИМН(C$3:C$99;A$3:A$99;E4;B$3:B$99;F4)

Файл перевложил. Там оба варианта

Автор - _Boroda_
Дата добавления - 31.05.2016 в 10:38
Yarik Дата: Вторник, 07.06.2016, 15:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте!
Boroda. Мне понравилось ваш метод со сводной таблицей, все просто и удобно очень.Вот правда одна проблема появилась при создании сводной таблицы из конструкторского документа. Выделяю нужные мне столбцы, указываю куда создать сводную таблицу (или новый лист), но выдает ошибку "Недопустимая ссылка на источник данных". Как обойти этот нюанс или я где то галочку забыл поставить?
Прикладываю исходный файл.
К сообщению приложен файл: 8504388.xlsx(100Kb)
 
Ответить
СообщениеЗдравствуйте!
Boroda. Мне понравилось ваш метод со сводной таблицей, все просто и удобно очень.Вот правда одна проблема появилась при создании сводной таблицы из конструкторского документа. Выделяю нужные мне столбцы, указываю куда создать сводную таблицу (или новый лист), но выдает ошибку "Недопустимая ссылка на источник данных". Как обойти этот нюанс или я где то галочку забыл поставить?
Прикладываю исходный файл.

Автор - Yarik
Дата добавления - 07.06.2016 в 15:12
_Boroda_ Дата: Вторник, 07.06.2016, 15:43 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Выделяю нужные мне столбцы

Какие?
Обратите внимание на то, что в ПЕРВОЙ строке выделения ВСЕ ячейки должны быть заполнены
К сообщению приложен файл: 8504388_1.xlsx(94Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Выделяю нужные мне столбцы

Какие?
Обратите внимание на то, что в ПЕРВОЙ строке выделения ВСЕ ячейки должны быть заполнены

Автор - _Boroda_
Дата добавления - 07.06.2016 в 15:43
Yarik Дата: Среда, 08.06.2016, 11:37 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
При создании сводной таблицы, я выделял полностью столбцы E, F, H и создать на новый лист. И тут эта ошибка "Недопустимая ссылка на источник данных". Благодаря вашему примеру, я попробовал выделить все столбцы E, F, G, H, I со второго листа и чтоб первая строка была заполнена и вуаля сводная таблица создалась. А дальше разберусь с оформлением и прочее.
Вообщем, благодарю Вас за помощь, вы меня очень выручили :hands:
Да, выложу сюда исходник, конструкторская документация для кабельного журнала, где рамки и штампы по ГОСТу, а то я в инете ничего подходящего не нашел. сам рисовал :D
К сообщению приложен файл: 4501160.xlsx(95Kb)


Сообщение отредактировал Yarik - Среда, 08.06.2016, 11:39
 
Ответить
СообщениеПри создании сводной таблицы, я выделял полностью столбцы E, F, H и создать на новый лист. И тут эта ошибка "Недопустимая ссылка на источник данных". Благодаря вашему примеру, я попробовал выделить все столбцы E, F, G, H, I со второго листа и чтоб первая строка была заполнена и вуаля сводная таблица создалась. А дальше разберусь с оформлением и прочее.
Вообщем, благодарю Вас за помощь, вы меня очень выручили :hands:
Да, выложу сюда исходник, конструкторская документация для кабельного журнала, где рамки и штампы по ГОСТу, а то я в инете ничего подходящего не нашел. сам рисовал :D

Автор - Yarik
Дата добавления - 08.06.2016 в 11:37
Yarik Дата: Пятница, 10.06.2016, 13:38 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день!
Возник еще один вопрос. В сводной таблице хотел воспользоваться во вкладке Значения функцией произведение, но оказывается это не то что мне нужно. Мне к примеру необходимо умножить на 2-ку все столбцы Число испол. жил в сводной таблицы и вывести результат Кол. жил умноженных на 2 в сводную таблицу.
Если нельзя реализовать это в сводной таблице, то какую формулу нужно использовать?
Заранее спасибо. Исходник файла постом выше
[moder]Это уже совсем другая тема - п.4 Правил форума[/moder]


Сообщение отредактировал _Boroda_ - Пятница, 10.06.2016, 14:38
 
Ответить
СообщениеДобрый день!
Возник еще один вопрос. В сводной таблице хотел воспользоваться во вкладке Значения функцией произведение, но оказывается это не то что мне нужно. Мне к примеру необходимо умножить на 2-ку все столбцы Число испол. жил в сводной таблицы и вывести результат Кол. жил умноженных на 2 в сводную таблицу.
Если нельзя реализовать это в сводной таблице, то какую формулу нужно использовать?
Заранее спасибо. Исходник файла постом выше
[moder]Это уже совсем другая тема - п.4 Правил форума[/moder]

Автор - Yarik
Дата добавления - 10.06.2016 в 13:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отловить одинаковые кабели(строка) и записать общею длину (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!