Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать сутки и перевести в часы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать сутки и перевести в часы (Формулы/Formulas)
Суммировать сутки и перевести в часы
seldom Дата: Четверг, 08.09.2016, 15:25 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Подскажите пожалуйста, как можно просуммировать сутки с часами и перевести их в сумму часов?

Большое спасибо за Ваш ответ!
К сообщению приложен файл: 6455049.xlsx(10Kb)
 
Ответить
СообщениеДобрый день!

Подскажите пожалуйста, как можно просуммировать сутки с часами и перевести их в сумму часов?

Большое спасибо за Ваш ответ!

Автор - seldom
Дата добавления - 08.09.2016 в 15:25
Nic70y Дата: Четверг, 08.09.2016, 16:05 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(ДЕНЬ(D8:D28)*24+ЧАС(D8:D28)+МИНУТЫ(D8:D28)/60)
Код
=ЦЕЛОЕ(СУММПРОИЗВ(ДЕНЬ(D8:D28)+(ЧАС(D8:D28))/24+МИНУТЫ(D8:D28)/24/60))&ТЕКСТ(СУММПРОИЗВ(ОСТАТ(D8:D28;1));". чч:мм")
Код
=ЦЕЛОЕ(СУММПРОИЗВ(ДЕНЬ(D8:D28)+(ЧАС(D8:D28))/24+МИНУТЫ(D8:D28)/24/60))&ТЕКСТ(СУММ(D8:D28);". чч:мм")
вдруг что-то правильно.
не понятно что в рез-те должно быть.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 08.09.2016, 16:32
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ДЕНЬ(D8:D28)*24+ЧАС(D8:D28)+МИНУТЫ(D8:D28)/60)
Код
=ЦЕЛОЕ(СУММПРОИЗВ(ДЕНЬ(D8:D28)+(ЧАС(D8:D28))/24+МИНУТЫ(D8:D28)/24/60))&ТЕКСТ(СУММПРОИЗВ(ОСТАТ(D8:D28;1));". чч:мм")
Код
=ЦЕЛОЕ(СУММПРОИЗВ(ДЕНЬ(D8:D28)+(ЧАС(D8:D28))/24+МИНУТЫ(D8:D28)/24/60))&ТЕКСТ(СУММ(D8:D28);". чч:мм")
вдруг что-то правильно.
не понятно что в рез-те должно быть.

Автор - Nic70y
Дата добавления - 08.09.2016 в 16:05
buchlotnik Дата: Четверг, 08.09.2016, 16:15 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как понял
Код
=СУММПРОИЗВ(ЦЕЛОЕ(D8:D28)*24+(D8:D28-ОТБР(D8:D28)))
только у вас там в одной строке 1927 - так и задумано?
К сообщению приложен файл: 6455049-1-.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 08.09.2016, 16:15
 
Ответить
Сообщениекак понял
Код
=СУММПРОИЗВ(ЦЕЛОЕ(D8:D28)*24+(D8:D28-ОТБР(D8:D28)))
только у вас там в одной строке 1927 - так и задумано?

Автор - buchlotnik
Дата добавления - 08.09.2016 в 16:15
pabchek Дата: Четверг, 08.09.2016, 16:17 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Млин, а я с днями сделал. Правда с корректным счетом "некорректных" записей. Может пригодится? :)
(массивная)
Код
=СУММ(ДЕНЬ(ОКРУГЛ(D8:D28;5)))+ОТБР(СУММ(ОСТАТ(ОКРУГЛ(D8:D28;5);1)))&"."&ТЕКСТ(ОСТАТ(СУММ(ОСТАТ(ОКРУГЛ(D8:D28;5);1));1);"чч:мм")


Добавил
А если просто часы, то (тоже массивная)
Код
=СУММ(ДЕНЬ(ОКРУГЛ(D8:D28;5)))+СУММ(ОСТАТ(ОКРУГЛ(D8:D28;5);1))
К сообщению приложен файл: 6320711.xlsx(9Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 08.09.2016, 16:27
 
Ответить
СообщениеМлин, а я с днями сделал. Правда с корректным счетом "некорректных" записей. Может пригодится? :)
(массивная)
Код
=СУММ(ДЕНЬ(ОКРУГЛ(D8:D28;5)))+ОТБР(СУММ(ОСТАТ(ОКРУГЛ(D8:D28;5);1)))&"."&ТЕКСТ(ОСТАТ(СУММ(ОСТАТ(ОКРУГЛ(D8:D28;5);1));1);"чч:мм")


Добавил
А если просто часы, то (тоже массивная)
Код
=СУММ(ДЕНЬ(ОКРУГЛ(D8:D28;5)))+СУММ(ОСТАТ(ОКРУГЛ(D8:D28;5);1))

Автор - pabchek
Дата добавления - 08.09.2016 в 16:17
Nic70y Дата: Четверг, 08.09.2016, 16:25 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
в одной строке 1927
там еще 11.12.1900


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
в одной строке 1927
там еще 11.12.1900

Автор - Nic70y
Дата добавления - 08.09.2016 в 16:25
buchlotnik Дата: Четверг, 08.09.2016, 16:26 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
там еще
проглядел. Ждём ответа ТС


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
там еще
проглядел. Ждём ответа ТС

Автор - buchlotnik
Дата добавления - 08.09.2016 в 16:26
_Boroda_ Дата: Четверг, 08.09.2016, 21:17 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если не обращать внимания на месяцы и годы, то так можно
Код
=СУММПРОИЗВ(("1900/1/"&ТЕКСТ(D8:D28+1;"Д ч:м"))-1)
К сообщению приложен файл: 6455049_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли не обращать внимания на месяцы и годы, то так можно
Код
=СУММПРОИЗВ(("1900/1/"&ТЕКСТ(D8:D28+1;"Д ч:м"))-1)

Автор - _Boroda_
Дата добавления - 08.09.2016 в 21:17
seldom Дата: Пятница, 09.09.2016, 15:23 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Большое спасибо за грамотные решения! Очень помогли!
 
Ответить
СообщениеБольшое спасибо за грамотные решения! Очень помогли!

Автор - seldom
Дата добавления - 09.09.2016 в 15:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать сутки и перевести в часы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!