Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Транспонирование с шагом. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонирование с шагом. (Формулы/Formulas)
Транспонирование с шагом.
cth Дата: Понедельник, 12.09.2016, 09:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Приветствую уважаемые форумчане! Помогите с преобразованием таблицы, есть строка, в ней однотипные данные расположены с определенным шагом, чередуются через один или два столбца, нужно выстроить эти данные в таблицу заданного вида. Такое сложное транспонирование получается с шагом.
К сообщению приложен файл: 9172956.xlsx(9Kb)


Сообщение отредактировал cth - Понедельник, 12.09.2016, 09:18
 
Ответить
СообщениеПриветствую уважаемые форумчане! Помогите с преобразованием таблицы, есть строка, в ней однотипные данные расположены с определенным шагом, чередуются через один или два столбца, нужно выстроить эти данные в таблицу заданного вида. Такое сложное транспонирование получается с шагом.

Автор - cth
Дата добавления - 12.09.2016 в 09:17
китин Дата: Понедельник, 12.09.2016, 09:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам не хворать. может так?
Код
=ИНДЕКС($A$3:$L$3;ОСТАТ(СТОЛБЕЦ(A1)-1;3)+(СТРОКА(A1)-1)*3+1)
К сообщению приложен файл: 111111.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 12.09.2016, 09:37
 
Ответить
СообщениеИ вам не хворать. может так?
Код
=ИНДЕКС($A$3:$L$3;ОСТАТ(СТОЛБЕЦ(A1)-1;3)+(СТРОКА(A1)-1)*3+1)

Автор - китин
Дата добавления - 12.09.2016 в 09:35
Nic70y Дата: Понедельник, 12.09.2016, 09:37 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
с доп. пустой строкой
Код
=ИНДЕКС($A$3:$L$3;СЧЁТЗ($A$6:$C6)+СТОЛБЕЦ())
К сообщению приложен файл: 3696168.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениес доп. пустой строкой
Код
=ИНДЕКС($A$3:$L$3;СЧЁТЗ($A$6:$C6)+СТОЛБЕЦ())

Автор - Nic70y
Дата добавления - 12.09.2016 в 09:37
buchlotnik Дата: Понедельник, 12.09.2016, 10:10 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
или так:
Код
=ИНДЕКС($A$3:$L$3;(СТРОКА(A1)-1)*3+СТОЛБЕЦ(A1))
Код
=ИНДЕКС($A$15:$H$15;(СТРОКА(A1)-1)*2+СТОЛБЕЦ(A1))
К сообщению приложен файл: 2249587.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеили так:
Код
=ИНДЕКС($A$3:$L$3;(СТРОКА(A1)-1)*3+СТОЛБЕЦ(A1))
Код
=ИНДЕКС($A$15:$H$15;(СТРОКА(A1)-1)*2+СТОЛБЕЦ(A1))

Автор - buchlotnik
Дата добавления - 12.09.2016 в 10:10
cth Дата: Понедельник, 12.09.2016, 19:52 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, воспользовался вашим вариантом. Благодарю всех за ответы!
 
Ответить
СообщениеNic70y, воспользовался вашим вариантом. Благодарю всех за ответы!

Автор - cth
Дата добавления - 12.09.2016 в 19:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонирование с шагом. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!