Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отдельные даты объединить в периоды с суммированием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отдельные даты объединить в периоды с суммированием (Формулы/Formulas)
Отдельные даты объединить в периоды с суммированием
AVI Дата: Среда, 28.09.2016, 08:51 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Пришел сюда с очередной просьбой.
Формируется отчет (столбцы с A по F). В столбец "G" формулами подтягиваются отчетные точки. Эти точки это последний день в периоде.
Вопрос в формировании столбцов H, I, J. На данный момент у меня с помощью большого количества вспомогательных столбцов формируются столбцы H, I, J. Столбцов там реально много. Подскажите функцию (и если можно формулу) которая бы могла мне помочь упростить формирование данных столбцов.
В приложеном файле цветами выделено для наглядности. Надеюсь, что понято описал проблему.
К сообщению приложен файл: groop.xlsx(14Kb)
 
Ответить
СообщениеДобрый день!
Пришел сюда с очередной просьбой.
Формируется отчет (столбцы с A по F). В столбец "G" формулами подтягиваются отчетные точки. Эти точки это последний день в периоде.
Вопрос в формировании столбцов H, I, J. На данный момент у меня с помощью большого количества вспомогательных столбцов формируются столбцы H, I, J. Столбцов там реально много. Подскажите функцию (и если можно формулу) которая бы могла мне помочь упростить формирование данных столбцов.
В приложеном файле цветами выделено для наглядности. Надеюсь, что понято описал проблему.

Автор - AVI
Дата добавления - 28.09.2016 в 08:51
TimSha Дата: Среда, 28.09.2016, 09:20 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 456
Репутация: 73 ±
Замечаний: 0% ±

Excel 2013 Pro +
Вариант, т.к. логики в определении периодов не понял... ;)
Код
=СУММЕСЛИМН($F$2:$F$84;$A$2:$A$84;">="&A2;$A$2:$A$84;"<="&A21)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

Сообщение отредактировал TimSha - Среда, 28.09.2016, 09:21
 
Ответить
СообщениеВариант, т.к. логики в определении периодов не понял... ;)
Код
=СУММЕСЛИМН($F$2:$F$84;$A$2:$A$84;">="&A2;$A$2:$A$84;"<="&A21)

Автор - TimSha
Дата добавления - 28.09.2016 в 09:20
AVI Дата: Среда, 28.09.2016, 09:36 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
TimSha, периоды определяются сложно. В столбец G попадает момент когда заканчивается очередной период, то есть после этой единицы начинается уже следующий период.
 
Ответить
СообщениеTimSha, периоды определяются сложно. В столбец G попадает момент когда заканчивается очередной период, то есть после этой единицы начинается уже следующий период.

Автор - AVI
Дата добавления - 28.09.2016 в 09:36
_Boroda_ Дата: Среда, 28.09.2016, 09:58 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(G2;ТЕКСТ(ПРОСМОТР(;-1/(G$1:G1<>"");A$2:A2);"[$-FC19]\c Д ММММ ГГГГ \г\.")&ТЕКСТ(A2;"[$-FC19] по Д ММММ ГГГГ \г\.");"")

Код
=ЕСЛИ($G2;СУММ(E$1:E2)-СУММ(I$1:I1);"")

Код
=ЕСЛИ($G2;СЧЁТ(F$1:F2)-СУММ(J$1:J1);"")


Ну и формулы в столбцах Р:R Вам переписал
К сообщению приложен файл: groop_1.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(G2;ТЕКСТ(ПРОСМОТР(;-1/(G$1:G1<>"");A$2:A2);"[$-FC19]\c Д ММММ ГГГГ \г\.")&ТЕКСТ(A2;"[$-FC19] по Д ММММ ГГГГ \г\.");"")

Код
=ЕСЛИ($G2;СУММ(E$1:E2)-СУММ(I$1:I1);"")

Код
=ЕСЛИ($G2;СЧЁТ(F$1:F2)-СУММ(J$1:J1);"")


Ну и формулы в столбцах Р:R Вам переписал

Автор - _Boroda_
Дата добавления - 28.09.2016 в 09:58
buchlotnik Дата: Среда, 28.09.2016, 09:59 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
период:
Код
=IF(G21;"с "&TEXT(LOOKUP(2;$G$1:G20;$A$2:A21);"[$-x-sysdate]ДДДД, ММММ ДД, ГГГГ")&" по "&TEXT(A21;"[$-x-sysdate]ДДДД, ММММ ДД, ГГГГ");"")
количество:
Код
=IF(G21;ROW()-LOOKUP(2;$G$1:G20;ROW($A$1:A20));"")
сумма:
Код
=IF(G21;IFERROR(F21-LOOKUP(2;$G$1:G20;$F$1:F20);F21);"")
К сообщению приложен файл: 1902350.xlsx(19Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 28.09.2016, 10:00
 
Ответить
Сообщениепериод:
Код
=IF(G21;"с "&TEXT(LOOKUP(2;$G$1:G20;$A$2:A21);"[$-x-sysdate]ДДДД, ММММ ДД, ГГГГ")&" по "&TEXT(A21;"[$-x-sysdate]ДДДД, ММММ ДД, ГГГГ");"")
количество:
Код
=IF(G21;ROW()-LOOKUP(2;$G$1:G20;ROW($A$1:A20));"")
сумма:
Код
=IF(G21;IFERROR(F21-LOOKUP(2;$G$1:G20;$F$1:F20);F21);"")

Автор - buchlotnik
Дата добавления - 28.09.2016 в 09:59
AVI Дата: Среда, 28.09.2016, 10:26 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Спасибо! Опять это конструкция с
Код
...ПРОСМОТР(;-1/..
.
Никак она мне не дается.

Спасибо за помощь. Работает на раз-два.
И за массив спасибо. Мой массив был сильно массивным массивом

buchlotnik, спасибо за вариант, нужно осваивать
Код
Просмотр


Сообщение отредактировал AVI - Среда, 28.09.2016, 10:32
 
Ответить
Сообщение_Boroda_, Спасибо! Опять это конструкция с
Код
...ПРОСМОТР(;-1/..
.
Никак она мне не дается.

Спасибо за помощь. Работает на раз-два.
И за массив спасибо. Мой массив был сильно массивным массивом

buchlotnik, спасибо за вариант, нужно осваивать
Код
Просмотр

Автор - AVI
Дата добавления - 28.09.2016 в 10:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отдельные даты объединить в периоды с суммированием (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!