Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнения поля при разных условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнения поля при разных условиях (Формулы/Formulas)
Автоматическое заполнения поля при разных условиях
Lexa__88 Дата: Четверг, 29.09.2016, 23:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Всем доброе время суток.
У меня появилось потребность, чтобы в ячейке (Статус пошлины) автоматически заполнялось либо "Учтена", либо "Не учтена". Условия таковы, по умолчанию пошлина при оплате всегда учтена. В случае получения письма о том, что пошлина не зачислена, статус должен поменяться на "Не учтена".
В примере я попытался решить эту задачу, но сработало на половину. И столкнулся с тем, как лучше заполнить ячейки, так как в моем варианте, пришлось бы редактировать каждую строчку отдельно, т.е. не получается применить формулу для всего столбца.
Задание спасибо!
К сообщению приложен файл: 7977673.xlsx(46Kb)
 
Ответить
СообщениеВсем доброе время суток.
У меня появилось потребность, чтобы в ячейке (Статус пошлины) автоматически заполнялось либо "Учтена", либо "Не учтена". Условия таковы, по умолчанию пошлина при оплате всегда учтена. В случае получения письма о том, что пошлина не зачислена, статус должен поменяться на "Не учтена".
В примере я попытался решить эту задачу, но сработало на половину. И столкнулся с тем, как лучше заполнить ячейки, так как в моем варианте, пришлось бы редактировать каждую строчку отдельно, т.е. не получается применить формулу для всего столбца.
Задание спасибо!

Автор - Lexa__88
Дата добавления - 29.09.2016 в 23:48
Karataev Дата: Пятница, 30.09.2016, 00:00 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Логику до конца не понял (почему одна ячейка F8" для всех данных), может такая формула подойдет (для "C2"):
Код
=ЕСЛИ(НЕ(ЕОШ(ПОИСК("№";B2)));"Учтена";ЕСЛИ(НЕ(ЕОШ(ПОИСК("Письмо о не зачете пошлины за 3-й год";$F$8)));"Не учтена";""))




Сообщение отредактировал Karataev - Пятница, 30.09.2016, 00:01
 
Ответить
СообщениеЛогику до конца не понял (почему одна ячейка F8" для всех данных), может такая формула подойдет (для "C2"):
Код
=ЕСЛИ(НЕ(ЕОШ(ПОИСК("№";B2)));"Учтена";ЕСЛИ(НЕ(ЕОШ(ПОИСК("Письмо о не зачете пошлины за 3-й год";$F$8)));"Не учтена";""))

Автор - Karataev
Дата добавления - 30.09.2016 в 00:00
buchlotnik Дата: Пятница, 30.09.2016, 09:11 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=IF(OR([@[Платежный документ]]="";IFERROR(MATCH("*"&[@Пошлина];Table1[Наименование];0);0));"Не учтена";"Учтена")
или по сути то же самое
Код
=IF(AND([@[Платежный документ]]<>"";ISERROR(MATCH("*"&[@Пошлина];Table1[Наименование];0)));"Учтена";"Не учтена")
К сообщению приложен файл: 0079088.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 30.09.2016, 09:15
 
Ответить
Сообщениетак нужно?
Код
=IF(OR([@[Платежный документ]]="";IFERROR(MATCH("*"&[@Пошлина];Table1[Наименование];0);0));"Не учтена";"Учтена")
или по сути то же самое
Код
=IF(AND([@[Платежный документ]]<>"";ISERROR(MATCH("*"&[@Пошлина];Table1[Наименование];0)));"Учтена";"Не учтена")

Автор - buchlotnik
Дата добавления - 30.09.2016 в 09:11
Lexa__88 Дата: Пятница, 30.09.2016, 13:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Buchlotnik, спасибо. Но столкнулся с тем, что когда формулу вставлял свой рабочий документ. Статус некоторых пошлин поменялась на "Не учтена". Формула не учитывает, что есть письмо о зачете пошлины за n-й год, следовательно пошлина учтена, по статус стоит "Не учтена". У меня вопрос, возможно ли применить и это условие?
К сообщению приложен файл: 6256560.xlsx(46Kb)
 
Ответить
СообщениеBuchlotnik, спасибо. Но столкнулся с тем, что когда формулу вставлял свой рабочий документ. Статус некоторых пошлин поменялась на "Не учтена". Формула не учитывает, что есть письмо о зачете пошлины за n-й год, следовательно пошлина учтена, по статус стоит "Не учтена". У меня вопрос, возможно ли применить и это условие?

Автор - Lexa__88
Дата добавления - 30.09.2016 в 13:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнения поля при разных условиях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!