Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выбор и перенос строк на другой лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор и перенос строк на другой лист (Формулы/Formulas)
выбор и перенос строк на другой лист
Алла2003 Дата: Пятница, 16.06.2017, 14:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Помогите, пожалуйста, не могу разобраться!
Необходимо из одного листа (тарификационного списка сотрудников) выбрать на другой лист тех сотрудников, которые получают зарплату ниже МРОТ (столбец Р (35)-доплата до МРОТ, т.е. он если больше 0, то перенести сотрудника на другой лист), причем не полностью строки, а выборочные сведения (ФИО, должность, сумма доплаты до МРОТ) с сохранением порядка строк.
Или хотя бы полностью строки (но в том же порядке как на исходном листе), а я уже потом из них перенесу в нужный лист выборочные сведения.
Заранее спасибо! Извините, если коряво объяснила.
Файл прилагаю.
К сообщению приложен файл: 5886841.xls(88Kb)
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста, не могу разобраться!
Необходимо из одного листа (тарификационного списка сотрудников) выбрать на другой лист тех сотрудников, которые получают зарплату ниже МРОТ (столбец Р (35)-доплата до МРОТ, т.е. он если больше 0, то перенести сотрудника на другой лист), причем не полностью строки, а выборочные сведения (ФИО, должность, сумма доплаты до МРОТ) с сохранением порядка строк.
Или хотя бы полностью строки (но в том же порядке как на исходном листе), а я уже потом из них перенесу в нужный лист выборочные сведения.
Заранее спасибо! Извините, если коряво объяснила.
Файл прилагаю.

Автор - Алла2003
Дата добавления - 16.06.2017 в 14:36
sboy Дата: Пятница, 16.06.2017, 15:31 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1105
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
как вариант каждое отделение на своем листе, а оттуда руками значения переносить
К сообщению приложен файл: 5886841.xlsx(36Kb)
 
Ответить
СообщениеДобрый день.
как вариант каждое отделение на своем листе, а оттуда руками значения переносить

Автор - sboy
Дата добавления - 16.06.2017 в 15:31
gling Дата: Пятница, 16.06.2017, 22:46 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1656
Репутация: 403 ±
Замечаний: 0% ±

2010
Здравствуйте. Вариант формул
Код
=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")
Excel 2013 их поймет, но если этот файл с другого компа где Excel 2003, формулу нужно немного переделать и она удлинится, или убрать исключение ошибки.Так
Код
=ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СУММПРОИЗВ((Спец!$L$19:$L$98<Спец!$O$14)*(Спец!$L$19:$L$98>0))+1-СТРОКА(B1))))
Хотя, не знаю в 2003, НАИБОЛЬШИЙ() есть или нет?
К сообщению приложен файл: 9546318.xlsx(32Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 16.06.2017, 22:47
 
Ответить
СообщениеЗдравствуйте. Вариант формул
Код
=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")
Excel 2013 их поймет, но если этот файл с другого компа где Excel 2003, формулу нужно немного переделать и она удлинится, или убрать исключение ошибки.Так
Код
=ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СУММПРОИЗВ((Спец!$L$19:$L$98<Спец!$O$14)*(Спец!$L$19:$L$98>0))+1-СТРОКА(B1))))
Хотя, не знаю в 2003, НАИБОЛЬШИЙ() есть или нет?

Автор - gling
Дата добавления - 16.06.2017 в 22:46
Алла2003 Дата: Понедельник, 19.06.2017, 10:10 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
как вариант каждое отделение на своем листе, а оттуда руками значения переносить

Спасибо, что откликнулись! Но у меня много подразделений, и другие листы с расчетами полетят.
 
Ответить
Сообщение
Добрый день.
как вариант каждое отделение на своем листе, а оттуда руками значения переносить

Спасибо, что откликнулись! Но у меня много подразделений, и другие листы с расчетами полетят.

Автор - Алла2003
Дата добавления - 19.06.2017 в 10:10
Алла2003 Дата: Понедельник, 19.06.2017, 10:15 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Вариант формул

=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")
Excel 2013 их поймет

Спасибо! В листе "Спец" добавила столбик с наименование подразделений, как Вы. А в другой лист перенесла формулы, подставила свои наименования столбцов-строк-массивов (так как в примере многое удалила) и почему-то пустые ячейки становятся :( пример не могу отправить (большой размер получается)
 
Ответить
Сообщение
Здравствуйте. Вариант формул

=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")
Excel 2013 их поймет

Спасибо! В листе "Спец" добавила столбик с наименование подразделений, как Вы. А в другой лист перенесла формулы, подставила свои наименования столбцов-строк-массивов (так как в примере многое удалила) и почему-то пустые ячейки становятся :( пример не могу отправить (большой размер получается)

Автор - Алла2003
Дата добавления - 19.06.2017 в 10:15
Алла2003 Дата: Понедельник, 19.06.2017, 10:25 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Вариант формул

=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")

Попробовала изменить формулы начало с 19 строки (как было в примере, так и оставила) по 900 (это у меня столько строк, и так не работает) на меньшее количество строк, например до 90-той строки ставлю, то все работает. Простите за такой неумный вопрос, но может дело в том, что для такой формулы 900 строк много?
 
Ответить
Сообщение
Здравствуйте. Вариант формул

=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")

Попробовала изменить формулы начало с 19 строки (как было в примере, так и оставила) по 900 (это у меня столько строк, и так не работает) на меньшее количество строк, например до 90-той строки ставлю, то все работает. Простите за такой неумный вопрос, но может дело в том, что для такой формулы 900 строк много?

Автор - Алла2003
Дата добавления - 19.06.2017 в 10:25
Pelena Дата: Понедельник, 19.06.2017, 11:02 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11756
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Покажите свою измененную формулу


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПокажите свою измененную формулу

Автор - Pelena
Дата добавления - 19.06.2017 в 11:02
Алла2003 Дата: Понедельник, 19.06.2017, 11:03 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Вариант формул

=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")

hands Работают формулы! Даже до 900 заработали (не знаю из-за чего). Только эти формулы не учитывают, что работая на 0,5 ставки или на 0,25 размер МРОТа уменьшается в два или четыре раза, а по формулам выбирает ВСЕХ у кого зарплата меньше 7800. Можно как-нибудь учесть и этот момент в формуле. Помогите, пожалуйста!
 
Ответить
Сообщение
Здравствуйте. Вариант формул

=ЕСЛИОШИБКА(ИНДЕКС(Спец!C:C;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$L$19:$L$98>0)*(Спец!$L$19:$L$98<Спец!$O$14)*СТРОКА(Спец!$O$19:$O$98);СЧЁТЕСЛИМН(Спец!$L$19:$L$98;"<"&Спец!$O$14;Спец!$L$19:$L$98;">0")+1-СТРОКА(B1))));"")

hands Работают формулы! Даже до 900 заработали (не знаю из-за чего). Только эти формулы не учитывают, что работая на 0,5 ставки или на 0,25 размер МРОТа уменьшается в два или четыре раза, а по формулам выбирает ВСЕХ у кого зарплата меньше 7800. Можно как-нибудь учесть и этот момент в формуле. Помогите, пожалуйста!

Автор - Алла2003
Дата добавления - 19.06.2017 в 11:03
Алла2003 Дата: Понедельник, 19.06.2017, 11:05 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Покажите свою измененную формулу

Код
=ЕСЛИОШИБКА(ИНДЕКС(Спец!CE:CE;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$AJ$19:$AJ$760>0)*(Спец!$AJ$19:$AJ$760<Спец!$AM$14)*СТРОКА(Спец!$AM$19:$AM$760);СЧЁТЕСЛИМН(Спец!$AJ$19:$AJ$760;"<"&Спец!$AM$14;Спец!$AJ$19:$AJ$760;">0")+1-СТРОКА(A2))));"")


Это работает, спасибо!


Сообщение отредактировал Алла2003 - Понедельник, 19.06.2017, 11:15
 
Ответить
Сообщение
Покажите свою измененную формулу

Код
=ЕСЛИОШИБКА(ИНДЕКС(Спец!CE:CE;СУММПРОИЗВ(НАИБОЛЬШИЙ((Спец!$AJ$19:$AJ$760>0)*(Спец!$AJ$19:$AJ$760<Спец!$AM$14)*СТРОКА(Спец!$AM$19:$AM$760);СЧЁТЕСЛИМН(Спец!$AJ$19:$AJ$760;"<"&Спец!$AM$14;Спец!$AJ$19:$AJ$760;">0")+1-СТРОКА(A2))));"")


Это работает, спасибо!

Автор - Алла2003
Дата добавления - 19.06.2017 в 11:05
Manyasha Дата: Понедельник, 19.06.2017, 11:11 | Сообщение № 10
Группа: Модераторы
Ранг: Старожил
Сообщений: 2008
Репутация: 837 ±
Замечаний: 0% ±

Excel 2010, 2016
Алла2003, формулы нужно оформлять тегами, об этом есть в Правилах. Исправьте свой последний пост (кнопка для формул - fx).


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеАлла2003, формулы нужно оформлять тегами, об этом есть в Правилах. Исправьте свой последний пост (кнопка для формул - fx).

Автор - Manyasha
Дата добавления - 19.06.2017 в 11:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор и перенос строк на другой лист (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!