Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск соседнего значения при неполном соответствии ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск соседнего значения при неполном соответствии ячеек (Формулы/Formulas)
Поиск соседнего значения при неполном соответствии ячеек
РоманМ Дата: Пятница, 28.07.2017, 05:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.

С одной стороны есть столбцы: D "полное наименование товара" и E "код товара".
С другой стороны необходимо подставить в стобец B "код товара", если известен столбец A "артикул товара".

Похожих решений много, но ни одно так и не сработало, в том числе из-за того, что "артикул" состоит из букв и цифр одновременно.
Перепробовал разные ВПР, ИНДЕКС, ПОИСК, fuzzy lookup по аналогичным образцам - ничего не получилось.

Хотелось бы решения с помощью функции, чтобы в дальнейшем ее можно было повторить в Гугл таблице.

Помогите, пожалуйста.
К сообщению приложен файл: 9857050.xls(20Kb)


Сообщение отредактировал РоманМ - Пятница, 28.07.2017, 05:49
 
Ответить
СообщениеЗдравствуйте.

С одной стороны есть столбцы: D "полное наименование товара" и E "код товара".
С другой стороны необходимо подставить в стобец B "код товара", если известен столбец A "артикул товара".

Похожих решений много, но ни одно так и не сработало, в том числе из-за того, что "артикул" состоит из букв и цифр одновременно.
Перепробовал разные ВПР, ИНДЕКС, ПОИСК, fuzzy lookup по аналогичным образцам - ничего не получилось.

Хотелось бы решения с помощью функции, чтобы в дальнейшем ее можно было повторить в Гугл таблице.

Помогите, пожалуйста.

Автор - РоманМ
Дата добавления - 28.07.2017 в 05:43
AndreTM Дата: Пятница, 28.07.2017, 07:21 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
...
(извиняюсь, что-то я не туда смотрел... бессонная ночь...) :)


Skype: andre.tm.007
Donate: Qiwi: 9517375010


Сообщение отредактировал AndreTM - Пятница, 28.07.2017, 09:45
 
Ответить
Сообщение...
(извиняюсь, что-то я не туда смотрел... бессонная ночь...) :)

Автор - AndreTM
Дата добавления - 28.07.2017 в 07:21
sboy Дата: Пятница, 28.07.2017, 09:06 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1014
Репутация: 255 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Для файла примера работает, но надо проверять на реальных данных
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(A2;$D$2:$D$6))*$E$2:$E$6)
К сообщению приложен файл: 2230392.xls(27Kb)
 
Ответить
СообщениеДобрый день.
Для файла примера работает, но надо проверять на реальных данных
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(A2;$D$2:$D$6))*$E$2:$E$6)

Автор - sboy
Дата добавления - 28.07.2017 в 09:06
buchlotnik Дата: Пятница, 28.07.2017, 09:08 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Как-то так, но это формула массива - под гуглы придётся адаптировать
Код
=ПРОСМОТР(;-ПОИСК(A2;$D$2:$D$6);$E$2:$E$6)


[p.s.] AndreTM, вообще-то артикул есть в полном описании ;)
К сообщению приложен файл: 7492368.xls(26Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеКак-то так, но это формула массива - под гуглы придётся адаптировать
Код
=ПРОСМОТР(;-ПОИСК(A2;$D$2:$D$6);$E$2:$E$6)


[p.s.] AndreTM, вообще-то артикул есть в полном описании ;)

Автор - buchlotnik
Дата добавления - 28.07.2017 в 09:08
_Boroda_ Дата: Пятница, 28.07.2017, 09:29 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=ВПР("*"&A2&"*";D$2:E$99;2;)

Код
=СУММЕСЛИ($D$2:$D$99;"*"&A2&"*";E$2:E$99)
К сообщению приложен файл: 9857050_1.xls(26Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=ВПР("*"&A2&"*";D$2:E$99;2;)

Код
=СУММЕСЛИ($D$2:$D$99;"*"&A2&"*";E$2:E$99)

Автор - _Boroda_
Дата добавления - 28.07.2017 в 09:29
РоманМ Дата: Пятница, 28.07.2017, 19:13 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное всем! Все варианты проверил.
На 32 тыс строках вариант sboy не захотел работать.
Остальные работают. Буду сравнивать и выбирать по скорости.

Еще раз спасибо. Избавили от очередной бессонной ночи, а она тут видимо не у меня одного ;)
 
Ответить
СообщениеСпасибо огромное всем! Все варианты проверил.
На 32 тыс строках вариант sboy не захотел работать.
Остальные работают. Буду сравнивать и выбирать по скорости.

Еще раз спасибо. Избавили от очередной бессонной ночи, а она тут видимо не у меня одного ;)

Автор - РоманМ
Дата добавления - 28.07.2017 в 19:13
Che79 Дата: Пятница, 28.07.2017, 19:43 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 541
Репутация: 95 ±
Замечаний: 0% ±

Excel 2010 RUS
Ещё вариант, пусть тоже будет. Но не очень шустрый на больших массивах
Код
=ИНДЕКС($F$2:$F$6;ПОИСКПОЗ("*"&A2&"*";$E$2:$E$6;))
К сообщению приложен файл: 9857050_2.xls(27Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 28.07.2017, 20:12
 
Ответить
СообщениеЕщё вариант, пусть тоже будет. Но не очень шустрый на больших массивах
Код
=ИНДЕКС($F$2:$F$6;ПОИСКПОЗ("*"&A2&"*";$E$2:$E$6;))

Автор - Che79
Дата добавления - 28.07.2017 в 19:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск соседнего значения при неполном соответствии ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!