Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/создание динамического диапазона с поиском уникальных значен - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создание динамического диапазона с поиском уникальных значен (Формулы/Formulas)
создание динамического диапазона с поиском уникальных значен
RAMH Дата: Понедельник, 09.10.2017, 08:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, форумчане.
Прошу помочь или направить в нужное русло в решении моего вопроса.
Суть следующая имеются два листа. На первом каждый день заносятся данные в соответствующие столбцы. На втором листе происходит группировка уникальных значений с подсчетом количества повторений.
Вопрос: как изменить формулу на втором листе в столбце А так, что бы диапазон изменялся динамически?
Пробовал использовать "диспетчер имен" используя формулы, взятые из темы ссылка
К сообщению приложен файл: 5607955.xlsx(12Kb)
 
Ответить
СообщениеДобрый день, форумчане.
Прошу помочь или направить в нужное русло в решении моего вопроса.
Суть следующая имеются два листа. На первом каждый день заносятся данные в соответствующие столбцы. На втором листе происходит группировка уникальных значений с подсчетом количества повторений.
Вопрос: как изменить формулу на втором листе в столбце А так, что бы диапазон изменялся динамически?
Пробовал использовать "диспетчер имен" используя формулы, взятые из темы ссылка

Автор - RAMH
Дата добавления - 09.10.2017 в 08:00
Pelena Дата: Понедельник, 09.10.2017, 08:25 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11840
Репутация: 2608 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
В файле три варианте решения:
с именованным динамическим диапазоном (желтые ячейки)
с использованием Умной таблицы (Лист1(2) и зеленые ячейки)
с использованием сводной таблицы (в качестве источника тоже Умная таблица с листа Лист1(2))
[p.s.]Не заметила сразу, что вопрос в разделе Google Docs. Ответ нужен именно для Google Docs или всё же для Excel?[/p.s.]
К сообщению приложен файл: 7946326.xlsx(20Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816


Сообщение отредактировал Pelena - Понедельник, 09.10.2017, 08:28
 
Ответить
СообщениеЗдравствуйте.
В файле три варианте решения:
с именованным динамическим диапазоном (желтые ячейки)
с использованием Умной таблицы (Лист1(2) и зеленые ячейки)
с использованием сводной таблицы (в качестве источника тоже Умная таблица с листа Лист1(2))
[p.s.]Не заметила сразу, что вопрос в разделе Google Docs. Ответ нужен именно для Google Docs или всё же для Excel?[/p.s.]

Автор - Pelena
Дата добавления - 09.10.2017 в 08:25
RAMH Дата: Понедельник, 09.10.2017, 08:47 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena спасибо за скорость ответа. Нужно для Exel.


Сообщение отредактировал RAMH - Понедельник, 09.10.2017, 09:03
 
Ответить
СообщениеPelena спасибо за скорость ответа. Нужно для Exel.

Автор - RAMH
Дата добавления - 09.10.2017 в 08:47
RAMH Дата: Понедельник, 09.10.2017, 09:48 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Сводная таблица - это очень интересный вариант.
Но все таки, как можно изменить или дополнить формулу на Лист2 в столбце А, что бы не вручную изменять диапазон в формуле. Если на Лист1 добавятся новые уникальные значения и число строк увеличится.
 
Ответить
СообщениеСводная таблица - это очень интересный вариант.
Но все таки, как можно изменить или дополнить формулу на Лист2 в столбце А, что бы не вручную изменять диапазон в формуле. Если на Лист1 добавятся новые уникальные значения и число строк увеличится.

Автор - RAMH
Дата добавления - 09.10.2017 в 09:48
китин Дата: Понедельник, 09.10.2017, 10:03 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4437
Репутация: 701 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а если просто расширить диапазон в формуле?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$C$2:$C$1001;НАИБОЛЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$C$2:$C$1001;Лист1!$C$2:$C$1001;0);ЛОЖЬ)=СТРОКА(Лист1!$A$1:$A$1000);СТРОКА(Лист1!$A$1:$A$1000));СТРОКА(Лист1!A1)));"")
К сообщению приложен файл: _5607955.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа если просто расширить диапазон в формуле?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$C$2:$C$1001;НАИБОЛЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$C$2:$C$1001;Лист1!$C$2:$C$1001;0);ЛОЖЬ)=СТРОКА(Лист1!$A$1:$A$1000);СТРОКА(Лист1!$A$1:$A$1000));СТРОКА(Лист1!A1)));"")

Автор - китин
Дата добавления - 09.10.2017 в 10:03
Pelena Дата: Понедельник, 09.10.2017, 10:18 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11840
Репутация: 2608 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Можно использовать тот же именованный динамический диапазон
Код
=ЕСЛИОШИБКА(ИНДЕКС(несоответствия;НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(несоответствия;несоответствия;0)=СТРОКА(несоответствия)-1;СТРОКА(несоответствия)-1);СТРОКА(Лист1!A1)));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно использовать тот же именованный динамический диапазон
Код
=ЕСЛИОШИБКА(ИНДЕКС(несоответствия;НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(несоответствия;несоответствия;0)=СТРОКА(несоответствия)-1;СТРОКА(несоответствия)-1);СТРОКА(Лист1!A1)));"")

Автор - Pelena
Дата добавления - 09.10.2017 в 10:18
_Boroda_ Дата: Понедельник, 09.10.2017, 10:24 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Диапазон динамическим можно сделать с помощью СМЕЩ (как у Лены в файле в именованном диапазоне). Есть еще куча способов. Мне больше всего нравится неволатильное
Код
Лист1!C$1:ИНДЕКС(Лист1!C:C;СЧЁТЗ(Лист1!C:C))

Этот кусок можно всунуть вместо Лист1!$C$2:$C$17. Правда, если именованные диапазон не использовать, то формула довольно большая получится
Предлагаю немного более другой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!C:C;ПОИСКПОЗ(;СЧЁТЕСЛИ(A$1:A1;Лист1!C$1:ИНДЕКС(Лист1!C:C;СЧЁТЗ(Лист1!C:C)));));"")
К сообщению приложен файл: 5607955_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДиапазон динамическим можно сделать с помощью СМЕЩ (как у Лены в файле в именованном диапазоне). Есть еще куча способов. Мне больше всего нравится неволатильное
Код
Лист1!C$1:ИНДЕКС(Лист1!C:C;СЧЁТЗ(Лист1!C:C))

Этот кусок можно всунуть вместо Лист1!$C$2:$C$17. Правда, если именованные диапазон не использовать, то формула довольно большая получится
Предлагаю немного более другой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!C:C;ПОИСКПОЗ(;СЧЁТЕСЛИ(A$1:A1;Лист1!C$1:ИНДЕКС(Лист1!C:C;СЧЁТЗ(Лист1!C:C)));));"")

Автор - _Boroda_
Дата добавления - 09.10.2017 в 10:24
RAMH Дата: Понедельник, 09.10.2017, 11:48 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем спасибо, помогли. Воспользовался вариантом уважаемого Boroda, остальные методы взял на вооружение и повышения своего уровня познаний Excel. - Исправлено yes


Сообщение отредактировал RAMH - Понедельник, 09.10.2017, 13:16
 
Ответить
СообщениеВсем спасибо, помогли. Воспользовался вариантом уважаемого Boroda, остальные методы взял на вооружение и повышения своего уровня познаний Excel. - Исправлено yes

Автор - RAMH
Дата добавления - 09.10.2017 в 11:48
Gustav Дата: Понедельник, 09.10.2017, 12:37 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1475
Репутация: 559 ±
Замечаний: 0% ±

начинал с Excel 4.0...
[offtop]
повышения своего уровня познаний exel

Не сочтите за троллинг, но первым "повышающим уровень" шагом предлагаю запомнить правильное написание названия нашей любимой программы yes


Мой tip box - яд 41001663842605
 
Ответить
Сообщение[offtop]
повышения своего уровня познаний exel

Не сочтите за троллинг, но первым "повышающим уровень" шагом предлагаю запомнить правильное написание названия нашей любимой программы yes

Автор - Gustav
Дата добавления - 09.10.2017 в 12:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создание динамического диапазона с поиском уникальных значен (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!