Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать количество пустых ячеек между заполненными - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать количество пустых ячеек между заполненными (Формулы/Formulas)
Как посчитать количество пустых ячеек между заполненными
Lisizza Дата: Пятница, 20.10.2017, 13:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть строка с 12ю ячейками (год). Часть из них заполнена данными, часть пустая. Нужно:
1) найти первую и последнюю ячейку с данными в диапазоне
2) посчитать количество пустых ячеек между ячейками со значениями в заданном диапазоне.

Если подряд идут 2 ячейки с данными, нужно писать 0.

В файле с примером: серые ячейки - ячейки до 1й/после последней ячейки с данными, их не нужно учитывать.
Зеленые ячейки (или границы) - пустые ячейки, которые нужно посчитать


Сообщение отредактировал Lisizza - Пятница, 20.10.2017, 13:57
 
Ответить
СообщениеЕсть строка с 12ю ячейками (год). Часть из них заполнена данными, часть пустая. Нужно:
1) найти первую и последнюю ячейку с данными в диапазоне
2) посчитать количество пустых ячеек между ячейками со значениями в заданном диапазоне.

Если подряд идут 2 ячейки с данными, нужно писать 0.

В файле с примером: серые ячейки - ячейки до 1й/после последней ячейки с данными, их не нужно учитывать.
Зеленые ячейки (или границы) - пустые ячейки, которые нужно посчитать

Автор - Lisizza
Дата добавления - 20.10.2017 в 13:57
китин Дата: Пятница, 20.10.2017, 13:59 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6907
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
файла нет


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениефайла нет

Автор - китин
Дата добавления - 20.10.2017 в 13:59
Lisizza Дата: Пятница, 20.10.2017, 14:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Пропал. вот тут есть!
Надеюсь, получится
К сообщению приложен файл: 3066408.xlsx(9.7 Kb)
 
Ответить
СообщениеПропал. вот тут есть!
Надеюсь, получится

Автор - Lisizza
Дата добавления - 20.10.2017 в 14:04
sboy Дата: Пятница, 20.10.2017, 14:27 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 723 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
а там всегда единички?
Код
=СУММПРОИЗВ(--(ИНДЕКС(A3:L3;;ПОИСКПОЗ(1;A3:L3;)):ИНДЕКС(A3:L3;;ПРОСМОТР(2;A3:L3;$A$2:$L$2))=""))
К сообщению приложен файл: 3320338.xlsx(10.1 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
а там всегда единички?
Код
=СУММПРОИЗВ(--(ИНДЕКС(A3:L3;;ПОИСКПОЗ(1;A3:L3;)):ИНДЕКС(A3:L3;;ПРОСМОТР(2;A3:L3;$A$2:$L$2))=""))

Автор - sboy
Дата добавления - 20.10.2017 в 14:27
Lisizza Дата: Пятница, 20.10.2017, 14:40 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а там всегда единички?

Да, там единички: это либо было совершено действие, либо не было совершено действие.

Решение, предложенное вами не подходит: вы посчитали сумму пустых ячеек в строке всего (это можно было сделать проще, сумм и епусто).
Мне нужна сумма пустых ячеек между каждой ячейкой с данными.

Возможно, я не совсем понятно объясняю: посмотрите мой файл с примером еще раз, пожалуйста, там написано, какой должен получаться результат: только я сейчас посчитала вручную, а надо, чтобы все выводилось формулой.

По механике действия формулы я вижу это так:
1) есть диапазон с данными (12 столбцов) и диапазон с решением, максимум 10 столбцов
2) находим координаты первой и второй ячейки с данными. выдаем количество пустых ячеек между ними в 1ю ячейку диапазона с решением.
3) находим координаты 2й и 3й ячейки с данными, выводим кол-во пустых ячеек между ними во 2ю ячейку диапазона с решением.

повторять до тех пор, пока не закончатся ячейки с данными.
Прикладываю картинку, как это должно выглядеть
К сообщению приложен файл: 9631872.png(35.2 Kb)
 
Ответить
Сообщение
а там всегда единички?

Да, там единички: это либо было совершено действие, либо не было совершено действие.

Решение, предложенное вами не подходит: вы посчитали сумму пустых ячеек в строке всего (это можно было сделать проще, сумм и епусто).
Мне нужна сумма пустых ячеек между каждой ячейкой с данными.

Возможно, я не совсем понятно объясняю: посмотрите мой файл с примером еще раз, пожалуйста, там написано, какой должен получаться результат: только я сейчас посчитала вручную, а надо, чтобы все выводилось формулой.

По механике действия формулы я вижу это так:
1) есть диапазон с данными (12 столбцов) и диапазон с решением, максимум 10 столбцов
2) находим координаты первой и второй ячейки с данными. выдаем количество пустых ячеек между ними в 1ю ячейку диапазона с решением.
3) находим координаты 2й и 3й ячейки с данными, выводим кол-во пустых ячеек между ними во 2ю ячейку диапазона с решением.

повторять до тех пор, пока не закончатся ячейки с данными.
Прикладываю картинку, как это должно выглядеть

Автор - Lisizza
Дата добавления - 20.10.2017 в 14:40
sboy Дата: Пятница, 20.10.2017, 14:53 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 723 ±
Замечаний: 0% ±

Excel 2010
Прошу прощения, невнимательно посмотрел файл)
тогда так
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;СТОЛБЕЦ($A3:$L3)/$A3:$L3;СТОЛБЕЦ(B1))-АГРЕГАТ(15;6;СТОЛБЕЦ($A3:$L3)/$A3:$L3;СТОЛБЕЦ(A1))-1;"")
К сообщению приложен файл: 1380175.xlsx(10.3 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеПрошу прощения, невнимательно посмотрел файл)
тогда так
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;СТОЛБЕЦ($A3:$L3)/$A3:$L3;СТОЛБЕЦ(B1))-АГРЕГАТ(15;6;СТОЛБЕЦ($A3:$L3)/$A3:$L3;СТОЛБЕЦ(A1))-1;"")

Автор - sboy
Дата добавления - 20.10.2017 в 14:53
_Boroda_ Дата: Пятница, 20.10.2017, 15:00 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16486
Репутация: 6419 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты формулами массива (вводятся одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A3:$L3;СТОЛБЕЦ(A:L));СТОЛБЕЦ(B3))-НАИМЕНЬШИЙ(ЕСЛИ($A3:$L3;СТОЛБЕЦ(A:L));СТОЛБЕЦ(A3))-1;"")

Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(НАИМЕНЬШИЙ(ЕСЛИ($A3:$L3;СТОЛБЕЦ(A:L));СТОЛБЕЦ(A:B))*{-1;1})-1;"")
К сообщению приложен файл: 3066408_1.xlsx(11.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты формулами массива (вводятся одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A3:$L3;СТОЛБЕЦ(A:L));СТОЛБЕЦ(B3))-НАИМЕНЬШИЙ(ЕСЛИ($A3:$L3;СТОЛБЕЦ(A:L));СТОЛБЕЦ(A3))-1;"")

Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(НАИМЕНЬШИЙ(ЕСЛИ($A3:$L3;СТОЛБЕЦ(A:L));СТОЛБЕЦ(A:B))*{-1;1})-1;"")

Автор - _Boroda_
Дата добавления - 20.10.2017 в 15:00
Lisizza Дата: Пятница, 20.10.2017, 15:45 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вы почти волшебник!

Работает корректно, но в строке 3: ниже не тянется.

У меня загвоздка в том, чтобы протянуть эту историю и получить результат для 14тыс.строк.
Как это сделать?

Извините, я не очень умная :(
 
Ответить
СообщениеВы почти волшебник!

Работает корректно, но в строке 3: ниже не тянется.

У меня загвоздка в том, чтобы протянуть эту историю и получить результат для 14тыс.строк.
Как это сделать?

Извините, я не очень умная :(

Автор - Lisizza
Дата добавления - 20.10.2017 в 15:45
_Boroda_ Дата: Пятница, 20.10.2017, 15:54 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16486
Репутация: 6419 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
протянуть эту историю и получить результат для 14тыс.строк
А потом что?
Смотрите в файле. Я ввел все 3 варианта в строку 3, растянул на 10 вправо и на сколько-то вниз. Все растягивается прекрасно
Да, я потом уже дописал, Вы обратили внимание на это?
формулами массива (вводятся одновременным нажатием Контрл Шифт Ентер)
К сообщению приложен файл: 3066408_2.xlsx(30.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
протянуть эту историю и получить результат для 14тыс.строк
А потом что?
Смотрите в файле. Я ввел все 3 варианта в строку 3, растянул на 10 вправо и на сколько-то вниз. Все растягивается прекрасно
Да, я потом уже дописал, Вы обратили внимание на это?
формулами массива (вводятся одновременным нажатием Контрл Шифт Ентер)

Автор - _Boroda_
Дата добавления - 20.10.2017 в 15:54
sboy Дата: Пятница, 20.10.2017, 16:02 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 723 ±
Замечаний: 0% ±

Excel 2010
Да и моя вроде протягивается без проблем...


Яндекс: 410016850021169
 
Ответить
СообщениеДа и моя вроде протягивается без проблем...

Автор - sboy
Дата добавления - 20.10.2017 в 16:02
Lisizza Дата: Пятница, 20.10.2017, 16:12 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Работает! Спасибо огромное!
 
Ответить
СообщениеРаботает! Спасибо огромное!

Автор - Lisizza
Дата добавления - 20.10.2017 в 16:12
_Boroda_ Дата: Пятница, 20.10.2017, 16:21 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16486
Репутация: 6419 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
и моя вроде протягивается без проблем

А я все три и вывел
Я ввел все 3 варианта

Моих две.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
и моя вроде протягивается без проблем

А я все три и вывел
Я ввел все 3 варианта

Моих две.

Автор - _Boroda_
Дата добавления - 20.10.2017 в 16:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать количество пустых ячеек между заполненными (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!