Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по параметрам точных значений, не приблизительн - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по параметрам точных значений, не приблизительн (Формулы/Formulas)
Суммирование по параметрам точных значений, не приблизительн
пУлька Дата: Вторник, 28.11.2017, 15:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени. Ломаю голову почему не работает формула
Код
=СУММЕСЛИ($A2:$A144450;C2;$B2:$B144450)

Точнее она работает, но складывает только приблизительные значения. А нам нужно точные. Возможно это из-за длинного искомого значения. Есть 18-ти.значный код, состоящий, как ИНН, из региона, района, и т.д. Так вот формула последние (нужные) четыре цифры товара не учитывает, из-за чего складывает все товары этого производителя. Как решить эту проблему?
Спасибо заранее))
К сообщению приложен файл: 1317367.xlsx(49Kb)


Сообщение отредактировал пУлька - Вторник, 28.11.2017, 15:38
 
Ответить
СообщениеДоброго времени. Ломаю голову почему не работает формула
Код
=СУММЕСЛИ($A2:$A144450;C2;$B2:$B144450)

Точнее она работает, но складывает только приблизительные значения. А нам нужно точные. Возможно это из-за длинного искомого значения. Есть 18-ти.значный код, состоящий, как ИНН, из региона, района, и т.д. Так вот формула последние (нужные) четыре цифры товара не учитывает, из-за чего складывает все товары этого производителя. Как решить эту проблему?
Спасибо заранее))

Автор - пУлька
Дата добавления - 28.11.2017 в 15:24
vikttur Дата: Вторник, 28.11.2017, 15:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2557
Репутация: 460 ±
Замечаний: 0% ±

Цитата
Сумм-ие по пар-м.

Оф-те ф-мулу в сообщ. согл. Првл
 
Ответить
Сообщение
Цитата
Сумм-ие по пар-м.

Оф-те ф-мулу в сообщ. согл. Првл

Автор - vikttur
Дата добавления - 28.11.2017 в 15:30
_Boroda_ Дата: Вторник, 28.11.2017, 15:34 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
:D :D :D
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение:D :D :D
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 28.11.2017 в 15:34
пУлька Дата: Вторник, 28.11.2017, 15:38 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Извиняюсь pray
 
Ответить
СообщениеИзвиняюсь pray

Автор - пУлька
Дата добавления - 28.11.2017 в 15:38
_Boroda_ Дата: Вторник, 28.11.2017, 15:42 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
СУММЕСЛИ не работает с текстовыми числами более15 символов. Вернее, он отрубает 15 левых знаков
Используйте
Код
=СУММПРОИЗВ((A$2:A$2217=C2)*B$2:B$2217)

Либо сцепку делайте явным текстом, типа такого 7802_000003401_60003


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСУММЕСЛИ не работает с текстовыми числами более15 символов. Вернее, он отрубает 15 левых знаков
Используйте
Код
=СУММПРОИЗВ((A$2:A$2217=C2)*B$2:B$2217)

Либо сцепку делайте явным текстом, типа такого 7802_000003401_60003

Автор - _Boroda_
Дата добавления - 28.11.2017 в 15:42
пУлька Дата: Вторник, 28.11.2017, 15:48 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Используйте


Спасибо Вам огромное, весь интернет перешерстила, голова к вечеру опухла.
Теперь главное начальству не разболтать, а то без работы можно остаться. Мы это в ручную собираем целыми днями.

yes
 
Ответить
Сообщение
Используйте


Спасибо Вам огромное, весь интернет перешерстила, голова к вечеру опухла.
Теперь главное начальству не разболтать, а то без работы можно остаться. Мы это в ручную собираем целыми днями.

yes

Автор - пУлька
Дата добавления - 28.11.2017 в 15:48
Che79 Дата: Вторник, 28.11.2017, 15:54 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
пУлька, если так хочется именно СУММЕСЛИ(), то можно :D
Код
=СУММЕСЛИ($E2:$E144450;F2;$B2:$B144450)
, только уже с допстолбцами E и F, в которых для A и С соответственно
Код
=ЛЕВБ(A2;4)&ПРАВБ(A2;9)

Но, есть риск нарваться на неприятности, если, например структура кодов (наличие нулей внутри) не всегда одинакова. Не то обрубит и... "привет".
К сообщению приложен файл: 1317367_1.xlsx(71Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениепУлька, если так хочется именно СУММЕСЛИ(), то можно :D
Код
=СУММЕСЛИ($E2:$E144450;F2;$B2:$B144450)
, только уже с допстолбцами E и F, в которых для A и С соответственно
Код
=ЛЕВБ(A2;4)&ПРАВБ(A2;9)

Но, есть риск нарваться на неприятности, если, например структура кодов (наличие нулей внутри) не всегда одинакова. Не то обрубит и... "привет".

Автор - Che79
Дата добавления - 28.11.2017 в 15:54
пУлька Дата: Вторник, 28.11.2017, 16:06 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Мне кажется я что-то не так делаю, в прикрепленных файлах я выбрала одного производителя и только его товары. Список на самом деле огромен.И когда я его копирую и вставляю в приведенный файл (три первых столбца), заменяю конечные ячейки в формуле на фактически конечные - у меня выходит #Н/Д %)

Объем файла не позволяет его вам показать girl_sad


Сообщение отредактировал пУлька - Вторник, 28.11.2017, 16:08
 
Ответить
СообщениеМне кажется я что-то не так делаю, в прикрепленных файлах я выбрала одного производителя и только его товары. Список на самом деле огромен.И когда я его копирую и вставляю в приведенный файл (три первых столбца), заменяю конечные ячейки в формуле на фактически конечные - у меня выходит #Н/Д %)

Объем файла не позволяет его вам показать girl_sad

Автор - пУлька
Дата добавления - 28.11.2017 в 16:06
Che79 Дата: Вторник, 28.11.2017, 16:10 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
Объем файла не позволяет его вам показать
покажите кусок с Н/Д'ами


Делай нормально и будет нормально!
 
Ответить
Сообщение
Объем файла не позволяет его вам показать
покажите кусок с Н/Д'ами

Автор - Che79
Дата добавления - 28.11.2017 в 16:10
_Boroda_ Дата: Вторник, 28.11.2017, 16:13 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
#Н/Д формула СУММПРОИЗВ (да и СУММЕСЛИ, и СУММЕСЛИМН) может дать только в одном случае - если у Вас в исходных данных (в столбцех А и/или В) есть значение #Н/Д

Кстати, вот Вам еще формула (должна быть побыстрее СУММПРОИЗВ
Код
=СУММЕСЛИМН(B:B;A:A;ЛЕВБ(C2;10)&"*";A:A;"*"&ПРАВБ(C2;8))

Код
=СУММЕСЛИМН(B:B;A:A;ЛЕВБ(C2;12)&"*";A:A;"*"&ПРАВБ(C2;ДЛСТР(C2)-12))


Попробуйте на этом файле
И проверьте автофильтром значения в столбцах А и В - там должны быть #Н/Д-шки
К сообщению приложен файл: 7798325.xlsx(47Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение#Н/Д формула СУММПРОИЗВ (да и СУММЕСЛИ, и СУММЕСЛИМН) может дать только в одном случае - если у Вас в исходных данных (в столбцех А и/или В) есть значение #Н/Д

Кстати, вот Вам еще формула (должна быть побыстрее СУММПРОИЗВ
Код
=СУММЕСЛИМН(B:B;A:A;ЛЕВБ(C2;10)&"*";A:A;"*"&ПРАВБ(C2;8))

Код
=СУММЕСЛИМН(B:B;A:A;ЛЕВБ(C2;12)&"*";A:A;"*"&ПРАВБ(C2;ДЛСТР(C2)-12))


Попробуйте на этом файле
И проверьте автофильтром значения в столбцах А и В - там должны быть #Н/Д-шки

Автор - _Boroda_
Дата добавления - 28.11.2017 в 16:13
пУлька Дата: Вторник, 28.11.2017, 16:15 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
покажите кусок с Н/Д'ами


Простите а как я кусок отрежу? В первом столбце 150 тысяч кодов. Во втором пусть будет всего 50 ед. Если я обрежу первый столбец допустим от 200 строки, возможно этих 50 значений в них и не будет.
 
Ответить
Сообщение
покажите кусок с Н/Д'ами


Простите а как я кусок отрежу? В первом столбце 150 тысяч кодов. Во втором пусть будет всего 50 ед. Если я обрежу первый столбец допустим от 200 строки, возможно этих 50 значений в них и не будет.

Автор - пУлька
Дата добавления - 28.11.2017 в 16:15
пУлька Дата: Вторник, 28.11.2017, 16:18 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
И проверьте автофильтром


Простите, забыла сказать что в столбце В есть нулевые и отрицательные значения. В столбце А все впорядке, это коды они неизменны.
 
Ответить
Сообщение
И проверьте автофильтром


Простите, забыла сказать что в столбце В есть нулевые и отрицательные значения. В столбце А все впорядке, это коды они неизменны.

Автор - пУлька
Дата добавления - 28.11.2017 в 16:18
пУлька Дата: Вторник, 28.11.2017, 16:21 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Кстати, вот Вам еще формула (должна быть побыстрее СУММПРОИЗВ


Эти формулы работают. )))) Только их написание мне вообще не понятно. Сохраню файл и буду просто подставлять )))
 
Ответить
Сообщение
Кстати, вот Вам еще формула (должна быть побыстрее СУММПРОИЗВ


Эти формулы работают. )))) Только их написание мне вообще не понятно. Сохраню файл и буду просто подставлять )))

Автор - пУлька
Дата добавления - 28.11.2017 в 16:21
vikttur Дата: Вторник, 28.11.2017, 16:26 | Сообщение № 14
Группа: Друзья
Ранг: Старожил
Сообщений: 2557
Репутация: 460 ±
Замечаний: 0% ±

 
Ответить
СообщениеКросс:
http://www.planetaexcel.ru/forum....oe-chis

Автор - vikttur
Дата добавления - 28.11.2017 в 16:26
пУлька Дата: Вторник, 28.11.2017, 16:38 | Сообщение № 15
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Кросс:


Код
=СУММЕСЛИ(A19:A23;"*"&A3&"*";B19:B23)


Цитата
вариант с "*" может внести ряд проблем, например если A3 = 1


О какой проблеме идет речь?


Сообщение отредактировал пУлька - Вторник, 28.11.2017, 16:38
 
Ответить
Сообщение
Кросс:


Код
=СУММЕСЛИ(A19:A23;"*"&A3&"*";B19:B23)


Цитата
вариант с "*" может внести ряд проблем, например если A3 = 1


О какой проблеме идет речь?

Автор - пУлька
Дата добавления - 28.11.2017 в 16:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по параметрам точных значений, не приблизительн (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!