Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как провести анализ многотоварных заказов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как провести анализ многотоварных заказов (Формулы/Formulas)
Как провести анализ многотоварных заказов
salatt Дата: Воскресенье, 11.02.2018, 11:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Имеются заказы, в каждом из них много позиций, задача - расположить данные для анализа определенным образом - заказ - наиболее частые позиции и так далее. Пример - в приложении
Цель подробно также разъясняется в приложенном табличном примере. Как перенести заказы и позиции в них, чтобы они были близки по частотам в массиве заказов. В примере позиций мало, а в настоящих массивах их очень много, возможно, надо сначала ранжировать и тому подобное, но как все это сделать наиболее рационально.
И еще вопрос - как потом найти свое сообщение с новыми ответами?
К сообщению приложен файл: 4747864.xls(17.5 Kb)
 
Ответить
СообщениеИмеются заказы, в каждом из них много позиций, задача - расположить данные для анализа определенным образом - заказ - наиболее частые позиции и так далее. Пример - в приложении
Цель подробно также разъясняется в приложенном табличном примере. Как перенести заказы и позиции в них, чтобы они были близки по частотам в массиве заказов. В примере позиций мало, а в настоящих массивах их очень много, возможно, надо сначала ранжировать и тому подобное, но как все это сделать наиболее рационально.
И еще вопрос - как потом найти свое сообщение с новыми ответами?

Автор - salatt
Дата добавления - 11.02.2018 в 11:54
Pelena Дата: Воскресенье, 11.02.2018, 12:42 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13221
Репутация: 2908 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Возможно, не совсем вникла в задачу, но посмотрите эту тему и ссылки в ней на похожие темы

По второму вопросу: справа над первым постом есть ссылка Подписаться на тему. Или в профиле ссылка Форум


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Возможно, не совсем вникла в задачу, но посмотрите эту тему и ссылки в ней на похожие темы

По второму вопросу: справа над первым постом есть ссылка Подписаться на тему. Или в профиле ссылка Форум

Автор - Pelena
Дата добавления - 11.02.2018 в 12:42
Светлый Дата: Вторник, 13.02.2018, 10:17 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 706
Репутация: 186 ±
Замечаний: 0% ±

Excel 2010
Немного поизвращался над задачкой
Формула сортированных по величине заказов (массивная):
Код
=ЕСЛИ(СТРОКА(E2)>СЧЁТЗ(A$2:A$46);"";ИНДЕКС(A:A;НАИМЕНЬШИЙ(НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(A:H));ПОИСКПОЗ(НАИБОЛЬШИЙ(МУМНОЖ(ТРАНСП((СТРОКА(A$2:A$46)>НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(A:H)))*(СТРОКА(A$2:A$46)<НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(B:I)))*C$2:C$46);1^СТРОКА($2:$46));СТРОКА(E1));МУМНОЖ(ТРАНСП((СТРОКА(A$2:A$46)>НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(A:H)))*(СТРОКА(A$2:A$46)<НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(B:I)))*C$2:C$46);1^СТРОКА($2:$46));))))

Формула сортированных по суммарной величине товаров (массивная):
Код
=ИНДЕКС($B:$B;ОСТАТ(НАИБОЛЬШИЙ(СУММЕСЛИ($B$1:$B$46;$B$1:$B$46;$C$1:$C$46)*(1-ЕОШИБКА(1/(ПОИСКПОЗ($B$1:$B$46;$B$1:$B$46;)=СТРОКА(1:46))))+СТРОКА(1:46)%%;СТОЛБЕЦ(A3));1)/1%%)

И формула суммы товара в заказе (массивная):
Код
=ЕСЛИ($E4="";"";СУММ((СТРОКА($1:$46)<МИН(ЕСЛИ((ПОИСКПОЗ($E4;$A:$A;)<СТРОКА($1:$46))*($A$1:$A$46<>"");СТРОКА($1:$46))))*(СТРОКА($1:$46)>ПОИСКПОЗ($E4;$A:$A;))*($B$1:$B$46=F$3)*$C$1:$C$46))

Формулу подправил, файл перевложил
К сообщению приложен файл: 4747864.xlsx(13.3 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 13.02.2018, 10:47
 
Ответить
СообщениеНемного поизвращался над задачкой
Формула сортированных по величине заказов (массивная):
Код
=ЕСЛИ(СТРОКА(E2)>СЧЁТЗ(A$2:A$46);"";ИНДЕКС(A:A;НАИМЕНЬШИЙ(НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(A:H));ПОИСКПОЗ(НАИБОЛЬШИЙ(МУМНОЖ(ТРАНСП((СТРОКА(A$2:A$46)>НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(A:H)))*(СТРОКА(A$2:A$46)<НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(B:I)))*C$2:C$46);1^СТРОКА($2:$46));СТРОКА(E1));МУМНОЖ(ТРАНСП((СТРОКА(A$2:A$46)>НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(A:H)))*(СТРОКА(A$2:A$46)<НАИМЕНЬШИЙ(ЕСЛИ(A$2:A$46<>"";СТРОКА(A$2:A$46);99);СТОЛБЕЦ(B:I)))*C$2:C$46);1^СТРОКА($2:$46));))))

Формула сортированных по суммарной величине товаров (массивная):
Код
=ИНДЕКС($B:$B;ОСТАТ(НАИБОЛЬШИЙ(СУММЕСЛИ($B$1:$B$46;$B$1:$B$46;$C$1:$C$46)*(1-ЕОШИБКА(1/(ПОИСКПОЗ($B$1:$B$46;$B$1:$B$46;)=СТРОКА(1:46))))+СТРОКА(1:46)%%;СТОЛБЕЦ(A3));1)/1%%)

И формула суммы товара в заказе (массивная):
Код
=ЕСЛИ($E4="";"";СУММ((СТРОКА($1:$46)<МИН(ЕСЛИ((ПОИСКПОЗ($E4;$A:$A;)<СТРОКА($1:$46))*($A$1:$A$46<>"");СТРОКА($1:$46))))*(СТРОКА($1:$46)>ПОИСКПОЗ($E4;$A:$A;))*($B$1:$B$46=F$3)*$C$1:$C$46))

Формулу подправил, файл перевложил

Автор - Светлый
Дата добавления - 13.02.2018 в 10:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как провести анализ многотоварных заказов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!