Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти часто встречающееся значение в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти часто встречающееся значение в массиве (Формулы/Formulas)
Найти часто встречающееся значение в массиве
zegor Дата: Воскресенье, 04.03.2018, 21:50 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Привет, excelworld. Помоги определить самое часто встречающееся текстовое значение в массиве. Методом ИНДЕКС(МОДА(ПОИСКПОЗ))) я могу только в столбце нужное вычислить. В двух столбцах, следующих друг за другом, уже нет. В примере массив "A1:B2", нужно чтобы в ячейку "С1" выводился вариант который встретился в массиве дважды.

Спасибо за внимание к теме.
К сообщению приложен файл: 000.xlsx(8.6 Kb)
 
Ответить
СообщениеПривет, excelworld. Помоги определить самое часто встречающееся текстовое значение в массиве. Методом ИНДЕКС(МОДА(ПОИСКПОЗ))) я могу только в столбце нужное вычислить. В двух столбцах, следующих друг за другом, уже нет. В примере массив "A1:B2", нужно чтобы в ячейку "С1" выводился вариант который встретился в массиве дважды.

Спасибо за внимание к теме.

Автор - zegor
Дата добавления - 04.03.2018 в 21:50
AlexM Дата: Воскресенье, 04.03.2018, 23:03 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
Две формулы. обычная и массивная
Код
=ИНДЕКС(A1:B2;МАКС((МАКС(СЧЁТЕСЛИ(A1:B2;A1:B2))=СЧЁТЕСЛИ(A1:B2;A1:B2))*СТРОКА(A1:B2));МАКС((МАКС(СЧЁТЕСЛИ(A1:B2;A1:B2))=СЧЁТЕСЛИ(A1:B2;A1:B2))*СТОЛБЕЦ(A1:B2)))
Код
=ПРОСМОТР(2;1/(МАКС(СЧЁТЕСЛИ(A1:B2;E1:E7))=СЧЁТЕСЛИ(A1:B2;E1:E7));E1:E7)
К сообщению приложен файл: 000_01.xlsx(8.8 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДве формулы. обычная и массивная
Код
=ИНДЕКС(A1:B2;МАКС((МАКС(СЧЁТЕСЛИ(A1:B2;A1:B2))=СЧЁТЕСЛИ(A1:B2;A1:B2))*СТРОКА(A1:B2));МАКС((МАКС(СЧЁТЕСЛИ(A1:B2;A1:B2))=СЧЁТЕСЛИ(A1:B2;A1:B2))*СТОЛБЕЦ(A1:B2)))
Код
=ПРОСМОТР(2;1/(МАКС(СЧЁТЕСЛИ(A1:B2;E1:E7))=СЧЁТЕСЛИ(A1:B2;E1:E7));E1:E7)

Автор - AlexM
Дата добавления - 04.03.2018 в 23:03
Che79 Дата: Понедельник, 05.03.2018, 10:20 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Вариант с помощью УФ
Код
=(СЧЁТЕСЛИ($A1:$B$100;A1)=МАКС(СЧЁТЕСЛИ($A$1:$B$100;$A$1:$B$100)))*(A1<>0)

Первый дубликат наиболее часто встречающегося дня недели выделяется цветом. Если таких дней несколько (допустим, понедельник и четверг или более), то выделяются два дня (или более).
К сообщению приложен файл: 000-.xlsx(8.9 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВариант с помощью УФ
Код
=(СЧЁТЕСЛИ($A1:$B$100;A1)=МАКС(СЧЁТЕСЛИ($A$1:$B$100;$A$1:$B$100)))*(A1<>0)

Первый дубликат наиболее часто встречающегося дня недели выделяется цветом. Если таких дней несколько (допустим, понедельник и четверг или более), то выделяются два дня (или более).

Автор - Che79
Дата добавления - 05.03.2018 в 10:20
zegor Дата: Понедельник, 05.03.2018, 18:55 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
AlexM, спасибо что помогаете. Первая формула почему-то выдаёт только значение ячейки "А1". Вторая (массивная) опирается на данные из "Е1:Е7", этого массива не будет в таблице. Меняя данные в массиве "А1:В2" первая формула так и выдаёт "А1", вторая делает всё правильно но при помощи "Е1:Е7" которого не должно быть. Лишнее убрал. Посмотрите пожалуйста.

перезалил пример
К сообщению приложен файл: 6360946.xlsx(8.3 Kb)


Сообщение отредактировал zegor - Понедельник, 05.03.2018, 19:05
 
Ответить
СообщениеAlexM, спасибо что помогаете. Первая формула почему-то выдаёт только значение ячейки "А1". Вторая (массивная) опирается на данные из "Е1:Е7", этого массива не будет в таблице. Меняя данные в массиве "А1:В2" первая формула так и выдаёт "А1", вторая делает всё правильно но при помощи "Е1:Е7" которого не должно быть. Лишнее убрал. Посмотрите пожалуйста.

перезалил пример

Автор - zegor
Дата добавления - 05.03.2018 в 18:55
zegor Дата: Понедельник, 05.03.2018, 19:02 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, спасибо за помощь. Немножко не то. То что мы ищем будет заголовком, по этому нужно именно получить значение которое встречается дважды. Массив всегда будет ограничен этими четырьмя ячейками.
К сообщению приложен файл: 0000.xlsx(8.3 Kb)


Сообщение отредактировал zegor - Понедельник, 05.03.2018, 19:02
 
Ответить
СообщениеChe79, спасибо за помощь. Немножко не то. То что мы ищем будет заголовком, по этому нужно именно получить значение которое встречается дважды. Массив всегда будет ограничен этими четырьмя ячейками.

Автор - zegor
Дата добавления - 05.03.2018 в 19:02
Pelena Дата: Понедельник, 05.03.2018, 19:13 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12759
Репутация: 2810 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
zegor, вводите первую формулу от AlexM тоже как формулу массива


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеzegor, вводите первую формулу от AlexM тоже как формулу массива

Автор - Pelena
Дата добавления - 05.03.2018 в 19:13
zegor Дата: Понедельник, 05.03.2018, 19:36 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, вот в таком варианте не хочет "массивиться".

"Формулы массива в объединенных ячейках неверны"
К сообщению приложен файл: 00.xlsx(8.3 Kb)


Сообщение отредактировал zegor - Понедельник, 05.03.2018, 19:38
 
Ответить
СообщениеPelena, вот в таком варианте не хочет "массивиться".

"Формулы массива в объединенных ячейках неверны"

Автор - zegor
Дата добавления - 05.03.2018 в 19:36
Pelena Дата: Понедельник, 05.03.2018, 19:41 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12759
Репутация: 2810 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Объединенные ячейки - зло yes
К сообщению приложен файл: 7296015.xlsx(9.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОбъединенные ячейки - зло yes

Автор - Pelena
Дата добавления - 05.03.2018 в 19:41
zegor Дата: Понедельник, 05.03.2018, 19:46 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, в вашем файлике поменял только данные. Всё зациклилось на "В3" почему-то.
К сообщению приложен файл: 7573848.xlsx(8.7 Kb)


Сообщение отредактировал zegor - Понедельник, 05.03.2018, 19:47
 
Ответить
СообщениеPelena, в вашем файлике поменял только данные. Всё зациклилось на "В3" почему-то.

Автор - zegor
Дата добавления - 05.03.2018 в 19:46
Pelena Дата: Понедельник, 05.03.2018, 20:18 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12759
Репутация: 2810 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Попробуйте другую формулу
К сообщению приложен файл: 7496339.xlsx(9.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте другую формулу

Автор - Pelena
Дата добавления - 05.03.2018 в 20:18
AlexM Дата: Понедельник, 05.03.2018, 20:40 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
Первая формула почему-то выдаёт только значение ячейки "А1"
Первая формула так же массивная. Ошибся.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Первая формула почему-то выдаёт только значение ячейки "А1"
Первая формула так же массивная. Ошибся.

Автор - AlexM
Дата добавления - 05.03.2018 в 20:40
AlexM Дата: Понедельник, 05.03.2018, 20:54 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
формула массива
Код
=ПРОСМОТР(2;1/(МАКС(СЧЁТЕСЛИ(A2:B3;ТЕКСТ(СТРОКА($1:$7);"ДДДД")))=СЧЁТЕСЛИ(A2:B3;ТЕКСТ(СТРОКА($1:$7);"ДДДД")));ТЕКСТ(СТРОКА($1:$7);"ДДДД"))
К сообщению приложен файл: 6360946_01.xlsx(8.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеформула массива
Код
=ПРОСМОТР(2;1/(МАКС(СЧЁТЕСЛИ(A2:B3;ТЕКСТ(СТРОКА($1:$7);"ДДДД")))=СЧЁТЕСЛИ(A2:B3;ТЕКСТ(СТРОКА($1:$7);"ДДДД")));ТЕКСТ(СТРОКА($1:$7);"ДДДД"))

Автор - AlexM
Дата добавления - 05.03.2018 в 20:54
zegor Дата: Понедельник, 05.03.2018, 21:44 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, пожалуйста не сердитесь только. Мне стоило сразу прикреплять пример как он будет у меня. Я же думал просто подставлю ваше решение к себе и всё. Как оказалось детали очень даже важны.

Ваше решение работает, но только если количество массивов будет равно одному. У меня таких будет 50 на листе (в примере только три но будет 50).
К сообщению приложен файл: Pelena.xlsx(9.0 Kb)
 
Ответить
СообщениеPelena, пожалуйста не сердитесь только. Мне стоило сразу прикреплять пример как он будет у меня. Я же думал просто подставлю ваше решение к себе и всё. Как оказалось детали очень даже важны.

Ваше решение работает, но только если количество массивов будет равно одному. У меня таких будет 50 на листе (в примере только три но будет 50).

Автор - zegor
Дата добавления - 05.03.2018 в 21:44
zegor Дата: Понедельник, 05.03.2018, 21:52 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
AlexM, и Вы извините. Дело в том, что дни недели я "прикрутил" в таблицу просто так, для того что бы дать понять- тип данных будет текстовый. Но это я сам виноват, что Вы поняли меня буквально. Ваше решение работает, но только с днями недели (подозреваю из-за элемента формулы ДДДД). На листе у меня 50 таких массивов будет.
К сообщению приложен файл: AlexM.xlsx(9.8 Kb)
 
Ответить
СообщениеAlexM, и Вы извините. Дело в том, что дни недели я "прикрутил" в таблицу просто так, для того что бы дать понять- тип данных будет текстовый. Но это я сам виноват, что Вы поняли меня буквально. Ваше решение работает, но только с днями недели (подозреваю из-за элемента формулы ДДДД). На листе у меня 50 таких массивов будет.

Автор - zegor
Дата добавления - 05.03.2018 в 21:52
Che79 Дата: Понедельник, 05.03.2018, 21:54 | Сообщение № 15
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
zegor, закрепите в формуле от Елены диапазоны в функциях СТРОКА() и СТОЛБЕЦ() и копируйте вправо насколько нужно.


Делай нормально и будет нормально!
 
Ответить
Сообщениеzegor, закрепите в формуле от Елены диапазоны в функциях СТРОКА() и СТОЛБЕЦ() и копируйте вправо насколько нужно.

Автор - Che79
Дата добавления - 05.03.2018 в 21:54
zegor Дата: Понедельник, 05.03.2018, 22:03 | Сообщение № 16
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, да. Так работает отлично. Спасибо большое за подсказку. :D
 
Ответить
СообщениеChe79, да. Так работает отлично. Спасибо большое за подсказку. :D

Автор - zegor
Дата добавления - 05.03.2018 в 22:03
AlexM Дата: Понедельник, 05.03.2018, 22:26 | Сообщение № 17
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3741
Репутация: 944 ±
Замечаний: 0% ±

Excel 2003
zegor, самая первая формула
К сообщению приложен файл: AlexM_01.xlsx(9.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеzegor, самая первая формула

Автор - AlexM
Дата добавления - 05.03.2018 в 22:26
zegor Дата: Понедельник, 05.03.2018, 22:49 | Сообщение № 18
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
AlexM, через некоторое количество копирований получаем неверный результат.
К сообщению приложен файл: AlexM_02.xlsx(10.2 Kb)
 
Ответить
СообщениеAlexM, через некоторое количество копирований получаем неверный результат.

Автор - zegor
Дата добавления - 05.03.2018 в 22:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти часто встречающееся значение в массиве (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!