Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расставить цифровые данные по мере возрастания. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расставить цифровые данные по мере возрастания. (Формулы/Formulas)
Расставить цифровые данные по мере возрастания.
Totalmen Дата: Четверг, 05.04.2018, 06:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте,помогите пожалуйста с формулой которая расставит данные по возрастанию . Дано три ячейки с цифрами в одной строке 80...307...135 ,задача в соседних ячейках что бы было 307...135...80
Спасибо за помощь.
 
Ответить
СообщениеЗдравствуйте,помогите пожалуйста с формулой которая расставит данные по возрастанию . Дано три ячейки с цифрами в одной строке 80...307...135 ,задача в соседних ячейках что бы было 307...135...80
Спасибо за помощь.

Автор - Totalmen
Дата добавления - 05.04.2018 в 06:12
Totalmen Дата: Четверг, 05.04.2018, 06:18 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да ,только что подумал ,мне же нужно знать ,не цифры которые там а название ячейки ,то есть 1ячейка -80...2ячейка-307...3ячейка-135 в итоге должно показать в соседних трёх ячейках только номера ,но по возрастанию = 2...3...1
К сообщению приложен файл: 3438606.xlsx(8.0 Kb)


Сообщение отредактировал Totalmen - Четверг, 05.04.2018, 06:26
 
Ответить
СообщениеДа ,только что подумал ,мне же нужно знать ,не цифры которые там а название ячейки ,то есть 1ячейка -80...2ячейка-307...3ячейка-135 в итоге должно показать в соседних трёх ячейках только номера ,но по возрастанию = 2...3...1

Автор - Totalmen
Дата добавления - 05.04.2018 в 06:18
Pelena Дата: Четверг, 05.04.2018, 06:36 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12620
Репутация: 2775 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС($A$1:$C$1;ПОИСКПОЗ(НАИБОЛЬШИЙ($A2:$C2;СТОЛБЕЦ(A1));$A2:$C2;0))
К сообщению приложен файл: 2830002.xlsx(8.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС($A$1:$C$1;ПОИСКПОЗ(НАИБОЛЬШИЙ($A2:$C2;СТОЛБЕЦ(A1));$A2:$C2;0))

Автор - Pelena
Дата добавления - 05.04.2018 в 06:36
Totalmen Дата: Четверг, 05.04.2018, 07:05 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Спасибо ,попробовал, всё отлично работает,но ещё как дополнение можно так сделать что бы нулевое значение в расчёт не бралось и не переносилось.
 
Ответить
СообщениеPelena, Спасибо ,попробовал, всё отлично работает,но ещё как дополнение можно так сделать что бы нулевое значение в расчёт не бралось и не переносилось.

Автор - Totalmen
Дата добавления - 05.04.2018 в 07:05
китин Дата: Четверг, 05.04.2018, 07:12 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4776
Репутация: 763 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так сделать что бы нулевое значение в расчёт не бралось

покажите пример в файле.
нулевое значение

где?
не переносилось.

куда?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
так сделать что бы нулевое значение в расчёт не бралось

покажите пример в файле.
нулевое значение

где?
не переносилось.

куда?

Автор - китин
Дата добавления - 05.04.2018 в 07:12
Totalmen Дата: Четверг, 05.04.2018, 08:48 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Доброе утро .
К сообщению приложен файл: 1909799.xlsx(9.4 Kb)
 
Ответить
Сообщениекитин, Доброе утро .

Автор - Totalmen
Дата добавления - 05.04.2018 в 08:48
китин Дата: Четверг, 05.04.2018, 08:59 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4776
Репутация: 763 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброе!!! формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$12:$C$12;;ПОИСКПОЗ(НАИБОЛЬШИЙ(ЕСЛИ($A13:$C13<>0;$A13:$C13);СТОЛБЕЦ(A1));$A13:$C13;0));"")
К сообщению приложен файл: Totalmen.xlsx(9.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброе!!! формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$12:$C$12;;ПОИСКПОЗ(НАИБОЛЬШИЙ(ЕСЛИ($A13:$C13<>0;$A13:$C13);СТОЛБЕЦ(A1));$A13:$C13;0));"")

Автор - китин
Дата добавления - 05.04.2018 в 08:59
Totalmen Дата: Четверг, 05.04.2018, 09:36 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Спасибо,то что нужно .
 
Ответить
Сообщениекитин, Спасибо,то что нужно .

Автор - Totalmen
Дата добавления - 05.04.2018 в 09:36
Totalmen Дата: Четверг, 05.04.2018, 11:36 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Pelena, Я думаю что такое не возможно,но всё таки решил спросить,когда данные в двух ячейках одинаковые ,выдаёт два повтора одной ячейки,нельзя ли что бы чтобы вторую ячейку брала ближайшею к большему числу и те ячейки которые одинаковые тоже их подряд ставила?Посмотрите пожалуйста.
К сообщению приложен файл: Totalmen_.xlsx(10.3 Kb)
 
Ответить
Сообщениекитин, Pelena, Я думаю что такое не возможно,но всё таки решил спросить,когда данные в двух ячейках одинаковые ,выдаёт два повтора одной ячейки,нельзя ли что бы чтобы вторую ячейку брала ближайшею к большему числу и те ячейки которые одинаковые тоже их подряд ставила?Посмотрите пожалуйста.

Автор - Totalmen
Дата добавления - 05.04.2018 в 11:36
Светлый Дата: Четверг, 05.04.2018, 19:43 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 409
Репутация: 92 ±
Замечаний: 0% ±

Excel 2007
Можно вот такой массивной формулой воспользоваться:
Код
=ЕСЛИОШИБКА(ОСТАТ(НАИБОЛЬШИЙ(ЕСЛИ($A13:$C13>0;$A13:$C13+$A$12:$C$12%);СТОЛБЕЦ(A1));1)/1%;"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно вот такой массивной формулой воспользоваться:
Код
=ЕСЛИОШИБКА(ОСТАТ(НАИБОЛЬШИЙ(ЕСЛИ($A13:$C13>0;$A13:$C13+$A$12:$C$12%);СТОЛБЕЦ(A1));1)/1%;"")

Автор - Светлый
Дата добавления - 05.04.2018 в 19:43
Totalmen Дата: Суббота, 07.04.2018, 10:12 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Светлый, Спасибо !!!
 
Ответить
СообщениеСветлый, Спасибо !!!

Автор - Totalmen
Дата добавления - 07.04.2018 в 10:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расставить цифровые данные по мере возрастания. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!