Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование диапазона в порядке возрастания - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование диапазона в порядке возрастания (Формулы/Formulas)
Формирование диапазона в порядке возрастания
Nik57 Дата: Пятница, 06.04.2018, 16:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 90
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, друзья!

Подскажите решить дилемму)) На листе 1, приложенного примера, есть условный диапазон А1:Н6. На листе 2 примера, я формирую этот же диапазон в порядке убывания по дате. Все работает, только если в выборке встречается дублирование даты, то в моем диапазоне повторяются дважды одни и те же значения (выделенный красный диапазон В4:Н5). А должно получиться, чтобы либо в строке В4:Н4, либо в строке В5:Н5 прописались вторые значения из выборки Листа1 (помидор;8;1;6;1сорт;6;8 соотвественно). Как подкорректировать формулы для данной ситуации, что то не додумаюсь для этого.
Всем заранее спасибо!
К сообщению приложен файл: 2485670.xlsx(10.5 Kb)
 
Ответить
СообщениеДобрый день, друзья!

Подскажите решить дилемму)) На листе 1, приложенного примера, есть условный диапазон А1:Н6. На листе 2 примера, я формирую этот же диапазон в порядке убывания по дате. Все работает, только если в выборке встречается дублирование даты, то в моем диапазоне повторяются дважды одни и те же значения (выделенный красный диапазон В4:Н5). А должно получиться, чтобы либо в строке В4:Н4, либо в строке В5:Н5 прописались вторые значения из выборки Листа1 (помидор;8;1;6;1сорт;6;8 соотвественно). Как подкорректировать формулы для данной ситуации, что то не додумаюсь для этого.
Всем заранее спасибо!

Автор - Nik57
Дата добавления - 06.04.2018 в 16:30
Светлый Дата: Пятница, 06.04.2018, 18:47 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 407
Репутация: 92 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
В B4 формула массива и протянуть вниз и вправо:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$6+СТРОКА($3:$6)%;СТРОКА(A1));1)/1%;СТОЛБЕЦ(A1));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
В B4 формула массива и протянуть вниз и вправо:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$6+СТРОКА($3:$6)%;СТРОКА(A1));1)/1%;СТОЛБЕЦ(A1));"")

Автор - Светлый
Дата добавления - 06.04.2018 в 18:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование диапазона в порядке возрастания (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!