Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование диапазона в порядке возрастания - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование диапазона в порядке возрастания (Формулы/Formulas)
Формирование диапазона в порядке возрастания
Nik57 Дата: Пятница, 06.04.2018, 16:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, друзья!

Подскажите решить дилемму)) На листе 1, приложенного примера, есть условный диапазон А1:Н6. На листе 2 примера, я формирую этот же диапазон в порядке убывания по дате. Все работает, только если в выборке встречается дублирование даты, то в моем диапазоне повторяются дважды одни и те же значения (выделенный красный диапазон В4:Н5). А должно получиться, чтобы либо в строке В4:Н4, либо в строке В5:Н5 прописались вторые значения из выборки Листа1 (помидор;8;1;6;1сорт;6;8 соотвественно). Как подкорректировать формулы для данной ситуации, что то не додумаюсь для этого.
Всем заранее спасибо!
К сообщению приложен файл: 2485670.xlsx(10.5 Kb)
 
Ответить
СообщениеДобрый день, друзья!

Подскажите решить дилемму)) На листе 1, приложенного примера, есть условный диапазон А1:Н6. На листе 2 примера, я формирую этот же диапазон в порядке убывания по дате. Все работает, только если в выборке встречается дублирование даты, то в моем диапазоне повторяются дважды одни и те же значения (выделенный красный диапазон В4:Н5). А должно получиться, чтобы либо в строке В4:Н4, либо в строке В5:Н5 прописались вторые значения из выборки Листа1 (помидор;8;1;6;1сорт;6;8 соотвественно). Как подкорректировать формулы для данной ситуации, что то не додумаюсь для этого.
Всем заранее спасибо!

Автор - Nik57
Дата добавления - 06.04.2018 в 16:30
Светлый Дата: Пятница, 06.04.2018, 18:47 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
В B4 формула массива и протянуть вниз и вправо:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$6+СТРОКА($3:$6)%;СТРОКА(A1));1)/1%;СТОЛБЕЦ(A1));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
В B4 формула массива и протянуть вниз и вправо:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$6+СТРОКА($3:$6)%;СТРОКА(A1));1)/1%;СТОЛБЕЦ(A1));"")

Автор - Светлый
Дата добавления - 06.04.2018 в 18:47
Nik57 Дата: Пятница, 27.04.2018, 15:13 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Все работает, только одна проблема. Если на листе1 происходит динамические действия и число выборки увеличивается (диапазон А7:Н7), то на втором листе вот эта запись в формуле
Лист1!$A$3:$A$6+СТРОКА($3:$6)
требует ручной корректировки. Технически это проблематично из-за объемов. В таком виде, к примеру, формула не работает Лист1!$A$:$A$+СТРОКА($3:$500)
Как ее поправить?
К сообщению приложен файл: 2723732.xlsx(13.5 Kb)
 
Ответить
СообщениеВсе работает, только одна проблема. Если на листе1 происходит динамические действия и число выборки увеличивается (диапазон А7:Н7), то на втором листе вот эта запись в формуле
Лист1!$A$3:$A$6+СТРОКА($3:$6)
требует ручной корректировки. Технически это проблематично из-за объемов. В таком виде, к примеру, формула не работает Лист1!$A$:$A$+СТРОКА($3:$500)
Как ее поправить?

Автор - Nik57
Дата добавления - 27.04.2018 в 15:13
Светлый Дата: Пятница, 27.04.2018, 16:10 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 652
Репутация: 176 ±
Замечаний: 0% ±

Excel 2010
Подкорректировал:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$500+СТРОКА(Лист1!$3:$500)%%;СТРОКА(A1));1)/1%%;СТОЛБЕЦ(A1));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПодкорректировал:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$500+СТРОКА(Лист1!$3:$500)%%;СТРОКА(A1));1)/1%%;СТОЛБЕЦ(A1));"")

Автор - Светлый
Дата добавления - 27.04.2018 в 16:10
Nik57 Дата: Понедельник, 28.05.2018, 16:09 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Светлый, тут еще одна делемка.. а можно скорректировать так, чтобы вместо нулей "выдавались" пустые ячейке в диапазоне В9:Н14 второго листа?
К сообщению приложен файл: 4159234.xlsx(14.5 Kb)
 
Ответить
СообщениеСветлый, тут еще одна делемка.. а можно скорректировать так, чтобы вместо нулей "выдавались" пустые ячейке в диапазоне В9:Н14 второго листа?

Автор - Nik57
Дата добавления - 28.05.2018 в 16:09
_Boroda_ Дата: Понедельник, 28.05.2018, 17:58 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13185
Репутация: 5422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немного изменил формулу Сергея и добавил условие для пустых
Код
=ЕСЛИ($A4="";"";ИНДЕКС(Лист1!B:B;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$500+СТРОКА(Лист1!$3:$500)%%;СТРОКА(B1));1)/1%%))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

*Добавлено
А если даты по порядку, то
Код
=ЕСЛИ($A4="";"";ИНДЕКС(Лист1!B:B;ПОИСКПОЗ($A4;Лист1!$A$1:$A$999;)+СЧЁТЕСЛИ($A$3:$A3;$A4)))
К сообщению приложен файл: 4159234_1.xlsx(15.0 Kb) · 4159234_2.xlsx(14.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Понедельник, 28.05.2018, 19:14
 
Ответить
СообщениеНемного изменил формулу Сергея и добавил условие для пустых
Код
=ЕСЛИ($A4="";"";ИНДЕКС(Лист1!B:B;ОСТАТ(НАИБОЛЬШИЙ(Лист1!$A$3:$A$500+СТРОКА(Лист1!$3:$500)%%;СТРОКА(B1));1)/1%%))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

*Добавлено
А если даты по порядку, то
Код
=ЕСЛИ($A4="";"";ИНДЕКС(Лист1!B:B;ПОИСКПОЗ($A4;Лист1!$A$1:$A$999;)+СЧЁТЕСЛИ($A$3:$A3;$A4)))

Автор - _Boroda_
Дата добавления - 28.05.2018 в 17:58
Nic70y Дата: Понедельник, 28.05.2018, 18:13 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4839
Репутация: 1047 ±
Замечаний: 0% ±

Excel 2013
если даты по порядку (думаю, оно так и есть)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;СТРОКА(A1)-ПОИСКПОЗ($A4;$A$4:$A4;)+ПОИСКПОЗ($A4;Лист1!$A:$A;);СТОЛБЕЦ(A1));"")
не массивная
К сообщению приложен файл: 8301431.xlsx(11.6 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеесли даты по порядку (думаю, оно так и есть)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$H;СТРОКА(A1)-ПОИСКПОЗ($A4;$A$4:$A4;)+ПОИСКПОЗ($A4;Лист1!$A:$A;);СТОЛБЕЦ(A1));"")
не массивная

Автор - Nic70y
Дата добавления - 28.05.2018 в 18:13
Nik57 Дата: Вторник, 29.05.2018, 10:20 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, пока на данном этапе все заработало)) Всем спасибо!!
 
Ответить
СообщениеДа, пока на данном этапе все заработало)) Всем спасибо!!

Автор - Nik57
Дата добавления - 29.05.2018 в 10:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование диапазона в порядке возрастания (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!