Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение одной ячейки и диапазоном с выводом значения. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение одной ячейки и диапазоном с выводом значения. (Формулы/Formulas)
Сравнение одной ячейки и диапазоном с выводом значения.
Максим2 Дата: Среда, 11.04.2018, 14:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Просьба решить проблему.

В Лист 1 значения, каждое из них сравнивается с "Диапазоном" значений на Листе 2. Если есть совпадение , то выводится "Результат это го значения" в отдельном столбце "Итог" на Листе 1. Если нет совпадения то пишется "0". Просьба указать как должны быть форматированы ячейки числовой или общий..потому что я пробовал формулы здесь на форуме и результат писал что в формуле ошибка.
 
Ответить
СообщениеПросьба решить проблему.

В Лист 1 значения, каждое из них сравнивается с "Диапазоном" значений на Листе 2. Если есть совпадение , то выводится "Результат это го значения" в отдельном столбце "Итог" на Листе 1. Если нет совпадения то пишется "0". Просьба указать как должны быть форматированы ячейки числовой или общий..потому что я пробовал формулы здесь на форуме и результат писал что в формуле ошибка.

Автор - Максим2
Дата добавления - 11.04.2018 в 14:23
Максим2 Дата: Среда, 11.04.2018, 14:24 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Я делаю это в 2010 Exel
 
Ответить
СообщениеЯ делаю это в 2010 Exel

Автор - Максим2
Дата добавления - 11.04.2018 в 14:24
Pelena Дата: Среда, 11.04.2018, 14:26 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13109
Репутация: 2888 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Судя по описанию, должна помочь функция ВПР()
Подробнее при наличии файла с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеСудя по описанию, должна помочь функция ВПР()
Подробнее при наличии файла с примером

Автор - Pelena
Дата добавления - 11.04.2018 в 14:26
Максим2 Дата: Среда, 11.04.2018, 14:27 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Файл с примером
К сообщению приложен файл: 4607296.xlsx(9.2 Kb)
 
Ответить
СообщениеФайл с примером

Автор - Максим2
Дата добавления - 11.04.2018 в 14:27
Pelena Дата: Среда, 11.04.2018, 14:29 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13109
Репутация: 2888 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИОШИБКА(ВПР(D11;Лист2!$D$9:$E$17;2;0);0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(D11;Лист2!$D$9:$E$17;2;0);0)

Автор - Pelena
Дата добавления - 11.04.2018 в 14:29
Максим2 Дата: Пятница, 13.04.2018, 08:24 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Формула помогла, но 2012 год не сходится. Пишет другие данные.
 
Ответить
СообщениеДобрый день. Формула помогла, но 2012 год не сходится. Пишет другие данные.

Автор - Максим2
Дата добавления - 13.04.2018 в 08:24
китин Дата: Пятница, 13.04.2018, 08:26 | Сообщение № 7
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Цитата Максим2, 13.04.2018 в 08:24, в сообщении № 6 ()
2012 год не сходится

Цитата Максим2, 11.04.2018 в 14:23, в сообщении № 1 ()
как должны быть форматированы ячейки числовой или общий

без файла с ошибкой ответ только такой


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Цитата Максим2, 13.04.2018 в 08:24, в сообщении № 6 ()
2012 год не сходится

Цитата Максим2, 11.04.2018 в 14:23, в сообщении № 1 ()
как должны быть форматированы ячейки числовой или общий

без файла с ошибкой ответ только такой

Автор - китин
Дата добавления - 13.04.2018 в 08:26
Максим2 Дата: Пятница, 13.04.2018, 08:39 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Это понятно , все года получились , а 2012 год пишет другие данные . Справочник и ячейка сравнения - общий. Значения - числа до 3 знака
К сообщению приложен файл: __3.xls(95.5 Kb)
 
Ответить
СообщениеЭто понятно , все года получились , а 2012 год пишет другие данные . Справочник и ячейка сравнения - общий. Значения - числа до 3 знака

Автор - Максим2
Дата добавления - 13.04.2018 в 08:39
китин Дата: Пятница, 13.04.2018, 08:55 | Сообщение № 9
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вы берете данные из столбца R так? а в формуле какой столбец?
вот так поменяйте
Код
=ЕСЛИОШИБКА(ВПР(B5;Справочник2012!$B$3:$R$41;17;0);0)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевы берете данные из столбца R так? а в формуле какой столбец?
вот так поменяйте
Код
=ЕСЛИОШИБКА(ВПР(B5;Справочник2012!$B$3:$R$41;17;0);0)

Автор - китин
Дата добавления - 13.04.2018 в 08:55
Максим2 Дата: Пятница, 13.04.2018, 10:09 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сделал и не получается . Что такое 17 в формуле ?
К сообщению приложен файл: 2964903.xls(95.5 Kb)
 
Ответить
СообщениеСделал и не получается . Что такое 17 в формуле ?

Автор - Максим2
Дата добавления - 13.04.2018 в 10:09
Максим2 Дата: Пятница, 13.04.2018, 10:14 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИОШИБКА(ВПР(J88;Справочник2014!$C$3:$D$6088;2;0);0)
J88 проверяемая ячейка
Справочник - это понятно
$C$3:$D$6088 диапазон справочника

Что такое "2" в формуле ?
 
Ответить
Сообщение=ЕСЛИОШИБКА(ВПР(J88;Справочник2014!$C$3:$D$6088;2;0);0)
J88 проверяемая ячейка
Справочник - это понятно
$C$3:$D$6088 диапазон справочника

Что такое "2" в формуле ?

Автор - Максим2
Дата добавления - 13.04.2018 в 10:14
китин Дата: Пятница, 13.04.2018, 10:16 | Сообщение № 12
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Что такое "2" в формуле ?

а справку по ВПР почитать не судьба?
Цитата
Самая простая функция ВПР означает следующее:

=ВПР(искомое значение; диапазон для поиска значения; номер столбца в диапазоне с возвращаемым значением; точное или приблизительное совпадение — указывается как 0/ЛОЖЬ или 1/ИСТИНА).


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Что такое "2" в формуле ?

а справку по ВПР почитать не судьба?
Цитата
Самая простая функция ВПР означает следующее:

=ВПР(искомое значение; диапазон для поиска значения; номер столбца в диапазоне с возвращаемым значением; точное или приблизительное совпадение — указывается как 0/ЛОЖЬ или 1/ИСТИНА).

Автор - китин
Дата добавления - 13.04.2018 в 10:16
Максим2 Дата: Пятница, 13.04.2018, 10:34 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Кто то мне написал ?

=ЕСЛИОШИБКА(ВПР(B5;Справочник2012!$B$3:$R$41;17;0);0)

Каой по счету 17 столбец Если их три всего в справочнике ???
К сообщению приложен файл: 2961626.xls(95.5 Kb)
 
Ответить
СообщениеКто то мне написал ?

=ЕСЛИОШИБКА(ВПР(B5;Справочник2012!$B$3:$R$41;17;0);0)

Каой по счету 17 столбец Если их три всего в справочнике ???

Автор - Максим2
Дата добавления - 13.04.2018 в 10:34
Максим2 Дата: Пятница, 13.04.2018, 10:38 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
R 18 столбец по счету , откуда же "17" ?
 
Ответить
СообщениеR 18 столбец по счету , откуда же "17" ?

Автор - Максим2
Дата добавления - 13.04.2018 в 10:38
китин Дата: Пятница, 13.04.2018, 10:48 | Сообщение № 15
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Каой по счету 17 столбец Если их три всего в справочнике ???

точно?


откуда же "17" ?

а диапазон то не с А начинается а с В столбца :p
К сообщению приложен файл: 8300819.gif(22.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Каой по счету 17 столбец Если их три всего в справочнике ???

точно?


откуда же "17" ?

а диапазон то не с А начинается а с В столбца :p

Автор - китин
Дата добавления - 13.04.2018 в 10:48
Максим2 Дата: Пятница, 13.04.2018, 10:49 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
"Важно не путать, что номер столбца указывается не по индексу на листе, а по порядку в указанном диапазоне." Как вообще считать этот столбец ?
 
Ответить
Сообщение"Важно не путать, что номер столбца указывается не по индексу на листе, а по порядку в указанном диапазоне." Как вообще считать этот столбец ?

Автор - Максим2
Дата добавления - 13.04.2018 в 10:49
Максим2 Дата: Пятница, 13.04.2018, 10:56 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все разобрался. Спасибо .
 
Ответить
СообщениеВсе разобрался. Спасибо .

Автор - Максим2
Дата добавления - 13.04.2018 в 10:56
китин Дата: Пятница, 13.04.2018, 10:58 | Сообщение № 18
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Как вообще считать этот столбец ?

от начала диапазона, но не от начала таблицы
у вас диапазон
Код
Справочник2012!$B$3:$R$41

значит считаем от столбца В
[p.s.]кстати оформите формулу в посте №11 и № 13 тэгами.пока наши добрейшей души модераторы не пришли


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Как вообще считать этот столбец ?

от начала диапазона, но не от начала таблицы
у вас диапазон
Код
Справочник2012!$B$3:$R$41

значит считаем от столбца В
[p.s.]кстати оформите формулу в посте №11 и № 13 тэгами.пока наши добрейшей души модераторы не пришли

Автор - китин
Дата добавления - 13.04.2018 в 10:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение одной ячейки и диапазоном с выводом значения. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!