Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по нескольким диапазонам в зависимости от даты. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по нескольким диапазонам в зависимости от даты. (Формулы/Formulas)
Суммирование по нескольким диапазонам в зависимости от даты.
AlexRoss Дата: Четверг, 28.06.2018, 06:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Столкнулся с проблемой решения задачи, прошу помощи в её решении.
В файле примера попытался реализовать суммирование по нескольким условиям, но не получилось.
В столбце I попытался использовать "СУММЕСЛИМН" но получить желаемого результата не смог.
В столбце K то, что необходимо получить (заполненность ячеек и результат) т.е. суммирование по столбцам D, E, G в зависимости от условий в столбцах А и С.
Задача состоит в том, чтоб получить результат в зависимости от критерия в столбца С и предшествующей даты, в столбце А (как не удачный пример, результат и формулы в столбцах I и J).
Нагромождение функций "СУММЕСЛИМН" в столбце J, так-же не привело к нужному результату.
Суммирование должно вестись из ближайшей даты в вычисляемой ячейке по условию из столбца С этой строки.
Например - строка 15, в ячейке D15 должно вестись вычисление от ближайшей даты к дате 12.04.2018 по условию в ячейке "С15" условие "Наименование 3".
Ближайшая дата по условию к ячейке "С15" - 03.04.2018, следовательно суммирование должно вестись из D5:E5;G5. Результат в ячейке D15 должен составлять - 36.
Строка 14 условие в ячейке "С14" условие "Наименование 1", ближайшая дата по условию к ячейке "С14" - 09.04.2018 и суммирование должно вестись из D12:E12;G12. Результат в ячейке D14 должен составлять - 20511.
И так далее...
Прошу посмотреть файл прикрепления.
Ниже строки 15 будет еще порядка 600-800 строк.
К сообщению приложен файл: 4706808.xlsx(10.5 Kb)
 
Ответить
СообщениеСтолкнулся с проблемой решения задачи, прошу помощи в её решении.
В файле примера попытался реализовать суммирование по нескольким условиям, но не получилось.
В столбце I попытался использовать "СУММЕСЛИМН" но получить желаемого результата не смог.
В столбце K то, что необходимо получить (заполненность ячеек и результат) т.е. суммирование по столбцам D, E, G в зависимости от условий в столбцах А и С.
Задача состоит в том, чтоб получить результат в зависимости от критерия в столбца С и предшествующей даты, в столбце А (как не удачный пример, результат и формулы в столбцах I и J).
Нагромождение функций "СУММЕСЛИМН" в столбце J, так-же не привело к нужному результату.
Суммирование должно вестись из ближайшей даты в вычисляемой ячейке по условию из столбца С этой строки.
Например - строка 15, в ячейке D15 должно вестись вычисление от ближайшей даты к дате 12.04.2018 по условию в ячейке "С15" условие "Наименование 3".
Ближайшая дата по условию к ячейке "С15" - 03.04.2018, следовательно суммирование должно вестись из D5:E5;G5. Результат в ячейке D15 должен составлять - 36.
Строка 14 условие в ячейке "С14" условие "Наименование 1", ближайшая дата по условию к ячейке "С14" - 09.04.2018 и суммирование должно вестись из D12:E12;G12. Результат в ячейке D14 должен составлять - 20511.
И так далее...
Прошу посмотреть файл прикрепления.
Ниже строки 15 будет еще порядка 600-800 строк.

Автор - AlexRoss
Дата добавления - 28.06.2018 в 06:29
Pelena Дата: Четверг, 28.06.2018, 08:41 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12830
Репутация: 2827 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Код
=СУММ(ИНДЕКС($D$3:$E11;ПОИСКПОЗ(ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11);$A$3:$A11;0);0))+ИНДЕКС($G$3:$G11;ПОИСКПОЗ(ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11);$A$3:$A11;0))

Если предположить, что значения в столбце F получаются как сумма D и E, формула будет раза в два короче.
Если в таблице не будет пустых строк, то можно ещё так
Код
=СУММПРОИЗВ(($D$3:$D11+$E$3:$E11+$G$3:$G11)*($C$3:$C11=C12)*($A$3:$A11=ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11)))
К сообщению приложен файл: 5575766.xlsx(11.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС($D$3:$E11;ПОИСКПОЗ(ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11);$A$3:$A11;0);0))+ИНДЕКС($G$3:$G11;ПОИСКПОЗ(ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11);$A$3:$A11;0))

Если предположить, что значения в столбце F получаются как сумма D и E, формула будет раза в два короче.
Если в таблице не будет пустых строк, то можно ещё так
Код
=СУММПРОИЗВ(($D$3:$D11+$E$3:$E11+$G$3:$G11)*($C$3:$C11=C12)*($A$3:$A11=ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11)))

Автор - Pelena
Дата добавления - 28.06.2018 в 08:41
AlexRoss Дата: Четверг, 28.06.2018, 17:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Ваш профессионализм просо восхищает и выше всяких похвал!
Большущее Вам человеческое спасибо от всего сердца!
Именно, значения в столбце F получаются как сумма D и E.

Один только вопрос, вторую формулу вводить как формулу массива или оставить как есть?
 
Ответить
СообщениеPelena, Ваш профессионализм просо восхищает и выше всяких похвал!
Большущее Вам человеческое спасибо от всего сердца!
Именно, значения в столбце F получаются как сумма D и E.

Один только вопрос, вторую формулу вводить как формулу массива или оставить как есть?

Автор - AlexRoss
Дата добавления - 28.06.2018 в 17:49
Pelena Дата: Четверг, 28.06.2018, 18:25 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12830
Репутация: 2827 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
значения в столбце F получаются как сумма D и E
В примере не везде так.
Тогда первая формула будет такая
Код
=СУММ(ИНДЕКС($F$3:$G11;ПОИСКПОЗ(ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11);$A$3:$A11;0);0))

Нет, массивный ввод для второй формулы не требуется


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
значения в столбце F получаются как сумма D и E
В примере не везде так.
Тогда первая формула будет такая
Код
=СУММ(ИНДЕКС($F$3:$G11;ПОИСКПОЗ(ПРОСМОТР(;-1/($C$3:$C11=C12);$A$3:$A11);$A$3:$A11;0);0))

Нет, массивный ввод для второй формулы не требуется

Автор - Pelena
Дата добавления - 28.06.2018 в 18:25
AlexRoss Дата: Четверг, 28.06.2018, 18:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Красота, да и только.
Теперь я совсем в растерянности от такого выбора обилия формул. %)
Какую всё-же лучше использовать? Массив данных до окончания года составит порядка 20000 строк.
Подскажите пожалуйста.
 
Ответить
СообщениеКрасота, да и только.
Теперь я совсем в растерянности от такого выбора обилия формул. %)
Какую всё-же лучше использовать? Массив данных до окончания года составит порядка 20000 строк.
Подскажите пожалуйста.

Автор - AlexRoss
Дата добавления - 28.06.2018 в 18:49
AlexRoss Дата: Четверг, 28.06.2018, 20:09 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Тогда первая формула будет такая


Посмотрите пожалуйста. Начал собирать таблицу и что-то пошло не так. :(
Начиная с 51 строки.
К сообщению приложен файл: 5550033.xlsx(24.0 Kb)
 
Ответить
Сообщение
Тогда первая формула будет такая


Посмотрите пожалуйста. Начал собирать таблицу и что-то пошло не так. :(
Начиная с 51 строки.

Автор - AlexRoss
Дата добавления - 28.06.2018 в 20:09
Pelena Дата: Четверг, 28.06.2018, 20:30 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12830
Репутация: 2827 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Проверьте так
К сообщению приложен файл: 2515498.xlsx(24.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПроверьте так

Автор - Pelena
Дата добавления - 28.06.2018 в 20:30
AlexRoss Дата: Пятница, 29.06.2018, 05:57 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Проверьте так


Да, работает отлично. Огромное, огромное спасибо Pelena!
 
Ответить
Сообщение
Проверьте так


Да, работает отлично. Огромное, огромное спасибо Pelena!

Автор - AlexRoss
Дата добавления - 29.06.2018 в 05:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по нескольким диапазонам в зависимости от даты. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!