Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести данные которые соответвуют условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести данные которые соответвуют условию (Формулы/Formulas)
Вывести данные которые соответвуют условию
stalber Дата: Вторник, 03.07.2018, 02:57 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Доброй ночи!

Задача: вывести названия которые соответствуют условию по формуле.

Файл прикрепил, обращаю внимания в нём 2 листа, 1-ый там данные, 2-ой лист там нужно вывести результат.

Помогите пожалуйста.
К сообщению приложен файл: _03072018.xlsx(10.4 Kb)


Сообщение отредактировал awaddwaawddw - Вторник, 03.07.2018, 02:58
 
Ответить
СообщениеДоброй ночи!

Задача: вывести названия которые соответствуют условию по формуле.

Файл прикрепил, обращаю внимания в нём 2 листа, 1-ый там данные, 2-ой лист там нужно вывести результат.

Помогите пожалуйста.

Автор - stalber
Дата добавления - 03.07.2018 в 02:57
_Boroda_ Дата: Вторник, 03.07.2018, 09:38 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?

Для D8
Код
=ИНДЕКС('3'!1:1;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ('3'!$C:$M)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3);999);СТОЛБЕЦ(B8)/2))&""
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Для Е8 обычная формула
Код
=ЕСЛИ(D8="";"";ИНДЕКС('3'!$F1:$P1/'3'!$G1:$Q1-1;ПОИСКПОЗ(D8;'3'!$C1:$M1;)))


Выделяете сразу обе ячейки и тянете сначала вправо, затем вниз (или наоборот)
К сообщению приложен файл: _03072018_1.xlsx(11.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?

Для D8
Код
=ИНДЕКС('3'!1:1;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ('3'!$C:$M)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3);999);СТОЛБЕЦ(B8)/2))&""
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Для Е8 обычная формула
Код
=ЕСЛИ(D8="";"";ИНДЕКС('3'!$F1:$P1/'3'!$G1:$Q1-1;ПОИСКПОЗ(D8;'3'!$C1:$M1;)))


Выделяете сразу обе ячейки и тянете сначала вправо, затем вниз (или наоборот)

Автор - _Boroda_
Дата добавления - 03.07.2018 в 09:38
stalber Дата: Понедельник, 09.07.2018, 22:45 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Будьте любезны, помогите пожалуйста.

Дополнительное условие к старой формуле: Из тех что получилось вывести, из них нужно оставить только те у которых левое число от и больше числа ---------> 15000

Конечная табличка нужна с учётом дополнительного условия.

Файл прикрепил, с примером проще объяснить, там тоже пояснения.
К сообщению приложен файл: _03072018_1_dop.xlsx(11.8 Kb)


Сообщение отредактировал awaddwaawddw - Понедельник, 09.07.2018, 22:47
 
Ответить
СообщениеБудьте любезны, помогите пожалуйста.

Дополнительное условие к старой формуле: Из тех что получилось вывести, из них нужно оставить только те у которых левое число от и больше числа ---------> 15000

Конечная табличка нужна с учётом дополнительного условия.

Файл прикрепил, с примером проще объяснить, там тоже пояснения.

Автор - stalber
Дата добавления - 09.07.2018 в 22:45
_Boroda_ Дата: Понедельник, 09.07.2018, 22:54 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС('3'!1:1;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ('3'!$C:$M)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4);999);СТОЛБЕЦ(B8)/2))&""
К сообщению приложен файл: 0215662.xlsx(12.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС('3'!1:1;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ('3'!$C:$M)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4);999);СТОЛБЕЦ(B8)/2))&""

Автор - _Boroda_
Дата добавления - 09.07.2018 в 22:54
stalber Дата: Понедельник, 09.07.2018, 22:58 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Спасибо! То что нужно, вопрос касаемо формулы: что такое в формуле число 999 и ещё вопрос что за ячейка B8 в формуле (она пустая).
 
Ответить
СообщениеСпасибо! То что нужно, вопрос касаемо формулы: что такое в формуле число 999 и ещё вопрос что за ячейка B8 в формуле (она пустая).

Автор - stalber
Дата добавления - 09.07.2018 в 22:58
_Boroda_ Дата: Вторник, 10.07.2018, 09:23 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
999 - просто число, заведомо бОльшее количества заполненных в таблице столбцов.
Код
ИНДЕКС(1:1;999)
(для понятности лучше написать так
Код
ИНДЕКС(1:1;1;999)
)даст ссылку на ячейку первой строки и 999-го столбца, которая точно пустая. Формула =ПустаяЯчейка даст нам ноль, чтобы этого избежать, мы приклеиваем справа пустоту, вот этот кусок формулы - &"". Тогда =ПустаяЯчейка&"" даст нам пусто

Что за ячейка В8 - это совершенно неважно. Важно то, что там не просто В8 написано, а СТОЛБЕЦ(В8). Функция СТОЛБЕЦ возвращает номер столбца ячейки(ек) аргумента. Другими словами, СТОЛБЕЦ(В8)=СТОЛБЕЦ(В1)=СТОЛБЕЦ(В99999)=2 - номеру столбца для ячейки В8. При протягивании вправо ссылка смещается (В-С-D-...) и номер столбца тоже (2-3-4-...). А все это мы подсовываем во второй аргумент функции НАИМЕНЬШИЙ


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение999 - просто число, заведомо бОльшее количества заполненных в таблице столбцов.
Код
ИНДЕКС(1:1;999)
(для понятности лучше написать так
Код
ИНДЕКС(1:1;1;999)
)даст ссылку на ячейку первой строки и 999-го столбца, которая точно пустая. Формула =ПустаяЯчейка даст нам ноль, чтобы этого избежать, мы приклеиваем справа пустоту, вот этот кусок формулы - &"". Тогда =ПустаяЯчейка&"" даст нам пусто

Что за ячейка В8 - это совершенно неважно. Важно то, что там не просто В8 написано, а СТОЛБЕЦ(В8). Функция СТОЛБЕЦ возвращает номер столбца ячейки(ек) аргумента. Другими словами, СТОЛБЕЦ(В8)=СТОЛБЕЦ(В1)=СТОЛБЕЦ(В99999)=2 - номеру столбца для ячейки В8. При протягивании вправо ссылка смещается (В-С-D-...) и номер столбца тоже (2-3-4-...). А все это мы подсовываем во второй аргумент функции НАИМЕНЬШИЙ

Автор - _Boroda_
Дата добавления - 10.07.2018 в 09:23
stalber Дата: Понедельник, 16.07.2018, 01:45 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Будьте добры, что нужно подправить в формуле?
Раньше в столбцах D E, I J, N O был текст, теперь числа, из за этого формула видимо учитывает эти числа и показывает в итоговой таблицы лишние данные.
К сообщению приложен файл: 111222333.xlsx(15.2 Kb)
 
Ответить
СообщениеБудьте добры, что нужно подправить в формуле?
Раньше в столбцах D E, I J, N O был текст, теперь числа, из за этого формула видимо учитывает эти числа и показывает в итоговой таблицы лишние данные.

Автор - stalber
Дата добавления - 16.07.2018 в 01:45
_Boroda_ Дата: Понедельник, 16.07.2018, 09:11 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС('3'!1:1;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ('3'!$C:$M)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4)/ЕТЕКСТ('3'!$C1:$M1);999);СТОЛБЕЦ(B8)/2))&""
К сообщению приложен файл: 111222333_1.xlsx(15.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС('3'!1:1;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ('3'!$C:$M)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4)/ЕТЕКСТ('3'!$C1:$M1);999);СТОЛБЕЦ(B8)/2))&""

Автор - _Boroda_
Дата добавления - 16.07.2018 в 09:11
stalber Дата: Пятница, 20.07.2018, 22:54 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер :-)

Помогите пожалуйста, как сделать чтобы конечная таблица, она выводилась по убыванию слева на право.

В экселе наглядно показано, что сейчас и что нужно.
К сообщению приложен файл: vopros_20072018.xlsx(16.1 Kb)
 
Ответить
СообщениеДобрый вечер :-)

Помогите пожалуйста, как сделать чтобы конечная таблица, она выводилась по убыванию слева на право.

В экселе наглядно показано, что сейчас и что нужно.

Автор - stalber
Дата добавления - 20.07.2018 в 22:54
stalber Дата: Воскресенье, 22.07.2018, 22:50 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
актуально последнее сообщение, помогите пожалуйста


Сообщение отредактировал awaddwaawddw - Воскресенье, 22.07.2018, 22:50
 
Ответить
Сообщениеактуально последнее сообщение, помогите пожалуйста

Автор - stalber
Дата добавления - 22.07.2018 в 22:50
_Boroda_ Дата: Понедельник, 23.07.2018, 00:41 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13509
Репутация: 5528 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Извините, что-то пропустил я Ваш вопрос
Код
=ИНДЕКС('3'!1:1;ПРАВБ(НАИБОЛЬШИЙ(ЕСЛИОШИБКА((ОКРУГЛ('3'!$F1:$P1/'3'!$G1:$Q1;6)+СТОЛБЕЦ('3'!$C:$M)%%%%)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4)/ЕТЕКСТ('3'!$C1:$M1););СТОЛБЕЦ(B8)/2);2)+0,1)&""
К сообщению приложен файл: 4751428.xlsx(16.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИзвините, что-то пропустил я Ваш вопрос
Код
=ИНДЕКС('3'!1:1;ПРАВБ(НАИБОЛЬШИЙ(ЕСЛИОШИБКА((ОКРУГЛ('3'!$F1:$P1/'3'!$G1:$Q1;6)+СТОЛБЕЦ('3'!$C:$M)%%%%)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4)/ЕТЕКСТ('3'!$C1:$M1););СТОЛБЕЦ(B8)/2);2)+0,1)&""

Автор - _Boroda_
Дата добавления - 23.07.2018 в 00:41
stalber Дата: Среда, 01.08.2018, 18:07 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Помогите пожалуйста, конечную формулу внедрить в эту таблицу. (файл прикрепил) Как только не перепробовал, всё не получается, с ошибками всё выходит.

[vba]
Код
=ЕСЛИ(D8="";"";ИНДЕКС('3'!$F1:$P1/'3'!$G1:$Q1-1;ПОИСКПОЗ(D8;'3'!$C1:$M1;)))
[/vba]

[vba]
Код
=ИНДЕКС('3'!1:1;ПРАВБ(НАИБОЛЬШИЙ(ЕСЛИОШИБКА((ОКРУГЛ('3'!$F1:$P1/'3'!$G1:$Q1;6)+СТОЛБЕЦ('3'!$C:$M)%%%%)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4)/ЕТЕКСТ('3'!$C1:$M1););СТОЛБЕЦ(B8)/2);2)+0,1)&""
[/vba]
К сообщению приложен файл: vnedritj_formul.xlsx(31.1 Kb)
 
Ответить
СообщениеПомогите пожалуйста, конечную формулу внедрить в эту таблицу. (файл прикрепил) Как только не перепробовал, всё не получается, с ошибками всё выходит.

[vba]
Код
=ЕСЛИ(D8="";"";ИНДЕКС('3'!$F1:$P1/'3'!$G1:$Q1-1;ПОИСКПОЗ(D8;'3'!$C1:$M1;)))
[/vba]

[vba]
Код
=ИНДЕКС('3'!1:1;ПРАВБ(НАИБОЛЬШИЙ(ЕСЛИОШИБКА((ОКРУГЛ('3'!$F1:$P1/'3'!$G1:$Q1;6)+СТОЛБЕЦ('3'!$C:$M)%%%%)/(('3'!$F1:$P1/'3'!$G1:$Q1-1)>$D$3)/('3'!$F1:$P1>$D$4)/ЕТЕКСТ('3'!$C1:$M1););СТОЛБЕЦ(B8)/2);2)+0,1)&""
[/vba]

Автор - stalber
Дата добавления - 01.08.2018 в 18:07
Pelena Дата: Среда, 01.08.2018, 21:38 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 13223
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так нужно?
К сообщению приложен файл: 6854567.xlsx(32.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак нужно?

Автор - Pelena
Дата добавления - 01.08.2018 в 21:38
stalber Дата: Четверг, 02.08.2018, 13:41 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Понял почему у меня не получалось!

Я добавил колонки A и B дата и время, формула видимо как то учитывает эти колонки, в связи с чем данные отображаются верно, но появляется лишний мусор в пустых ячейках.

Помогите пожалуйста исправить? Файл прикрепил.
К сообщению приложен файл: excel_sprositj.xlsx(33.6 Kb)


Сообщение отредактировал awaddwaawddw - Четверг, 02.08.2018, 13:41
 
Ответить
СообщениеПонял почему у меня не получалось!

Я добавил колонки A и B дата и время, формула видимо как то учитывает эти колонки, в связи с чем данные отображаются верно, но появляется лишний мусор в пустых ячейках.

Помогите пожалуйста исправить? Файл прикрепил.

Автор - stalber
Дата добавления - 02.08.2018 в 13:41
Pelena Дата: Четверг, 02.08.2018, 15:00 | Сообщение № 15
Группа: Админы
Ранг: Местный житель
Сообщений: 13223
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Поэтому и сказано в Правилах: сохраняйте структуру файла.
Можно так
К сообщению приложен файл: 5702300.xlsx(32.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПоэтому и сказано в Правилах: сохраняйте структуру файла.
Можно так

Автор - Pelena
Дата добавления - 02.08.2018 в 15:00
EvgenyAgeev Дата: Четверг, 02.08.2018, 15:07 | Сообщение № 16
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Друзья, всем привет.

Прошу помощи. Во вложении табель. Проблемы с вкладкой "Июль 2018". Она формируется из вкладки "Список бригады". Суть такая - во вкладке "Список бригады" проставляются галочки напротив тех сотрудников, которых нужно внести в табель. Дальше по условию я просто дублирую этот список людей во вкладку "Июль 2018" (потом этот столбец скроется). Для первого человека формула готова - она определяет первого сотрудника в столбце и выводит в ячейку, это то, что нужно.

Проблема с последующими людьми: нужно, чтобы формула определяла первого человека в ячейке С3, пробегалась по ячейкам столбца В, находила этого сотрудника, исключала, а сразу следующего сотрудника, видимого в ячейке (не обязательно следующей сразу за "исключенным" сотрудником) выводила в ячейку С14 и так далее вниз соответственно.

Не хватает мозгов, как это сделать :(

Вопрос задавал здесь, но там тишина.
К сообщению приложен файл: 5310825.xlsx(36.7 Kb) · 2606680.png(117.3 Kb)


Сообщение отредактировал EvgenyAgeev - Четверг, 02.08.2018, 15:11
 
Ответить
СообщениеДрузья, всем привет.

Прошу помощи. Во вложении табель. Проблемы с вкладкой "Июль 2018". Она формируется из вкладки "Список бригады". Суть такая - во вкладке "Список бригады" проставляются галочки напротив тех сотрудников, которых нужно внести в табель. Дальше по условию я просто дублирую этот список людей во вкладку "Июль 2018" (потом этот столбец скроется). Для первого человека формула готова - она определяет первого сотрудника в столбце и выводит в ячейку, это то, что нужно.

Проблема с последующими людьми: нужно, чтобы формула определяла первого человека в ячейке С3, пробегалась по ячейкам столбца В, находила этого сотрудника, исключала, а сразу следующего сотрудника, видимого в ячейке (не обязательно следующей сразу за "исключенным" сотрудником) выводила в ячейку С14 и так далее вниз соответственно.

Не хватает мозгов, как это сделать :(

Вопрос задавал здесь, но там тишина.

Автор - EvgenyAgeev
Дата добавления - 02.08.2018 в 15:07
Pelena Дата: Четверг, 02.08.2018, 15:10 | Сообщение № 17
Группа: Админы
Ранг: Местный житель
Сообщений: 13223
Репутация: 2909 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
EvgenyAgeev, прочитайте Правила форума и создайте свою тему


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеEvgenyAgeev, прочитайте Правила форума и создайте свою тему

Автор - Pelena
Дата добавления - 02.08.2018 в 15:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести данные которые соответвуют условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!