Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение дубликатов данных таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение дубликатов данных таблицы (Формулы/Formulas)
Объединение дубликатов данных таблицы
Tallen Дата: Понедельник, 09.07.2018, 09:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые специалисты Excel!
Подскажите пожалуйста: возможно ли автоматизировать процесс слияния данных строк с одинаковыми номенклатурными номерами?
Вручную долго, таблица в реальности очень большая. В столбце А номенклатурные номера (дубликаты подкрасила при помощи надстройки), дальше.. тупик. В столбце С нужно чтобы количество суммировалось, в Е цена становилась усредненная, в диапазоне G:J данные тоже складывались.
К сообщению приложен файл: 5171653.xls(37.5 Kb)


Сообщение отредактировал Tallen - Понедельник, 09.07.2018, 09:48
 
Ответить
СообщениеЗдравствуйте, уважаемые специалисты Excel!
Подскажите пожалуйста: возможно ли автоматизировать процесс слияния данных строк с одинаковыми номенклатурными номерами?
Вручную долго, таблица в реальности очень большая. В столбце А номенклатурные номера (дубликаты подкрасила при помощи надстройки), дальше.. тупик. В столбце С нужно чтобы количество суммировалось, в Е цена становилась усредненная, в диапазоне G:J данные тоже складывались.

Автор - Tallen
Дата добавления - 09.07.2018 в 09:42
sboy Дата: Понедельник, 09.07.2018, 09:57 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2063
Репутация: 593 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Самый простой вариант собрать сводной таблицей
К сообщению приложен файл: 7338326.xls(43.0 Kb)
 
Ответить
СообщениеДобрый день.
Самый простой вариант собрать сводной таблицей

Автор - sboy
Дата добавления - 09.07.2018 в 09:57
Tallen Дата: Понедельник, 09.07.2018, 10:05 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, спасибо! То, что надо ))
 
Ответить
Сообщениеsboy, спасибо! То, что надо ))

Автор - Tallen
Дата добавления - 09.07.2018 в 10:05
_Boroda_ Дата: Понедельник, 09.07.2018, 10:13 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12981
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня тоже сначала сводной таблицей, потом из нее в обычную тянется. И границы ставятся Условным форматированием
К сообщению приложен файл: 5171653_1.xls(72.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня тоже сначала сводной таблицей, потом из нее в обычную тянется. И границы ставятся Условным форматированием

Автор - _Boroda_
Дата добавления - 09.07.2018 в 10:13
Tallen Дата: Понедельник, 09.07.2018, 10:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, спасибо!!!
 
Ответить
Сообщение_Boroda_, спасибо!!!

Автор - Tallen
Дата добавления - 09.07.2018 в 10:41
Tallen Дата: Пятница, 27.07.2018, 14:51 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, подскажите пожалуйста что я неправильно делаю? В Вашу таблицу добавила больше своих данных.
1. на листе 3 в сводной таблице почему "пусто" выскакивает в строке 16?
2. на листе 4 есть строки (например 34, 35, 39), в которых не проставляются данные.
В чем моя ошибка?
К сообщению приложен файл: 11.xlsx(91.1 Kb)
 
Ответить
Сообщение_Boroda_, подскажите пожалуйста что я неправильно делаю? В Вашу таблицу добавила больше своих данных.
1. на листе 3 в сводной таблице почему "пусто" выскакивает в строке 16?
2. на листе 4 есть строки (например 34, 35, 39), в которых не проставляются данные.
В чем моя ошибка?

Автор - Tallen
Дата добавления - 27.07.2018 в 14:51
_Boroda_ Дата: Пятница, 27.07.2018, 15:31 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12981
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1. Отсортируйте в Лист3 сводную по возрастанию столбца А.
2. Все ВПРы перепишите с ОКРУГЛ, вот так
Код
=ЕСЛИОШИБКА(ВПР(ОКРУГЛ(A3;0);Лист1!A$3:B$999;2;);"")

или в столбце А вот так напишите (лучше так сделайте, чем ОКРУГЛ)
Код
=ЕСЛИ(ЕЧИСЛО(Лист3!A5);Лист3!A5;"")
К сообщению приложен файл: 11-6-1.xlsx(88.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1. Отсортируйте в Лист3 сводную по возрастанию столбца А.
2. Все ВПРы перепишите с ОКРУГЛ, вот так
Код
=ЕСЛИОШИБКА(ВПР(ОКРУГЛ(A3;0);Лист1!A$3:B$999;2;);"")

или в столбце А вот так напишите (лучше так сделайте, чем ОКРУГЛ)
Код
=ЕСЛИ(ЕЧИСЛО(Лист3!A5);Лист3!A5;"")

Автор - _Boroda_
Дата добавления - 27.07.2018 в 15:31
Tallen Дата: Понедельник, 30.07.2018, 09:24 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, спасибо большое!
 
Ответить
Сообщение_Boroda_, спасибо большое!

Автор - Tallen
Дата добавления - 30.07.2018 в 09:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение дубликатов данных таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!