Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отбор из диапазона всех совпадений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отбор из диапазона всех совпадений (Формулы/Formulas)
Отбор из диапазона всех совпадений
AVI Дата: Суббота, 21.07.2018, 17:44 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 355
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
В этой http://www.excelworld.ru/forum/2-38618-1 теме есть что-то похожее, но я не понял как сделать то, что мне нужно.
Мне нужно, что бы в результат попадали все, что удовлетворяет обоим условиям. Как в примере.

И еще вопрос: планируется, что данных будет все больше и больше. Если написать макрос для описанной процедуры - он будет работать быстрее, чем формула?

Исправил
К сообщению приложен файл: _Microsoft_Exce.xlsx(8.8 Kb)


Сообщение отредактировал AVI - Суббота, 21.07.2018, 18:58
 
Ответить
СообщениеДобрый день!
В этой http://www.excelworld.ru/forum/2-38618-1 теме есть что-то похожее, но я не понял как сделать то, что мне нужно.
Мне нужно, что бы в результат попадали все, что удовлетворяет обоим условиям. Как в примере.

И еще вопрос: планируется, что данных будет все больше и больше. Если написать макрос для описанной процедуры - он будет работать быстрее, чем формула?

Исправил

Автор - AVI
Дата добавления - 21.07.2018 в 17:44
Светлый Дата: Суббота, 21.07.2018, 18:24 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Файл пустой.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Файл пустой.

Автор - Светлый
Дата добавления - 21.07.2018 в 18:24
Светлый Дата: Суббота, 21.07.2018, 19:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ(D$1&D$2=N$2:N$29&O$2:O$29;СТРОКА($2:$29));СТРОКА(C1)));"")

А если без повторений:
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ((D$1&D$2=N$2:N$29&O$2:O$29)*(ПОИСКПОЗ(N$2:N$29&O$2:O$29&P$2:P$29;N$2:N$29&O$2:O$29&P$2:P$29;)=СТРОКА($1:$28));СТРОКА($2:$29));СТРОКА(C1)));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 21.07.2018, 19:41
 
Ответить
СообщениеФормула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ(D$1&D$2=N$2:N$29&O$2:O$29;СТРОКА($2:$29));СТРОКА(C1)));"")

А если без повторений:
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ((D$1&D$2=N$2:N$29&O$2:O$29)*(ПОИСКПОЗ(N$2:N$29&O$2:O$29&P$2:P$29;N$2:N$29&O$2:O$29&P$2:P$29;)=СТРОКА($1:$28));СТРОКА($2:$29));СТРОКА(C1)));"")

Автор - Светлый
Дата добавления - 21.07.2018 в 19:25
jakim Дата: Суббота, 21.07.2018, 20:11 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 843
Репутация: 223 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(INDEX(P$2:P$2200;AGGREGATE(15;6;ROW(A$1:A$2200)/(N$2:N$2200=D$1)/(O$2:O$2200=D$2);ROWS($7:7)));"")
К сообщению приложен файл: Microsoft_Exce.xlsx(9.3 Kb)
 
Ответить
Сообщение
Формула

Код
=IFERROR(INDEX(P$2:P$2200;AGGREGATE(15;6;ROW(A$1:A$2200)/(N$2:N$2200=D$1)/(O$2:O$2200=D$2);ROWS($7:7)));"")

Автор - jakim
Дата добавления - 21.07.2018 в 20:11
AVI Дата: Воскресенье, 22.07.2018, 05:39 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 355
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Спасибо за ответы!

Я все пытаюсь разобраться. Вроде понимаю, а вроде нет.

Вот пример такого же вопроса, только данные другие.

Одно условие и цифровое. У меня самого получается найти, но отразить полученный результат так как в столбце D никак не получается. Там какая-то магия с
Код
Наименьший()
и
Код
Строка()
, но никак мне не даются эти массивы...
К сообщению приложен файл: 1743508.xlsx(10.1 Kb)
 
Ответить
СообщениеСпасибо за ответы!

Я все пытаюсь разобраться. Вроде понимаю, а вроде нет.

Вот пример такого же вопроса, только данные другие.

Одно условие и цифровое. У меня самого получается найти, но отразить полученный результат так как в столбце D никак не получается. Там какая-то магия с
Код
Наименьший()
и
Код
Строка()
, но никак мне не даются эти массивы...

Автор - AVI
Дата добавления - 22.07.2018 в 05:39
Светлый Дата: Воскресенье, 22.07.2018, 10:30 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 132 ±
Замечаний: 0% ±

Excel 2007
Формула (массивная) должна быть такая;
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ($B$1=Таблица1[А];СТРОКА(Таблица1[Б]));СТРОКА(F1)));"")

По ЕСЛИ определяем строки с 3 и задаём им значение номера строки. Остальные останутся со значением ЛОЖЬ. Функция НАИМЕНЬШИЙ определяет этот номер, соответствующий строке в результирующей таблице. А ИНДЕКС берёт само значение.
Доб.
В Функции СТРОКА используем ячейки таблицы для синхронизации формулы при изменении размеров таблицы. Можно было бы использовать СТРОКА($2;$25).


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Воскресенье, 22.07.2018, 10:37
 
Ответить
СообщениеФормула (массивная) должна быть такая;
Код
=ЕСЛИОШИБКА(ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ($B$1=Таблица1[А];СТРОКА(Таблица1[Б]));СТРОКА(F1)));"")

По ЕСЛИ определяем строки с 3 и задаём им значение номера строки. Остальные останутся со значением ЛОЖЬ. Функция НАИМЕНЬШИЙ определяет этот номер, соответствующий строке в результирующей таблице. А ИНДЕКС берёт само значение.
Доб.
В Функции СТРОКА используем ячейки таблицы для синхронизации формулы при изменении размеров таблицы. Можно было бы использовать СТРОКА($2;$25).

Автор - Светлый
Дата добавления - 22.07.2018 в 10:30
_Boroda_ Дата: Воскресенье, 22.07.2018, 22:27 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12761
Репутация: 5228 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулы (тоже массивная, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ(B$1=Таблица1[А];СТРОКА(Таблица1[Б]);9^6);СТРОКА(I1)))&""
К сообщению приложен файл: 1743508_1.xlsx(10.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулы (тоже массивная, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(P:P;НАИМЕНЬШИЙ(ЕСЛИ(B$1=Таблица1[А];СТРОКА(Таблица1[Б]);9^6);СТРОКА(I1)))&""

Автор - _Boroda_
Дата добавления - 22.07.2018 в 22:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отбор из диапазона всех совпадений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!