Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование чисел через заданное количество строк. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование чисел через заданное количество строк. (Формулы/Formulas)
Суммирование чисел через заданное количество строк.
deus_russia Дата: Вторник, 30.10.2018, 07:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, друзья!
Столкнулся с тем, что не получается суммировать данные из другого листа. При этом суммировать их необходимо через каждые 5 строк. Для примера прикрепил файл. В листе "Деньги" в колонке "В" нужно сделать так чтобы информация бралась из листа "Доходы" колонки "L" начиная с L6, затем L11, после L16 и так далее, каждый раз +5.
Заранее всем спасибо!
К сообщению приложен файл: 5525455.xlsx(47.2 Kb)
 
Ответить
СообщениеЗдравствуйте, друзья!
Столкнулся с тем, что не получается суммировать данные из другого листа. При этом суммировать их необходимо через каждые 5 строк. Для примера прикрепил файл. В листе "Деньги" в колонке "В" нужно сделать так чтобы информация бралась из листа "Доходы" колонки "L" начиная с L6, затем L11, после L16 и так далее, каждый раз +5.
Заранее всем спасибо!

Автор - deus_russia
Дата добавления - 30.10.2018 в 07:50
китин Дата: Вторник, 30.10.2018, 08:18 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5103
Репутация: 809 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и вам!!!
чисто по примеру
Код
=0+СУММЕСЛИ(Доходы!$A$6:$A$155;Деньги!$A5;Доходы!$L$6:$L$155)
К сообщению приложен файл: deus_russia.xlsx(48.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго и вам!!!
чисто по примеру
Код
=0+СУММЕСЛИ(Доходы!$A$6:$A$155;Деньги!$A5;Доходы!$L$6:$L$155)

Автор - китин
Дата добавления - 30.10.2018 в 08:18
_Boroda_ Дата: Вторник, 30.10.2018, 09:08 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=ВПР(A5;Доходы!A$6:L$999;12;)

Лучше наверное с проверкой на ошибку
Код
=еслиошибка(ВПР(A5;Доходы!A$6:L$999;12;);)

еще
Код
=ИНДЕКС(Доходы!L$6:L$999;ПОИСКПОЗ(A5;Доходы!A$6:A$999;))

Код
=СУММПРОИЗВ((A5=Доходы!A$6:A$999)*Доходы!L$6:L$999)

Код
=ПРОСМОТР(A5;Доходы!A$6:A$999;Доходы!L$6:L$999)
К сообщению приложен файл: 5525455_1.xlsx(46.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=ВПР(A5;Доходы!A$6:L$999;12;)

Лучше наверное с проверкой на ошибку
Код
=еслиошибка(ВПР(A5;Доходы!A$6:L$999;12;);)

еще
Код
=ИНДЕКС(Доходы!L$6:L$999;ПОИСКПОЗ(A5;Доходы!A$6:A$999;))

Код
=СУММПРОИЗВ((A5=Доходы!A$6:A$999)*Доходы!L$6:L$999)

Код
=ПРОСМОТР(A5;Доходы!A$6:A$999;Доходы!L$6:L$999)

Автор - _Boroda_
Дата добавления - 30.10.2018 в 09:08
deus_russia Дата: Среда, 31.10.2018, 08:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, китин, Спасибо за помощь!
 
Ответить
Сообщение_Boroda_, китин, Спасибо за помощь!

Автор - deus_russia
Дата добавления - 31.10.2018 в 08:50
deus_russia Дата: Среда, 31.10.2018, 09:16 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Столкнулся с еще одной похожей проблемой. Но теперь нужно посчитать в одной ячейке сразу за месяц. Файл приложил.
Еще раз спасибо )
К сообщению приложен файл: 6528745.xlsx(39.3 Kb)
 
Ответить
СообщениеСтолкнулся с еще одной похожей проблемой. Но теперь нужно посчитать в одной ячейке сразу за месяц. Файл приложил.
Еще раз спасибо )

Автор - deus_russia
Дата добавления - 31.10.2018 в 09:16
_Boroda_ Дата: Среда, 31.10.2018, 09:51 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(Доходы!B:B;"Общая сумма";Доходы!C:C)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(Доходы!B:B;"Общая сумма";Доходы!C:C)

Автор - _Boroda_
Дата добавления - 31.10.2018 в 09:51
deus_russia Дата: Четверг, 01.11.2018, 03:28 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Спасибо за ваш ответ! Формула немного не подходит. В случае добавления новых дат, например следующего месяца и прописывания сумм в этих датах (сейчас там даты с 1.09 по 30.09) сумма в ячейке продолжает считать суммы и по ним. Нужно сделать так, чтобы считались только по заданному диапазону. В моем случае диапазон равен одному месяцу.
 
Ответить
Сообщение_Boroda_, Спасибо за ваш ответ! Формула немного не подходит. В случае добавления новых дат, например следующего месяца и прописывания сумм в этих датах (сейчас там даты с 1.09 по 30.09) сумма в ячейке продолжает считать суммы и по ним. Нужно сделать так, чтобы считались только по заданному диапазону. В моем случае диапазон равен одному месяцу.

Автор - deus_russia
Дата добавления - 01.11.2018 в 03:28
_Boroda_ Дата: Четверг, 01.11.2018, 09:34 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
deus_russia, Вы в следующий раз пример делайте с учетом всяких "в случае добавления". Откуда мы знать могли? Тем более, что в X1 стоит январь 2017
Если переписать Х1 на 01.09.2018, то (файл _2)
Код
=СУММЕСЛИМН(Доходы!C$7:C$999;Доходы!B$7:B$999;"Общая сумма";Доходы!A$6:A$998;">="&X1;Доходы!A$6:A$998;"<="&КОНМЕСЯЦА(X1;0))

А если потом еще и имена справа добавятся, то вот так можно (файл _1)
Код
=СУММПРОИЗВ(Доходы!$C$7:$V$999*(Доходы!$B$7:$B$999="Общая сумма")*(ТЕКСТ(Доходы!$A$6:$A$998;"МГ")=ТЕКСТ(X$1;"МГ"))*(Доходы!$C$3:$V$3=B3))
К сообщению приложен файл: 6528745-1-2.xlsx(38.9 Kb) · 6528745-1-1.xlsx(41.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеdeus_russia, Вы в следующий раз пример делайте с учетом всяких "в случае добавления". Откуда мы знать могли? Тем более, что в X1 стоит январь 2017
Если переписать Х1 на 01.09.2018, то (файл _2)
Код
=СУММЕСЛИМН(Доходы!C$7:C$999;Доходы!B$7:B$999;"Общая сумма";Доходы!A$6:A$998;">="&X1;Доходы!A$6:A$998;"<="&КОНМЕСЯЦА(X1;0))

А если потом еще и имена справа добавятся, то вот так можно (файл _1)
Код
=СУММПРОИЗВ(Доходы!$C$7:$V$999*(Доходы!$B$7:$B$999="Общая сумма")*(ТЕКСТ(Доходы!$A$6:$A$998;"МГ")=ТЕКСТ(X$1;"МГ"))*(Доходы!$C$3:$V$3=B3))

Автор - _Boroda_
Дата добавления - 01.11.2018 в 09:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование чисел через заданное количество строк. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!