Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматизированный график работ сутки-трое. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматизированный график работ сутки-трое. (Формулы/Formulas)
Автоматизированный график работ сутки-трое.
PORTANDREW Дата: Суббота, 24.11.2018, 18:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток дорогие форумчане!
Проблема такова: решил сочинить график работы сутки через трое, да такой чтобы он был автоматизированный, да мозгов не хватило правильно написать формулу. Нашел у одного человека видео в ютубе, сделал подобный, график конечно классный, но его формула работает на пятидневку. Мне такой не подходит, нужно сутки-трое. Может кто поможет, подскажет правильную формулу? Желательно чтобы ячейки закрашивались или буква "С" - сутки, ставилась в нужную клетку.
Пример
К сообщению приложен файл: _2.xlsx(15.4 Kb)


ZAC

Сообщение отредактировал PORTANDREW - Суббота, 24.11.2018, 18:02
 
Ответить
СообщениеДоброго времени суток дорогие форумчане!
Проблема такова: решил сочинить график работы сутки через трое, да такой чтобы он был автоматизированный, да мозгов не хватило правильно написать формулу. Нашел у одного человека видео в ютубе, сделал подобный, график конечно классный, но его формула работает на пятидневку. Мне такой не подходит, нужно сутки-трое. Может кто поможет, подскажет правильную формулу? Желательно чтобы ячейки закрашивались или буква "С" - сутки, ставилась в нужную клетку.
Пример

Автор - PORTANDREW
Дата добавления - 24.11.2018 в 18:00
Pelena Дата: Суббота, 24.11.2018, 18:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13300
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Как-то так
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ОСТАТ(F$8-$E9;4);$C9="");"";"с");"")
К сообщению приложен файл: _2-2-.xlsx(17.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как-то так
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ОСТАТ(F$8-$E9;4);$C9="");"";"с");"")

Автор - Pelena
Дата добавления - 24.11.2018 в 18:31
jakim Дата: Суббота, 24.11.2018, 19:13 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 858
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
Вариант с применением условного форматирования формулами

Код
=MOD(F$8;4)=0;1;2;3

и формулы

Код
=IF(MONTH(DATE($E$4;$D$4;COLUMNS($F:F)))=$D$4;DATE($E$4;$D$4;COLUMNS($F:F));"")

для заполнения дат в 8 строке графика.
К сообщению приложен файл: Kopija-2.xlsx(15.8 Kb)


Сообщение отредактировал jakim - Суббота, 24.11.2018, 19:15
 
Ответить
Сообщение
Вариант с применением условного форматирования формулами

Код
=MOD(F$8;4)=0;1;2;3

и формулы

Код
=IF(MONTH(DATE($E$4;$D$4;COLUMNS($F:F)))=$D$4;DATE($E$4;$D$4;COLUMNS($F:F));"")

для заполнения дат в 8 строке графика.

Автор - jakim
Дата добавления - 24.11.2018 в 19:13
PORTANDREW Дата: Суббота, 24.11.2018, 19:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Это просто ШИКАРНО!!!
Огромное Вам спасибо!!!


ZAC
 
Ответить
СообщениеPelena, Это просто ШИКАРНО!!!
Огромное Вам спасибо!!!

Автор - PORTANDREW
Дата добавления - 24.11.2018 в 19:23
PORTANDREW Дата: Суббота, 24.11.2018, 19:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
[size=15] jakim, Благодарю! Как аналогичный метод тоже хорош!!!
Эх, мне до таких просветленных мозгов ещё далеко! Честно, сам бы не допёр.
Огромное всем спасибо![/size]


ZAC

Сообщение отредактировал PORTANDREW - Суббота, 24.11.2018, 19:32
 
Ответить
Сообщение[size=15] jakim, Благодарю! Как аналогичный метод тоже хорош!!!
Эх, мне до таких просветленных мозгов ещё далеко! Честно, сам бы не допёр.
Огромное всем спасибо![/size]

Автор - PORTANDREW
Дата добавления - 24.11.2018 в 19:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматизированный график работ сутки-трое. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!