Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование и поиск значений из данных ячейки до символа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование и поиск значений из данных ячейки до символа (Формулы/Formulas)
Суммирование и поиск значений из данных ячейки до символа
Dfgq Дата: Пятница, 04.01.2019, 22:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую, товарищи!

В документе имеется два листа. На первом большая таблица, в которую заносятся исключительно числа, состоящая из полсотни строк и 15 граф.
На втором листе таблица с разноской, из которых в автоматическом режиме таблица на первом листе должна заполнятся.

В сведениях на листе 2 имеется столбец с ячейками, в которых указываются номера строк и столбцов таблицы, из которых должны браться сведения для таблицы первого листа. Вида, например: «01, 02, 05, 20, 40 / 01, 05», где до «/« - номера строк, а после «/« - номера граф. Значения после «/« для первой таблицы собственно не нужны, нужны для человека, но убирать их нельзя. Прописываю для каждой ячейки таблицы формулу, где проверяется значение диапазона ячеек с «разноской» и если число находится, то ставится соответствующая цифра.

Проблема: формула «поиск» не различает строки и графы. Ячейку делить нельзя, запись должна быть как представлена выше. Нужна формула с условием поиска до знака «/«, чтобы если до «/« значения нет, не брал он сведения после слэша и не путал всю таблицу. Не могу додуматься как это сделать, прошу помощи.
 
Ответить
СообщениеПриветствую, товарищи!

В документе имеется два листа. На первом большая таблица, в которую заносятся исключительно числа, состоящая из полсотни строк и 15 граф.
На втором листе таблица с разноской, из которых в автоматическом режиме таблица на первом листе должна заполнятся.

В сведениях на листе 2 имеется столбец с ячейками, в которых указываются номера строк и столбцов таблицы, из которых должны браться сведения для таблицы первого листа. Вида, например: «01, 02, 05, 20, 40 / 01, 05», где до «/« - номера строк, а после «/« - номера граф. Значения после «/« для первой таблицы собственно не нужны, нужны для человека, но убирать их нельзя. Прописываю для каждой ячейки таблицы формулу, где проверяется значение диапазона ячеек с «разноской» и если число находится, то ставится соответствующая цифра.

Проблема: формула «поиск» не различает строки и графы. Ячейку делить нельзя, запись должна быть как представлена выше. Нужна формула с условием поиска до знака «/«, чтобы если до «/« значения нет, не брал он сведения после слэша и не путал всю таблицу. Не могу додуматься как это сделать, прошу помощи.

Автор - Dfgq
Дата добавления - 04.01.2019 в 22:30
AlexM Дата: Пятница, 04.01.2019, 23:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Страшно длинное описание, и ничего не понятно.
Не проще ли показать пример в файле формата Excel, тем более правила форума это требуют?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеСтрашно длинное описание, и ничего не понятно.
Не проще ли показать пример в файле формата Excel, тем более правила форума это требуют?

Автор - AlexM
Дата добавления - 04.01.2019 в 23:02
Dfgq Дата: Суббота, 05.01.2019, 08:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сбрасываю пример в файле, старался доступно объяснить как видится результат.
К сообщению приложен файл: 9148546.xls(37.5 Kb)
 
Ответить
СообщениеСбрасываю пример в файле, старался доступно объяснить как видится результат.

Автор - Dfgq
Дата добавления - 05.01.2019 в 08:58
Pelena Дата: Суббота, 05.01.2019, 09:10 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14094
Репутация: 3081 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если правильно поняла
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/";Лист2!$G$3:$G$500))*ЕЧИСЛО(ПОИСК("/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$A$3:$A$500<=$B$1)*(Лист2!$F$3:$F$500))
К сообщению приложен файл: 4149603.xls(40.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли правильно поняла
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/";Лист2!$G$3:$G$500))*ЕЧИСЛО(ПОИСК("/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$A$3:$A$500<=$B$1)*(Лист2!$F$3:$F$500))

Автор - Pelena
Дата добавления - 05.01.2019 в 09:10
Dfgq Дата: Суббота, 05.01.2019, 09:23 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное! С exel я на Вы, третий день голову ломаю как оптимизировать работу в рамках журналов и отчетов по форме, утвержденной руководством.
 
Ответить
СообщениеСпасибо огромное! С exel я на Вы, третий день голову ломаю как оптимизировать работу в рамках журналов и отчетов по форме, утвержденной руководством.

Автор - Dfgq
Дата добавления - 05.01.2019 в 09:23
AlexM Дата: Суббота, 05.01.2019, 09:26 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2;ЛЕВБ(Лист2!$G$3:$G$8;ПОИСК("/";Лист2!$G$3:$G$8)))*ПОИСК(C$1;ПСТР(Лист2!$G$3:$G$8;ПОИСК("/";Лист2!$G$3:$G$8);99)))*Лист2!$F$3:$F$8)
К сообщению приложен файл: 9148546_01.xls(43.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2;ЛЕВБ(Лист2!$G$3:$G$8;ПОИСК("/";Лист2!$G$3:$G$8)))*ПОИСК(C$1;ПСТР(Лист2!$G$3:$G$8;ПОИСК("/";Лист2!$G$3:$G$8);99)))*Лист2!$F$3:$F$8)

Автор - AlexM
Дата добавления - 05.01.2019 в 09:26
AlexM Дата: Суббота, 05.01.2019, 09:37 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Формула Елены (Pelena) сокращенная
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/";Лист2!$G$3:$G$500)*ПОИСК("/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$F$3:$F$500))
не понял для чего (Лист2!$A$3:$A$500<=$B$1), поэтому убрал
Разобрался. :)
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/";Лист2!$G$3:$G$500)*ПОИСК("/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$A$3:$A$500<=$B$1)*(Лист2!$F$3:$F$500))
Все равно короче <_<
К сообщению приложен файл: 9148546_03.xls(41.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 05.01.2019, 09:42
 
Ответить
СообщениеФормула Елены (Pelena) сокращенная
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/";Лист2!$G$3:$G$500)*ПОИСК("/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$F$3:$F$500))
не понял для чего (Лист2!$A$3:$A$500<=$B$1), поэтому убрал
Разобрался. :)
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/";Лист2!$G$3:$G$500)*ПОИСК("/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$A$3:$A$500<=$B$1)*(Лист2!$F$3:$F$500))
Все равно короче <_<

Автор - AlexM
Дата добавления - 05.01.2019 в 09:37
AlexM Дата: Суббота, 05.01.2019, 09:47 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$A$3:$A$500<=$B$1)*Лист2!$F$3:$F$500)
К сообщению приложен файл: 9148546_04.xls(40.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 05.01.2019, 09:52
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($B2&"*/*"&C$1;Лист2!$G$3:$G$500))*(Лист2!$A$3:$A$500<=$B$1)*Лист2!$F$3:$F$500)

Автор - AlexM
Дата добавления - 05.01.2019 в 09:47
Dfgq Дата: Суббота, 05.01.2019, 10:07 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Товарищи форумчане, Вы просто супер. Именно то, что надо. Спасибо еще раз! С наступившими и наступающими Вас!
 
Ответить
СообщениеТоварищи форумчане, Вы просто супер. Именно то, что надо. Спасибо еще раз! С наступившими и наступающими Вас!

Автор - Dfgq
Дата добавления - 05.01.2019 в 10:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование и поиск значений из данных ячейки до символа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!