Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как присвоить нужную категорию в двух таблицах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как присвоить нужную категорию в двух таблицах (Формулы/Formulas)
Как присвоить нужную категорию в двух таблицах
bazaar Дата: Среда, 13.03.2019, 14:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть два листа, нужно найти на одном из листов все строки с совпадениями по ячейке на другом листе, при этом первый лист должен соответствовать заданному условию из другой ячейки (текст, например), и подставлять это значение в ячейку другого листа.

Теперь попробую более понятно объяснить. У меня есть две таблицы, и в той и другой есть ID транзакций. Мне нужно провести сверку транзакций и дополнить вторую таблицу недостающими параметрами из первой ячейки, вторая таблица не отражает тип транзакции, а мне нужно отсортировать ее по этому параметру. То есть найти в первой таблице все соответствующие ID шники и из это же строки вытащить другую ячейку и подставить во вторую таблицу
 
Ответить
СообщениеЕсть два листа, нужно найти на одном из листов все строки с совпадениями по ячейке на другом листе, при этом первый лист должен соответствовать заданному условию из другой ячейки (текст, например), и подставлять это значение в ячейку другого листа.

Теперь попробую более понятно объяснить. У меня есть две таблицы, и в той и другой есть ID транзакций. Мне нужно провести сверку транзакций и дополнить вторую таблицу недостающими параметрами из первой ячейки, вторая таблица не отражает тип транзакции, а мне нужно отсортировать ее по этому параметру. То есть найти в первой таблице все соответствующие ID шники и из это же строки вытащить другую ячейку и подставить во вторую таблицу

Автор - bazaar
Дата добавления - 13.03.2019 в 14:03
Pelena Дата: Среда, 13.03.2019, 14:19 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14770
Репутация: 3231 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 13.03.2019 в 14:19
Nic70y Дата: Среда, 13.03.2019, 21:19 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5710
Репутация: 1251 ±
Замечаний: 0% ±

ru13;10;03
по описанию на
Код
=ВПР()
или
Код
=ПОИСКПОЗ()
+
Код
=ИНДЕКС()
смахивает


ЯД(poison) 41001841029809
 
Ответить
Сообщениепо описанию на
Код
=ВПР()
или
Код
=ПОИСКПОЗ()
+
Код
=ИНДЕКС()
смахивает

Автор - Nic70y
Дата добавления - 13.03.2019 в 21:19
bazaar Дата: Воскресенье, 17.03.2019, 19:22 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Файл с примером помог бы в понимании проблемы


Я не могу прикрепить пример, так как не могу снизить размер файла ниже 100кб. Отметил красным и выложил на яндекс диске
Ссылка удалена. Нарушение Правил форума


Сообщение отредактировал Pelena - Воскресенье, 17.03.2019, 22:10
 
Ответить
Сообщение
Файл с примером помог бы в понимании проблемы


Я не могу прикрепить пример, так как не могу снизить размер файла ниже 100кб. Отметил красным и выложил на яндекс диске
Ссылка удалена. Нарушение Правил форума

Автор - bazaar
Дата добавления - 17.03.2019 в 19:22
Pelena Дата: Воскресенье, 17.03.2019, 22:09 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14770
Репутация: 3231 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
не могу снизить размер файла ниже 100кб

На Лист1 нажмите Ctrl+G -- Выделить -- Объекты -- ОК
Затем Delete. Файл сразу похудеет раз в 10.
А внешние ссылки на файлы по правилам форума не допускаются


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
не могу снизить размер файла ниже 100кб

На Лист1 нажмите Ctrl+G -- Выделить -- Объекты -- ОК
Затем Delete. Файл сразу похудеет раз в 10.
А внешние ссылки на файлы по правилам форума не допускаются

Автор - Pelena
Дата добавления - 17.03.2019 в 22:09
bazaar Дата: Вторник, 19.03.2019, 08:17 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
На Лист1 нажмите Ctrl+G -- Выделить -- Объекты -- ОК
Затем Delete. Файл сразу похудеет раз в 10.
А внешние ссылки на файлы по правилам форума не допускаются


Спасибо, помогло!

Вот документ
К сообщению приложен файл: example_02.xlsx(27.0 Kb)
 
Ответить
Сообщение
На Лист1 нажмите Ctrl+G -- Выделить -- Объекты -- ОК
Затем Delete. Файл сразу похудеет раз в 10.
А внешние ссылки на файлы по правилам форума не допускаются


Спасибо, помогло!

Вот документ

Автор - bazaar
Дата добавления - 19.03.2019 в 08:17
китин Дата: Вторник, 19.03.2019, 08:27 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5929
Репутация: 921 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$C$2:$C$580;ПОИСКПОЗ(Лист1!$A3;Sheet1!$A$2:$A$580;0));"")
К сообщению приложен файл: bazaar.xlsx(29.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$C$2:$C$580;ПОИСКПОЗ(Лист1!$A3;Sheet1!$A$2:$A$580;0));"")

Автор - китин
Дата добавления - 19.03.2019 в 08:27
bazaar Дата: Вторник, 19.03.2019, 08:51 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$C$2:$C$580;ПОИСКПОЗ(Лист1!$A3;Sheet1!$A$2:$A$580;0));"")


Да, все верно! Спасибо! Только насколько я понимаю сверки суммы не идет по этой формуле? Как добавить сюда дополнительное условие, чтобы при соответствии значения сумм оплаты ячейка отмечалась зеленым, а при несоответствии красным (B столбцы в обеих таблицах)?
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!$C$2:$C$580;ПОИСКПОЗ(Лист1!$A3;Sheet1!$A$2:$A$580;0));"")


Да, все верно! Спасибо! Только насколько я понимаю сверки суммы не идет по этой формуле? Как добавить сюда дополнительное условие, чтобы при соответствии значения сумм оплаты ячейка отмечалась зеленым, а при несоответствии красным (B столбцы в обеих таблицах)?

Автор - bazaar
Дата добавления - 19.03.2019 в 08:51
китин Дата: Вторник, 19.03.2019, 08:59 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 5929
Репутация: 921 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
сверки суммы не идет по этой формуле

а где это сказано, что это надо делать?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
сверки суммы не идет по этой формуле

а где это сказано, что это надо делать?

Автор - китин
Дата добавления - 19.03.2019 в 08:59
bazaar Дата: Вторник, 19.03.2019, 09:29 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
а где это сказано, что это надо делать?


В теле сообщения форума этого нет, есть в ячейке. Можно считать это отдельным вопросом — стоит такая задача, сравнить еще и суммы на соответствие
 
Ответить
Сообщение
а где это сказано, что это надо делать?


В теле сообщения форума этого нет, есть в ячейке. Можно считать это отдельным вопросом — стоит такая задача, сравнить еще и суммы на соответствие

Автор - bazaar
Дата добавления - 19.03.2019 в 09:29
китин Дата: Вторник, 19.03.2019, 10:10 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 5929
Репутация: 921 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Можно считать это отдельным вопросом

- п.4 Правил форума: один вопрос - одна тема


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Можно считать это отдельным вопросом

- п.4 Правил форума: один вопрос - одна тема

Автор - китин
Дата добавления - 19.03.2019 в 10:10
bazaar Дата: Вторник, 19.03.2019, 11:43 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
- п.4 Правил форума: один вопрос - одна тема


Как много правил )) Могу я отредактировать главную тему и задать там оба этих вопроса?
 
Ответить
Сообщение
- п.4 Правил форума: один вопрос - одна тема


Как много правил )) Могу я отредактировать главную тему и задать там оба этих вопроса?

Автор - bazaar
Дата добавления - 19.03.2019 в 11:43
_Boroda_ Дата: Вторник, 19.03.2019, 11:49 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Могу я отредактировать главную тему и задать там оба этих вопроса?

Можете, почему нет? Кто Вам может запретить? Но вопрос поставлен неверно. Нужно спросить "Не будет ли нарушением Правил форума, если я ...". И на этот вопрос Вы уже сами ответили в цитате своего же поста


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Могу я отредактировать главную тему и задать там оба этих вопроса?

Можете, почему нет? Кто Вам может запретить? Но вопрос поставлен неверно. Нужно спросить "Не будет ли нарушением Правил форума, если я ...". И на этот вопрос Вы уже сами ответили в цитате своего же поста

Автор - _Boroda_
Дата добавления - 19.03.2019 в 11:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как присвоить нужную категорию в двух таблицах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!