Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значений в интервале дат c тремя условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений в интервале дат c тремя условиями (Формулы/Formulas)
Поиск значений в интервале дат c тремя условиями
cants Дата: Среда, 13.03.2019, 22:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые участники форума, добрый вечер.

Возник вопрос, связанный с тем, как, ориентируясь на три условия: наименование поставщика, покупателя и дату, определить объем отгруженной продукции за месяц. Пробовал использовать формулу СУММЕСЛИМН, но на лист 2 выводятся значения только за определенную дату, а требуется сумма за месяц

Пример во вложении
К сообщению приложен файл: _13.03.19.xlsx(12.9 Kb)
 
Ответить
СообщениеУважаемые участники форума, добрый вечер.

Возник вопрос, связанный с тем, как, ориентируясь на три условия: наименование поставщика, покупателя и дату, определить объем отгруженной продукции за месяц. Пробовал использовать формулу СУММЕСЛИМН, но на лист 2 выводятся значения только за определенную дату, а требуется сумма за месяц

Пример во вложении

Автор - cants
Дата добавления - 13.03.2019 в 22:19
skais Дата: Среда, 13.03.2019, 22:30 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 157
Репутация: 18 ±
Замечаний: 60% ±

Excel 2010
Так и просится сводная
К сообщению приложен файл: 5748399.xlsx(16.2 Kb)
 
Ответить
СообщениеТак и просится сводная

Автор - skais
Дата добавления - 13.03.2019 в 22:30
gling Дата: Среда, 13.03.2019, 22:34 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1911
Репутация: 478 ±
Замечаний: 0% ±

2010
Здравствуйте. А если так попробовать?
Код
=СУММЕСЛИМН(Лист1!$D$2:$D$26;Лист1!$B$2:$B$26;Лист2!A2;Лист1!$C$2:$C$26;Лист2!B2;Лист1!$E$2:$E$26;">="&Лист2!$C$1;Лист1!$E$2:$E$26;"<="&КОНМЕСЯЦА(Лист2!$C$1;0))


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. А если так попробовать?
Код
=СУММЕСЛИМН(Лист1!$D$2:$D$26;Лист1!$B$2:$B$26;Лист2!A2;Лист1!$C$2:$C$26;Лист2!B2;Лист1!$E$2:$E$26;">="&Лист2!$C$1;Лист1!$E$2:$E$26;"<="&КОНМЕСЯЦА(Лист2!$C$1;0))

Автор - gling
Дата добавления - 13.03.2019 в 22:34
krosav4ig Дата: Среда, 13.03.2019, 22:47 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2031
Репутация: 847 ±
Замечаний: 0% ±

Excel 2007,2010,2013
еще вариант
Код
=СУММПРОИЗВ((МУМНОЖ(--(Лист1!$B$2:$C$26=$A2:$B2);{1:1})=2)*(ГПР(Ч(ИНДЕКС(+Лист1!$E$2:$E$26;));Лист2!$B$1:$E$1;1)=C$1)*Лист1!$D$2:$D$26)
и сводная с группировкой по году и месяцу
К сообщению приложен файл: 1843189.xlsx(18.5 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениееще вариант
Код
=СУММПРОИЗВ((МУМНОЖ(--(Лист1!$B$2:$C$26=$A2:$B2);{1:1})=2)*(ГПР(Ч(ИНДЕКС(+Лист1!$E$2:$E$26;));Лист2!$B$1:$E$1;1)=C$1)*Лист1!$D$2:$D$26)
и сводная с группировкой по году и месяцу

Автор - krosav4ig
Дата добавления - 13.03.2019 в 22:47
cants Дата: Среда, 13.03.2019, 23:42 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Господа, всем спасибо! Подходит любой из предложенных варинтов
 
Ответить
СообщениеГоспода, всем спасибо! Подходит любой из предложенных варинтов

Автор - cants
Дата добавления - 13.03.2019 в 23:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений в интервале дат c тремя условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!