Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод строк из массива на отдельный лист. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод строк из массива на отдельный лист. (Формулы/Formulas)
Вывод строк из массива на отдельный лист.
negodyaj Дата: Воскресенье, 26.05.2019, 12:26 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть лист "Массив", нужно из него вывести на отдельный лист "Вывод" все строки, кроме тех что в ячейке "Действие" содержит "Не трогаем".
К сообщению приложен файл: 0059265.xlsx(11.8 Kb)


Сообщение отредактировал negodyaj - Воскресенье, 26.05.2019, 12:42
 
Ответить
СообщениеЕсть лист "Массив", нужно из него вывести на отдельный лист "Вывод" все строки, кроме тех что в ячейке "Действие" содержит "Не трогаем".

Автор - negodyaj
Дата добавления - 26.05.2019 в 12:26
_Igor_61 Дата: Воскресенье, 26.05.2019, 14:17 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 63 ±
Замечаний: 0% ±

Excel 2007
В "A1" на листе "Вывод":
Код
=ЕСЛИ(Массив!$M2="Не трогаем";Массив!A2;"")
и тянуть вниз и вправо
 
Ответить
СообщениеВ "A1" на листе "Вывод":
Код
=ЕСЛИ(Массив!$M2="Не трогаем";Массив!A2;"")
и тянуть вниз и вправо

Автор - _Igor_61
Дата добавления - 26.05.2019 в 14:17
negodyaj Дата: Воскресенье, 26.05.2019, 17:59 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В "A1" на листе "Вывод":

=ЕСЛИ(Массив!$M2="Не трогаем";Массив!A2;"")
и тянуть вниз и вправо

Это выведет не строку , а только ячейку А2 и второе это выведет именно те строки, что не нужны. Нужны не "Не трогаем" строки.
 
Ответить
Сообщение
В "A1" на листе "Вывод":

=ЕСЛИ(Массив!$M2="Не трогаем";Массив!A2;"")
и тянуть вниз и вправо

Это выведет не строку , а только ячейку А2 и второе это выведет именно те строки, что не нужны. Нужны не "Не трогаем" строки.

Автор - negodyaj
Дата добавления - 26.05.2019 в 17:59
_Igor_61 Дата: Воскресенье, 26.05.2019, 21:12 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 63 ±
Замечаний: 0% ±

Excel 2007
Ну не так понял, извините :) А догадаться, что "=" можно заменить на "<>"?
Это выведет не строку , а только ячейку А2
Нужно чтобы на листе "Вывод" в одну ячейку выводилась вся строка?
К сообщению приложен файл: 4647402.xlsx(18.8 Kb)


Сообщение отредактировал _Igor_61 - Воскресенье, 26.05.2019, 21:38
 
Ответить
СообщениеНу не так понял, извините :) А догадаться, что "=" можно заменить на "<>"?
Это выведет не строку , а только ячейку А2
Нужно чтобы на листе "Вывод" в одну ячейку выводилась вся строка?

Автор - _Igor_61
Дата добавления - 26.05.2019 в 21:12
negodyaj Дата: Воскресенье, 26.05.2019, 22:45 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Нужно чтобы на листе "Вывод" в одну ячейку выводилась вся строка?

Нет, что б повторялась строка на отдельном листе полностью.
Спасибо за файл. hands


Сообщение отредактировал negodyaj - Воскресенье, 26.05.2019, 22:48
 
Ответить
Сообщение
Нужно чтобы на листе "Вывод" в одну ячейку выводилась вся строка?

Нет, что б повторялась строка на отдельном листе полностью.
Спасибо за файл. hands

Автор - negodyaj
Дата добавления - 26.05.2019 в 22:45
_Igor_61 Дата: Воскресенье, 26.05.2019, 22:49 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 63 ±
Замечаний: 0% ±

Excel 2007
del


Сообщение отредактировал _Igor_61 - Понедельник, 27.05.2019, 16:40
 
Ответить
Сообщениеdel

Автор - _Igor_61
Дата добавления - 26.05.2019 в 22:49
_Boroda_ Дата: Понедельник, 27.05.2019, 09:47 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15269
Репутация: 5991 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Может так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Массив!A:A;НАИМЕНЬШИЙ(ЕСЛИ((Массив!$M$2:$M$999<>"Не трогаем")*Массив!$A$2:$A$999;СТРОКА(Массив!A$2:A$999));СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Или попроще, да и работать побыстрее будет (в файле на другом листе)
В А2 и ниже массивку
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((Массив!M$2:M$999<>"Не трогаем")*Массив!A$2:A$999;Массив!A$2:A$999);СТРОКА(A1));"")

В В2 и правее-ниже
Код
=ЕСЛИ($A2="";"";ИНДЕКС(Массив!B$2:B$999;$A2))
К сообщению приложен файл: 0059265_1.xlsx(22.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожет так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Массив!A:A;НАИМЕНЬШИЙ(ЕСЛИ((Массив!$M$2:$M$999<>"Не трогаем")*Массив!$A$2:$A$999;СТРОКА(Массив!A$2:A$999));СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Или попроще, да и работать побыстрее будет (в файле на другом листе)
В А2 и ниже массивку
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((Массив!M$2:M$999<>"Не трогаем")*Массив!A$2:A$999;Массив!A$2:A$999);СТРОКА(A1));"")

В В2 и правее-ниже
Код
=ЕСЛИ($A2="";"";ИНДЕКС(Массив!B$2:B$999;$A2))

Автор - _Boroda_
Дата добавления - 27.05.2019 в 09:47
negodyaj Дата: Понедельник, 27.05.2019, 22:50 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо
 
Ответить
СообщениеСпасибо

Автор - negodyaj
Дата добавления - 27.05.2019 в 22:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод строк из массива на отдельный лист. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!