Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск строки по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строки по условию (Формулы/Formulas)
Поиск строки по условию
Tort Дата: Вторник, 25.06.2019, 16:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Снова здравствуйте,я уже тут постоянно что то ищу и смотрю, и в этот раз прошу помочь. Простое суммирование я могу сделать а вот что то по серьезнее увы нет.
Мне китин помог из таблицы вывести данные с точками теперь ситуация наоборот нужно вывести данные без точек. Я пытался переделать существующую формулу
Код
=ЕСЛИ(ПОИСК(".";$F2);"";D2)
но она выдает #знач. наверно не верное
Есть таблица со столбцами и строками мне нужно:
1 найти строки где в значенивх нет точки, и перенести правее в соответствии с цветом
2 есть столбец G там значения "а,в,с" мне необходимо суммировать "с" строку столбца Н12+Х12 и I12+Y12. т.е просуммировать только "с" строку
3 столбец Z вписывались не только значения столбца D строки без точек, но и через запятую значения строк с точками если значения повторяются то прописывались чтоб один раз
К сообщению приложен файл: 8551674.xlsx(49.1 Kb)


Сообщение отредактировал Tort - Вторник, 25.06.2019, 16:58
 
Ответить
СообщениеСнова здравствуйте,я уже тут постоянно что то ищу и смотрю, и в этот раз прошу помочь. Простое суммирование я могу сделать а вот что то по серьезнее увы нет.
Мне китин помог из таблицы вывести данные с точками теперь ситуация наоборот нужно вывести данные без точек. Я пытался переделать существующую формулу
Код
=ЕСЛИ(ПОИСК(".";$F2);"";D2)
но она выдает #знач. наверно не верное
Есть таблица со столбцами и строками мне нужно:
1 найти строки где в значенивх нет точки, и перенести правее в соответствии с цветом
2 есть столбец G там значения "а,в,с" мне необходимо суммировать "с" строку столбца Н12+Х12 и I12+Y12. т.е просуммировать только "с" строку
3 столбец Z вписывались не только значения столбца D строки без точек, но и через запятую значения строк с точками если значения повторяются то прописывались чтоб один раз

Автор - Tort
Дата добавления - 25.06.2019 в 16:12
_Boroda_ Дата: Вторник, 25.06.2019, 16:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 25.06.2019 в 16:21
Tort Дата: Вторник, 25.06.2019, 16:29 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
поправил :)
 
Ответить
Сообщениепоправил :)

Автор - Tort
Дата добавления - 25.06.2019 в 16:29
monstr_ork Дата: Вторник, 25.06.2019, 18:21 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вот так можно:
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(".";$F3;1));"";D3)

чтобы формула работала.


Сообщение отредактировал monstr_ork - Вторник, 25.06.2019, 18:25
 
Ответить
Сообщениевот так можно:
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(".";$F3;1));"";D3)

чтобы формула работала.

Автор - monstr_ork
Дата добавления - 25.06.2019 в 18:21
_Boroda_ Дата: Вторник, 25.06.2019, 21:38 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да просто перевернуть аргументы в ЕСЛИ в формуле из предыдущей темы
Код
=ЕСЛИ(ЕОШ(ПОИСК(".";$C2));A2;"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа просто перевернуть аргументы в ЕСЛИ в формуле из предыдущей темы
Код
=ЕСЛИ(ЕОШ(ПОИСК(".";$C2));A2;"")

Автор - _Boroda_
Дата добавления - 25.06.2019 в 21:38
Tort Дата: Среда, 26.06.2019, 09:59 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Спасибо Вам что подсказали все получилось :) . Обе формулы работают
Есть еще один вопрос как просуммировать строки H12+P12, а строки от Н1 до Н11 прописывались без изменений
 
Ответить
СообщениеСпасибо Вам что подсказали все получилось :) . Обе формулы работают
Есть еще один вопрос как просуммировать строки H12+P12, а строки от Н1 до Н11 прописывались без изменений

Автор - Tort
Дата добавления - 26.06.2019 в 09:59
_Boroda_ Дата: Среда, 26.06.2019, 10:06 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Приложите файл с желаемым результатом, заполненным вручную


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Приложите файл с желаемым результатом, заполненным вручную

Автор - _Boroda_
Дата добавления - 26.06.2019 в 10:06
Tort Дата: Среда, 26.06.2019, 10:14 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Вот Файл
К сообщению приложен файл: 9073313.xlsx(47.9 Kb)


Сообщение отредактировал Tort - Среда, 26.06.2019, 12:20
 
Ответить
СообщениеВот Файл

Автор - Tort
Дата добавления - 26.06.2019 в 10:14
Tort Дата: Среда, 26.06.2019, 12:36 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Есть тут кто?
 
Ответить
СообщениеЕсть тут кто?

Автор - Tort
Дата добавления - 26.06.2019 в 12:36
Tort Дата: Среда, 26.06.2019, 15:08 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
?
 
Ответить
Сообщение?

Автор - Tort
Дата добавления - 26.06.2019 в 15:08
Pelena Дата: Среда, 26.06.2019, 15:25 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 14585
Репутация: 3196 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Tort, слишком много вопросов для одной темы. На Ваш первый вопрос ответ дан. Остальные вопросы к теме "Поиск строки по условию" не относятся. Читайте Правила форума


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеTort, слишком много вопросов для одной темы. На Ваш первый вопрос ответ дан. Остальные вопросы к теме "Поиск строки по условию" не относятся. Читайте Правила форума

Автор - Pelena
Дата добавления - 26.06.2019 в 15:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строки по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!