Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Учет дней в графике отпусков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учет дней в графике отпусков (Формулы/Formulas)
Учет дней в графике отпусков
nastyarz Дата: Вторник, 23.07.2019, 13:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Не могу сообразить: есть график по запланированным отпускам, нужно сделать свод по количеству дней на каждый месяц по всем работникам, внесенным в график.
Нюанс: есть отпуска, переходящие из одного месяца в другой, эти дни нужно раскидать по разным месяцам в своде.
К сообщению приложен файл: ___2020.xlsx(11.8 Kb)
 
Ответить
СообщениеДобрый день!
Не могу сообразить: есть график по запланированным отпускам, нужно сделать свод по количеству дней на каждый месяц по всем работникам, внесенным в график.
Нюанс: есть отпуска, переходящие из одного месяца в другой, эти дни нужно раскидать по разным месяцам в своде.

Автор - nastyarz
Дата добавления - 23.07.2019 в 13:33
Pelena Дата: Вторник, 23.07.2019, 14:48 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14882
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(--ТЕКСТ(КОНМЕСЯЦА(B21;0)-ТЕКСТ(КОНМЕСЯЦА(B21;0)-$H$9:$H$16;"0;\0")-(B21+ТЕКСТ($G$9:$G$16-B21;"0;\0"))+1;"0;\0"))
К сообщению приложен файл: _2020.xlsx(12.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(--ТЕКСТ(КОНМЕСЯЦА(B21;0)-ТЕКСТ(КОНМЕСЯЦА(B21;0)-$H$9:$H$16;"0;\0")-(B21+ТЕКСТ($G$9:$G$16-B21;"0;\0"))+1;"0;\0"))

Автор - Pelena
Дата добавления - 23.07.2019 в 14:48
Светлый Дата: Вторник, 23.07.2019, 15:17 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1369
Репутация: 364 ±
Замечаний: 0% ±

Excel 2010, 2013
А я на скорую руку монстрика массивного слепил:
Код
=СУММ(Ч(ЕСЛИ((СТРОКА(ДВССЫЛ(МИН(G$9:H$16)&":"&МАКСА(G$9:H$16)))>=ТРАНСП(G$9:G$16))*(СТРОКА(ДВССЫЛ(МИН(G$9:H$16)&":"&МАКСА(G$9:H$16)))<=ТРАНСП(H$9:H$16));МЕСЯЦ(СТРОКА(ДВССЫЛ(МИН(G$9:H$16)&":"&МАКСА(G$9:H$16)))))=МЕСЯЦ(B21)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА я на скорую руку монстрика массивного слепил:
Код
=СУММ(Ч(ЕСЛИ((СТРОКА(ДВССЫЛ(МИН(G$9:H$16)&":"&МАКСА(G$9:H$16)))>=ТРАНСП(G$9:G$16))*(СТРОКА(ДВССЫЛ(МИН(G$9:H$16)&":"&МАКСА(G$9:H$16)))<=ТРАНСП(H$9:H$16));МЕСЯЦ(СТРОКА(ДВССЫЛ(МИН(G$9:H$16)&":"&МАКСА(G$9:H$16)))))=МЕСЯЦ(B21)))

Автор - Светлый
Дата добавления - 23.07.2019 в 15:17
nastyarz Дата: Среда, 24.07.2019, 10:36 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, добрый день! Попробовала Ваш вариант, не работает(
 
Ответить
СообщениеСветлый, добрый день! Попробовала Ваш вариант, не работает(

Автор - nastyarz
Дата добавления - 24.07.2019 в 10:36
nastyarz Дата: Четверг, 22.08.2019, 09:39 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, добрый день! Пользуюсь Вашей формулой, спасибо!
Но выходит расхождение с графиком из-за наличия праздничных дней, которые не учитываются. Есть светлые мысли как это исправить? :)
К сообщению приложен файл: 7492050.xlsx(12.3 Kb)
 
Ответить
СообщениеPelena, добрый день! Пользуюсь Вашей формулой, спасибо!
Но выходит расхождение с графиком из-за наличия праздничных дней, которые не учитываются. Есть светлые мысли как это исправить? :)

Автор - nastyarz
Дата добавления - 22.08.2019 в 09:39
Pelena Дата: Четверг, 22.08.2019, 16:47 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14882
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Напишите вручную, сколько где должно получиться


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНапишите вручную, сколько где должно получиться

Автор - Pelena
Дата добавления - 22.08.2019 в 16:47
nastyarz Дата: Пятница, 23.08.2019, 12:59 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, комментарии в прикрепленном файле.
Спасибо!
К сообщению приложен файл: 7518429.xlsx(12.6 Kb)
 
Ответить
СообщениеPelena, комментарии в прикрепленном файле.
Спасибо!

Автор - nastyarz
Дата добавления - 23.08.2019 в 12:59
Pelena Дата: Суббота, 24.08.2019, 07:39 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14882
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как-то так можно
Код
=СУММПРОИЗВ(--ТЕКСТ(ТЕКСТ(КОНМЕСЯЦА(B21;0)-ТЕКСТ(КОНМЕСЯЦА(B21;0)-$H$9:$H$16;"0;\0")-(B21+ТЕКСТ($G$9:$G$16-B21;"0;\0"))+1;"0;\0")-СУММПРОИЗВ((B21<=СЧЁТЕСЛИМН($G$9:$G$16;"<="&Праздники!$A$3:$A$16;$H$9:$H$16;">="&Праздники!$A$3:$A$16)*Праздники!$A$3:$A$16)*(КОНМЕСЯЦА(B21;0)>=СЧЁТЕСЛИМН($G$9:$G$16;"<="&Праздники!$A$3:$A$16;$H$9:$H$16;">="&Праздники!$A$3:$A$16)*Праздники!$A$3:$A$16));"0;\0"))
К сообщению приложен файл: 4572520.xlsx(13.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак-то так можно
Код
=СУММПРОИЗВ(--ТЕКСТ(ТЕКСТ(КОНМЕСЯЦА(B21;0)-ТЕКСТ(КОНМЕСЯЦА(B21;0)-$H$9:$H$16;"0;\0")-(B21+ТЕКСТ($G$9:$G$16-B21;"0;\0"))+1;"0;\0")-СУММПРОИЗВ((B21<=СЧЁТЕСЛИМН($G$9:$G$16;"<="&Праздники!$A$3:$A$16;$H$9:$H$16;">="&Праздники!$A$3:$A$16)*Праздники!$A$3:$A$16)*(КОНМЕСЯЦА(B21;0)>=СЧЁТЕСЛИМН($G$9:$G$16;"<="&Праздники!$A$3:$A$16;$H$9:$H$16;">="&Праздники!$A$3:$A$16)*Праздники!$A$3:$A$16));"0;\0"))

Автор - Pelena
Дата добавления - 24.08.2019 в 07:39
nastyarz Дата: Понедельник, 26.08.2019, 10:06 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, не понимаю, почему в июне день пропадает :eek:
К сообщению приложен файл: ____2020.xlsx(17.1 Kb)
 
Ответить
СообщениеPelena, не понимаю, почему в июне день пропадает :eek:

Автор - nastyarz
Дата добавления - 26.08.2019 в 10:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учет дней в графике отпусков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!