Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение несколько строк со сложением значений в строке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение несколько строк со сложением значений в строке (Формулы/Formulas)
Объединение несколько строк со сложением значений в строке
KoKauH46 Дата: Пятница, 09.08.2019, 08:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Подскажите пожалуйста, как можно через макрос найти и объединить в одну строку одинаковые значение в строках таблицы и еще суммировав значение в столбце I начиная со строки I8

Пример таблицы выкладываю сюда.
Желтым я выделил строки у которых одинаковые значения в столбцах но только в столбце I8 могут быть разное кол-во от повторяющихся строк, вот их и нужно суммировать.
На против таблицы я как пример выделил значения зеленым цветом, как должно произойти после работы макроса.

Рабочие столбцы в таблицы по которым обязательно должны объединяться строки это B,D,I, только еще в по столбцу I значение должны суммироваться.
К сообщению приложен файл: 9613167.xlsx(15.8 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите пожалуйста, как можно через макрос найти и объединить в одну строку одинаковые значение в строках таблицы и еще суммировав значение в столбце I начиная со строки I8

Пример таблицы выкладываю сюда.
Желтым я выделил строки у которых одинаковые значения в столбцах но только в столбце I8 могут быть разное кол-во от повторяющихся строк, вот их и нужно суммировать.
На против таблицы я как пример выделил значения зеленым цветом, как должно произойти после работы макроса.

Рабочие столбцы в таблицы по которым обязательно должны объединяться строки это B,D,I, только еще в по столбцу I значение должны суммироваться.

Автор - KoKauH46
Дата добавления - 09.08.2019 в 08:23
китин Дата: Пятница, 09.08.2019, 08:44 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5736
Репутация: 903 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и Вам!!!
именно макрос? формулами не прокатит?
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$8:B8;$B8)=1;СУММПРОИЗВ(--$I$8:$I$76*($B$8:$B$76=$B8));"")

ну и УФ для красоты
К сообщению приложен файл: KoKauH46.xlsx(28.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго и Вам!!!
именно макрос? формулами не прокатит?
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$8:B8;$B8)=1;СУММПРОИЗВ(--$I$8:$I$76*($B$8:$B$76=$B8));"")

ну и УФ для красоты

Автор - китин
Дата добавления - 09.08.2019 в 08:44
_Boroda_ Дата: Пятница, 09.08.2019, 09:35 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы уверены, что объединяться должны по I, а не по J?
Значения ж там по порядку у Вас идут, поэтому можно облегченную формулу типа
Код
=ЕСЛИ(И(B8=B9;D8=D9;J8=J9);"";СУММПРОИЗВ(--I$8:I8)-СУММ(L$7:L7))

Или еще более облегченную
Код
=ЕСЛИ(И(B8=B9;D8=D9;J8=J9);"";ЕСЛИ(И(B8=B7;D8=D7;J8=J7);СУММПРОИЗВ(--I$8:I8)-СУММ(L$7:L7);--I8))

Или для произвольного расположения
Код
=ЕСЛИ(СЧЁТЕСЛИМН(B$7:B7;B8;D$7:D7;D8;J$7:J7;J8);"";СУММПРОИЗВ((B$8:B$999=B8)*(D$8:D$999=D8)*(J$8:J$999=J8)*I$8:I$999))

Ну и итоговую сумму наверное тоже пересчитать нужно?
Код
=ЕСЛИ(L8="";"";L8*J8)
К сообщению приложен файл: KoKauH46_1.xlsx(25.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы уверены, что объединяться должны по I, а не по J?
Значения ж там по порядку у Вас идут, поэтому можно облегченную формулу типа
Код
=ЕСЛИ(И(B8=B9;D8=D9;J8=J9);"";СУММПРОИЗВ(--I$8:I8)-СУММ(L$7:L7))

Или еще более облегченную
Код
=ЕСЛИ(И(B8=B9;D8=D9;J8=J9);"";ЕСЛИ(И(B8=B7;D8=D7;J8=J7);СУММПРОИЗВ(--I$8:I8)-СУММ(L$7:L7);--I8))

Или для произвольного расположения
Код
=ЕСЛИ(СЧЁТЕСЛИМН(B$7:B7;B8;D$7:D7;D8;J$7:J7;J8);"";СУММПРОИЗВ((B$8:B$999=B8)*(D$8:D$999=D8)*(J$8:J$999=J8)*I$8:I$999))

Ну и итоговую сумму наверное тоже пересчитать нужно?
Код
=ЕСЛИ(L8="";"";L8*J8)

Автор - _Boroda_
Дата добавления - 09.08.2019 в 09:35
KoKauH46 Дата: Пятница, 09.08.2019, 09:55 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вот я со сводной таблицей попробовал. вроде все устраивает меня, едиствено есть ньюанс.
к примеру в столбце по название "Реф №" есть позиции:
19800291 в файле кол-во = 1, в заказе кол-во = 10
19802741 в файле кол-во = 1, в заказе кол-во = 10
19803531 в файле кол-во = 1, в заказе кол-во = 2
19803657 в файле кол-во = 1, в заказе кол-во = 10
19803741 в файле кол-во = 1, в заказе кол-во = 8

они в таблице как одной строкой идут. но в сводной таблице их значение приводиться к 1. хотя в таблице их значение другое. почему в сводную не переноситься то значение которое в таблице?
Файл примера прикладываю
К сообщению приложен файл: test1.xlsx(19.2 Kb)
 
Ответить
Сообщениевот я со сводной таблицей попробовал. вроде все устраивает меня, едиствено есть ньюанс.
к примеру в столбце по название "Реф №" есть позиции:
19800291 в файле кол-во = 1, в заказе кол-во = 10
19802741 в файле кол-во = 1, в заказе кол-во = 10
19803531 в файле кол-во = 1, в заказе кол-во = 2
19803657 в файле кол-во = 1, в заказе кол-во = 10
19803741 в файле кол-во = 1, в заказе кол-во = 8

они в таблице как одной строкой идут. но в сводной таблице их значение приводиться к 1. хотя в таблице их значение другое. почему в сводную не переноситься то значение которое в таблице?
Файл примера прикладываю

Автор - KoKauH46
Дата добавления - 09.08.2019 в 09:55
KoKauH46 Дата: Пятница, 09.08.2019, 09:57 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вот я со сводной таблицей попробовал. вроде все устраивает меня, едиствено есть ньюанс.
к примеру в столбце по название "Реф №" есть позиции:
19800291 в файле кол-во = 1, в заказе кол-во = 10
19802741 в файле кол-во = 1, в заказе кол-во = 10
19803531 в файле кол-во = 1, в заказе кол-во = 2
19803657 в файле кол-во = 1, в заказе кол-во = 10
19803741 в файле кол-во = 1, в заказе кол-во = 8

они в таблице как одной строкой идут. но в сводной таблице их значение приводиться к 1. хотя в таблице их значение другое. почему в сводную не переноситься то значение которое в таблице?
Файл примера прикладываю
К сообщению приложен файл: 1064566.xlsx(19.2 Kb)
 
Ответить
Сообщениевот я со сводной таблицей попробовал. вроде все устраивает меня, едиствено есть ньюанс.
к примеру в столбце по название "Реф №" есть позиции:
19800291 в файле кол-во = 1, в заказе кол-во = 10
19802741 в файле кол-во = 1, в заказе кол-во = 10
19803531 в файле кол-во = 1, в заказе кол-во = 2
19803657 в файле кол-во = 1, в заказе кол-во = 10
19803741 в файле кол-во = 1, в заказе кол-во = 8

они в таблице как одной строкой идут. но в сводной таблице их значение приводиться к 1. хотя в таблице их значение другое. почему в сводную не переноситься то значение которое в таблице?
Файл примера прикладываю

Автор - KoKauH46
Дата добавления - 09.08.2019 в 09:57
_Boroda_ Дата: Пятница, 09.08.2019, 10:26 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Нужно сначала преобразовать столбец F в числа (выделить столбец - Данные - Текст по столбцам - ОК
Затем в сводной топнуть правой мышой на поле Кол, выбрать Параметры поля и в Операциях изменить Количество на Сумму
К сообщению приложен файл: test1-5-1.xlsx(34.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНужно сначала преобразовать столбец F в числа (выделить столбец - Данные - Текст по столбцам - ОК
Затем в сводной топнуть правой мышой на поле Кол, выбрать Параметры поля и в Операциях изменить Количество на Сумму

Автор - _Boroda_
Дата добавления - 09.08.2019 в 10:26
китин Дата: Пятница, 09.08.2019, 10:45 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5736
Репутация: 903 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
моя попытка использовать Power Query
К сообщению приложен файл: KoKauH46_PQ.xlsx(36.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениемоя попытка использовать Power Query

Автор - китин
Дата добавления - 09.08.2019 в 10:45
KoKauH46 Дата: Пятница, 09.08.2019, 11:13 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, да. отлично. Большое спасибо.
 
Ответить
Сообщение_Boroda_, да. отлично. Большое спасибо.

Автор - KoKauH46
Дата добавления - 09.08.2019 в 11:13
KoKauH46 Дата: Пятница, 09.08.2019, 11:59 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, спасибо) через сводную реализацию вроде проще)
 
Ответить
Сообщениекитин, спасибо) через сводную реализацию вроде проще)

Автор - KoKauH46
Дата добавления - 09.08.2019 в 11:59
китин Дата: Пятница, 09.08.2019, 12:12 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 5736
Репутация: 903 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
KoKauH46, я просто пытаюсь изучать Power Query. а лучше способа учиться, решая задачки я не знаю :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеKoKauH46, я просто пытаюсь изучать Power Query. а лучше способа учиться, решая задачки я не знаю :D

Автор - китин
Дата добавления - 09.08.2019 в 12:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение несколько строк со сложением значений в строке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!