Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос значений по заданному интервалу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений по заданному интервалу (Формулы/Formulas)
Перенос значений по заданному интервалу
Sergei_vrn Дата: Пятница, 16.08.2019, 09:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые знатоки, прошу помочь решить задачу!

Из массива данных выбрать позиции, результаты которых соответствуют определенному условию и перенести их в отдельную таблицу.
Что-то похожее я находил здесь на форуме, но там переносились наименования блюд если по ним имеется какое-то количество. У меня же задача перенести те позиции, результаты которых находятся в определенном интервале.Пытался корректировать готовое решение ничего не вышло.
К сообщению приложен файл: vyborka.xlsx(10.4 Kb)
 
Ответить
СообщениеУважаемые знатоки, прошу помочь решить задачу!

Из массива данных выбрать позиции, результаты которых соответствуют определенному условию и перенести их в отдельную таблицу.
Что-то похожее я находил здесь на форуме, но там переносились наименования блюд если по ним имеется какое-то количество. У меня же задача перенести те позиции, результаты которых находятся в определенном интервале.Пытался корректировать готовое решение ничего не вышло.

Автор - Sergei_vrn
Дата добавления - 16.08.2019 в 09:29
Nic70y Дата: Пятница, 16.08.2019, 09:37 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
я б использовал допы и ВПР
К сообщению приложен файл: 3324503.xlsx(12.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениея б использовал допы и ВПР

Автор - Nic70y
Дата добавления - 16.08.2019 в 09:37
китин Дата: Пятница, 16.08.2019, 10:01 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
без допов и ВПР, но Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$5:A$17;НАИМЕНЬШИЙ(ЕСЛИ(($B$5:$B$17>=$G$2)*($B$5:$B$17<=$H$2);СТРОКА($B$5:$B$17)-4);СТРОКА(A1)));"")
К сообщению приложен файл: vyborka_1.xlsx(11.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениебез допов и ВПР, но Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$5:A$17;НАИМЕНЬШИЙ(ЕСЛИ(($B$5:$B$17>=$G$2)*($B$5:$B$17<=$H$2);СТРОКА($B$5:$B$17)-4);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 16.08.2019 в 10:01
Sergei_vrn Дата: Пятница, 16.08.2019, 10:01 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, все гениальные решения, просты )) вроде работает, спасибо Вам!
 
Ответить
СообщениеNic70y, все гениальные решения, просты )) вроде работает, спасибо Вам!

Автор - Sergei_vrn
Дата добавления - 16.08.2019 в 10:01
Sergei_vrn Дата: Пятница, 16.08.2019, 10:05 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, спасибо огромное! Ваш способ, по-моему, я как раз пытался отредактировать, теперь вижу как надо было сделать )
 
Ответить
Сообщениекитин, спасибо огромное! Ваш способ, по-моему, я как раз пытался отредактировать, теперь вижу как надо было сделать )

Автор - Sergei_vrn
Дата добавления - 16.08.2019 в 10:05
_Boroda_ Дата: Пятница, 16.08.2019, 10:07 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще похожий вариант
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ((B$5:B$98>=G$2)*(B$5:B$98<=H$2);СТРОКА($5:$98);99);СТРОКА(E1)))&""

Если нужно по возрастанию рентабельности, то тоже можно, но посложнее будет формула
К сообщению приложен файл: 7964163.xlsx(11.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще похожий вариант
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ((B$5:B$98>=G$2)*(B$5:B$98<=H$2);СТРОКА($5:$98);99);СТРОКА(E1)))&""

Если нужно по возрастанию рентабельности, то тоже можно, но посложнее будет формула

Автор - _Boroda_
Дата добавления - 16.08.2019 в 10:07
китин Дата: Пятница, 16.08.2019, 10:35 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Все то же самое но без формул. при помощи PQ
К сообщению приложен файл: vyborka_1_PQ.xlsx(26.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВсе то же самое но без формул. при помощи PQ

Автор - китин
Дата добавления - 16.08.2019 в 10:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений по заданному интервалу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!