Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать сумму ячеек где буквы и цифры - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 3
  • 1
  • 2
  • 3
  • »
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать сумму ячеек где буквы и цифры (Формулы/Formulas)
Как посчитать сумму ячеек где буквы и цифры
exc012 Дата: Вторник, 29.10.2019, 13:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Есть ячейки в них будет такой текст, например,
Я 8.2
Я 4,4
Необходимо в результирующей ячейке посчитать сумму по этим всем ячейкам, чтобы формула игнорировала буквы
Т.е. тут итог должен быть 12.6

Какую формулу надо использовать (функцию для суммирования)?


Сообщение отредактировал exc012 - Среда, 30.10.2019, 06:59
 
Ответить
СообщениеЗдравствуйте.
Есть ячейки в них будет такой текст, например,
Я 8.2
Я 4,4
Необходимо в результирующей ячейке посчитать сумму по этим всем ячейкам, чтобы формула игнорировала буквы
Т.е. тут итог должен быть 12.6

Какую формулу надо использовать (функцию для суммирования)?

Автор - exc012
Дата добавления - 29.10.2019 в 13:27
bmv98rus Дата: Вторник, 29.10.2019, 14:16 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
exc012, Все ячейки с буквами. Название темы лучше приблизить к сути проблемы.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеexc012, Все ячейки с буквами. Название темы лучше приблизить к сути проблемы.

Автор - bmv98rus
Дата добавления - 29.10.2019 в 14:16
китин Дата: Вторник, 29.10.2019, 14:30 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5926
Репутация: 920 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
exc012, - Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, конкретнее обозначьте проблему
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеexc012, - Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, конкретнее обозначьте проблему
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 29.10.2019 в 14:30
exc012 Дата: Среда, 30.10.2019, 07:00 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прикладываю файл
К сообщению приложен файл: 0575860.xls(25.0 Kb)
 
Ответить
СообщениеПрикладываю файл

Автор - exc012
Дата добавления - 30.10.2019 в 07:00
bmv98rus Дата: Среда, 30.10.2019, 07:40 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Ну с названием по прежнему не доработка. Вы не сумму ячеек считаете, а сумму чисел в ячейках, содержащих числа с суффиксом из текста.
для конкретно этого случая
Код
=SUMPRODUCT(--SUBSTITUTE(A3:C3;"Я";))
но то что было в топике требует минимум еще одну подстановку, точки или запятой на разделитель десятичный
Код
=SUMPRODUCT(--SUBSTITUTE(SUBSTITUTE(A3:C3;"Я";);".";",")
А для общего случая не зависисмого от региональных установок
Код
=SUMPRODUCT(--SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A3:C3;"Я";);".";",");",";MID(1/2;2;1)))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеНу с названием по прежнему не доработка. Вы не сумму ячеек считаете, а сумму чисел в ячейках, содержащих числа с суффиксом из текста.
для конкретно этого случая
Код
=SUMPRODUCT(--SUBSTITUTE(A3:C3;"Я";))
но то что было в топике требует минимум еще одну подстановку, точки или запятой на разделитель десятичный
Код
=SUMPRODUCT(--SUBSTITUTE(SUBSTITUTE(A3:C3;"Я";);".";",")
А для общего случая не зависисмого от региональных установок
Код
=SUMPRODUCT(--SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A3:C3;"Я";);".";",");",";MID(1/2;2;1)))

Автор - bmv98rus
Дата добавления - 30.10.2019 в 07:40
amfor Дата: Среда, 30.10.2019, 07:49 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 186
Репутация: 52 ±
Замечаний: 0% ±

Excel 2016
Вариант
Код
=СУММПРОИЗВ(--ПСТР("00"&A3:C3;1;ДЛСТР(A3:C3)+1))


Семь бед - один RESET.
 
Ответить
СообщениеВариант
Код
=СУММПРОИЗВ(--ПСТР("00"&A3:C3;1;ДЛСТР(A3:C3)+1))

Автор - amfor
Дата добавления - 30.10.2019 в 07:49
exc012 Дата: Четверг, 31.10.2019, 07:06 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вариант

=СУММПРОИЗВ(--ПСТР("00"&A3:C3;1;ДЛСТР(A3:C3)+1))

Спасибо!!! Так работает.
Еще добавил в конце +СУММ(A3:C3) чтобы подсуммировались ячейки, где буква не указана.

Отличный форум! Оригинальный дизаин
 
Ответить
Сообщение
Вариант

=СУММПРОИЗВ(--ПСТР("00"&A3:C3;1;ДЛСТР(A3:C3)+1))

Спасибо!!! Так работает.
Еще добавил в конце +СУММ(A3:C3) чтобы подсуммировались ячейки, где буква не указана.

Отличный форум! Оригинальный дизаин

Автор - exc012
Дата добавления - 31.10.2019 в 07:06
exc012 Дата: Понедельник, 11.11.2019, 08:03 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
СОС!!
Помогите, оказывается надо учесть еще лучай когда в ячейк не 1 буква, например, 7.6Я, а еще когда так в ячейке: 7.6АП

Прикладываю файл, помогите!

П.с. сейчас еще сам, конечно попробую, но не факт что смогу.
К сообщению приложен файл: 6893054.xls(25.0 Kb)
 
Ответить
СообщениеСОС!!
Помогите, оказывается надо учесть еще лучай когда в ячейк не 1 буква, например, 7.6Я, а еще когда так в ячейке: 7.6АП

Прикладываю файл, помогите!

П.с. сейчас еще сам, конечно попробую, но не факт что смогу.

Автор - exc012
Дата добавления - 11.11.2019 в 08:03
Светлый Дата: Понедельник, 11.11.2019, 09:17 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1340
Репутация: 333 ±
Замечаний: 0% ±

Excel 2010
конечно попробую
Ещё одна функция ПОДСТАВИТЬ и всё в порядке.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
конечно попробую
Ещё одна функция ПОДСТАВИТЬ и всё в порядке.

Автор - Светлый
Дата добавления - 11.11.2019 в 09:17
exc012 Дата: Понедельник, 11.11.2019, 10:53 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
У меня вообще не работал.
Пожалуйста?


Сообщение отредактировал китин - Понедельник, 11.11.2019, 12:52
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
У меня вообще не работал.
Пожалуйста?

Автор - exc012
Дата добавления - 11.11.2019 в 10:53
exc012 Дата: Понедельник, 11.11.2019, 11:35 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Очень бы хотелось получить ответ. Просто срочно надо!!!
Ковыряюсь по всякому, не работает

Вот в такой формуле, если поставить 3 нуля, тогда работает, если Я с пробелом стоит, но это тоже не вариант пробелы ставить
Код
=СУММПРОИЗВ(--ПСТР("000"&A3:C3;1;ДЛСТР(A3:C3)+1))
 
Ответить
СообщениеОчень бы хотелось получить ответ. Просто срочно надо!!!
Ковыряюсь по всякому, не работает

Вот в такой формуле, если поставить 3 нуля, тогда работает, если Я с пробелом стоит, но это тоже не вариант пробелы ставить
Код
=СУММПРОИЗВ(--ПСТР("000"&A3:C3;1;ДЛСТР(A3:C3)+1))

Автор - exc012
Дата добавления - 11.11.2019 в 11:35
bmv98rus Дата: Понедельник, 11.11.2019, 12:27 | Сообщение № 12
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Ковыряюсь по всякому, не работает

Ну вы ж сразу от правильного варианта переключились на понятный Вам.

Цитата Светлый, 11.11.2019 в 09:17, в сообщении № 9 ()
Ещё одна функция ПОДСТАВИТЬ и всё в порядке.

Код
=SUMPRODUCT(--SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A3:C3;"Я";);"АП";);".";","))
К сообщению приложен файл: Copy_of_1267.xlsx(17.3 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Ковыряюсь по всякому, не работает

Ну вы ж сразу от правильного варианта переключились на понятный Вам.

Цитата Светлый, 11.11.2019 в 09:17, в сообщении № 9 ()
Ещё одна функция ПОДСТАВИТЬ и всё в порядке.

Код
=SUMPRODUCT(--SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(A3:C3;"Я";);"АП";);".";","))

Автор - bmv98rus
Дата добавления - 11.11.2019 в 12:27
exc012 Дата: Понедельник, 11.11.2019, 12:45 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, видимо я плохой пример привел.
Там внутри длинная строка и могут быть пустые ячейки

Этот вариант работает только при непрерывной строке.

А строка может быть:

7.8Я 7.8АП В В 7.8РП

То есть и букв может быть много и в ячейке может быть только буква без часов.
 
Ответить
СообщениеСпасибо, видимо я плохой пример привел.
Там внутри длинная строка и могут быть пустые ячейки

Этот вариант работает только при непрерывной строке.

А строка может быть:

7.8Я 7.8АП В В 7.8РП

То есть и букв может быть много и в ячейке может быть только буква без часов.

Автор - exc012
Дата добавления - 11.11.2019 в 12:45
bmv98rus Дата: Понедельник, 11.11.2019, 12:52 | Сообщение № 14
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
видимо я плохой пример привел.

Естественно надо прикладывать реалистичные данные, или уметь адаптировать к ним решения.
К сообщению приложен файл: Copy_of_1267_1.xlsx(17.3 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
видимо я плохой пример привел.

Естественно надо прикладывать реалистичные данные, или уметь адаптировать к ним решения.

Автор - bmv98rus
Дата добавления - 11.11.2019 в 12:52
exc012 Дата: Понедельник, 11.11.2019, 12:53 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот, прикладываю файл уже приближенный.
К сообщению приложен файл: 6538239.xlsx(11.1 Kb)
 
Ответить
СообщениеВот, прикладываю файл уже приближенный.

Автор - exc012
Дата добавления - 11.11.2019 в 12:53
exc012 Дата: Понедельник, 11.11.2019, 12:57 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Естественно надо прикладывать реалистичные данные, или уметь адаптировать к ним решения.
К сообщению приложен файл: Copy_of_1267_1.xlsx(17.3 Kb)

Да, вижу тут есть обработка ошибки, но, если как в недавнем выложеном файле. Разные буквы, т.е. чтобы учесть все буквы надо формулу очень большукю тут рисовать

Поэтому я схватился за вариант
Код
=СУММПРОИЗВ(--ПСТР("00"&A3:C3;1;ДЛСТР(A3:C3)+1))


Где все это работало и только не учитывало буквы с длиной 2 (т.е. всякие РП, АП, ДО, и т.д.)
И попытался ее смодифицировать
 
Ответить
Сообщение
Естественно надо прикладывать реалистичные данные, или уметь адаптировать к ним решения.
К сообщению приложен файл: Copy_of_1267_1.xlsx(17.3 Kb)

Да, вижу тут есть обработка ошибки, но, если как в недавнем выложеном файле. Разные буквы, т.е. чтобы учесть все буквы надо формулу очень большукю тут рисовать

Поэтому я схватился за вариант
Код
=СУММПРОИЗВ(--ПСТР("00"&A3:C3;1;ДЛСТР(A3:C3)+1))


Где все это работало и только не учитывало буквы с длиной 2 (т.е. всякие РП, АП, ДО, и т.д.)
И попытался ее смодифицировать

Автор - exc012
Дата добавления - 11.11.2019 в 12:57
exc012 Дата: Понедельник, 11.11.2019, 13:13 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
--ПОДСТАВИТЬ(A3:C3;"Я";)

Что то хотел упростить (убрать замену точек на зпт) и добавить обработку еще 1 символа "РП" что-то заплюхался
...Еще пробую так, чтото не работает

Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3:E3;"Я";);"АП";);"РП";);))


Сообщение отредактировал exc012 - Понедельник, 11.11.2019, 13:14
 
Ответить
Сообщение
--ПОДСТАВИТЬ(A3:C3;"Я";)

Что то хотел упростить (убрать замену точек на зпт) и добавить обработку еще 1 символа "РП" что-то заплюхался
...Еще пробую так, чтото не работает

Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A3:E3;"Я";);"АП";);"РП";);))

Автор - exc012
Дата добавления - 11.11.2019 в 13:13
bmv98rus Дата: Понедельник, 11.11.2019, 13:22 | Сообщение № 18
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Ага,а если учесть что пример от
7.8Я 7.8АП В В 7.8РП
то...

Короче, если тексто суффиксом, то массивная
Код
=SUM(IFERROR(--SUBSTITUTE(LEFT(A3:E3;MAX(IF(ISNUMBER(--MID(A3:E3;{1;2;3;4;5};1));{1;2;3;4;5})));".";",");))
Думаю 5 хватит, даже если будет 23.59

Нормальные примеры в следующий раз готовьте.

Что-то сложное вышло из под пера
Код
=SUM(IFERROR(--SUBSTITUTE(LEFT(A3:E3;TRANSPOSE(MMULT(--(ISNUMBER(--MID(TRANSPOSE(SUBSTITUTE(A3:E3;".";","));1;{1\2\3\4\5})));{1;1;1;1;1})));".";",");))
К сообщению приложен файл: Copy_of_1267_2.xlsx(17.2 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 11.11.2019, 14:28
 
Ответить
СообщениеАга,а если учесть что пример от
7.8Я 7.8АП В В 7.8РП
то...

Короче, если тексто суффиксом, то массивная
Код
=SUM(IFERROR(--SUBSTITUTE(LEFT(A3:E3;MAX(IF(ISNUMBER(--MID(A3:E3;{1;2;3;4;5};1));{1;2;3;4;5})));".";",");))
Думаю 5 хватит, даже если будет 23.59

Нормальные примеры в следующий раз готовьте.

Что-то сложное вышло из под пера
Код
=SUM(IFERROR(--SUBSTITUTE(LEFT(A3:E3;TRANSPOSE(MMULT(--(ISNUMBER(--MID(TRANSPOSE(SUBSTITUTE(A3:E3;".";","));1;{1\2\3\4\5})));{1;1;1;1;1})));".";",");))

Автор - bmv98rus
Дата добавления - 11.11.2019 в 13:22
exc012 Дата: Понедельник, 11.11.2019, 13:24 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016

Естественно надо прикладывать реалистичные данные, или уметь адаптировать к ним решения.
К сообщению приложен файл: Copy_of_1267_1.xlsx(17.3 Kb)


Добавил обработку еще символа, кое-как с бубном заработало.
Сейчас попытаюсь все буквы учесть
 
Ответить
Сообщение

Естественно надо прикладывать реалистичные данные, или уметь адаптировать к ним решения.
К сообщению приложен файл: Copy_of_1267_1.xlsx(17.3 Kb)


Добавил обработку еще символа, кое-как с бубном заработало.
Сейчас попытаюсь все буквы учесть

Автор - exc012
Дата добавления - 11.11.2019 в 13:24
exc012 Дата: Понедельник, 11.11.2019, 13:38 | Сообщение № 20
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
7.8Я 7.8АП В В 7.8РП
то...

Короче, если тексто суффиксом, то массивная

=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ЛЕВСИМВ(A3:E3;МАКС(ЕСЛИ(ЕЧИСЛО(--ПСТР(A3:E3;{1;2;3;4;5};1));{1;2;3;4;5})));".";",");))
Думаю 5 хватит, даже если будет 23.59
Нормальные примеры в следующий раз готовьте.

Формула в вашем примере работает, а себе в лист вставляю и меняю диапазон на свой и показывает 0.
Вроде аккуратно копирую формулу.
 
Ответить
Сообщение
7.8Я 7.8АП В В 7.8РП
то...

Короче, если тексто суффиксом, то массивная

=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ЛЕВСИМВ(A3:E3;МАКС(ЕСЛИ(ЕЧИСЛО(--ПСТР(A3:E3;{1;2;3;4;5};1));{1;2;3;4;5})));".";",");))
Думаю 5 хватит, даже если будет 23.59
Нормальные примеры в следующий раз готовьте.

Формула в вашем примере работает, а себе в лист вставляю и меняю диапазон на свой и показывает 0.
Вроде аккуратно копирую формулу.

Автор - exc012
Дата добавления - 11.11.2019 в 13:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать сумму ячеек где буквы и цифры (Формулы/Formulas)
  • Страница 1 из 3
  • 1
  • 2
  • 3
  • »
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!