Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по многим условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по многим условиям (Формулы/Formulas)
Суммирование по многим условиям
mark_twen_1975 Дата: Вторник, 17.03.2020, 11:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую.

Следующая проблема. Есть огромный файл с данными по показам, кликам, бюджету рекламы клиентов (страница sheet 1).

На странице main нужно просуммировать данные только по тем кампаниям, которые содержат test1 или test2 (эти названия условны, т.к. реальные названия кампаний не могут разглашаться). При этом на странице main нужна разбивка по датам, чтобы даты не повторялись как на странице sheet1.

Пробовал через суммеслимн и регулярное выражение, но не получается.

Файл пример прикладываю.

С уважением.
К сообщению приложен файл: Example.xlsx(6.3 Kb)
 
Ответить
СообщениеПриветствую.

Следующая проблема. Есть огромный файл с данными по показам, кликам, бюджету рекламы клиентов (страница sheet 1).

На странице main нужно просуммировать данные только по тем кампаниям, которые содержат test1 или test2 (эти названия условны, т.к. реальные названия кампаний не могут разглашаться). При этом на странице main нужна разбивка по датам, чтобы даты не повторялись как на странице sheet1.

Пробовал через суммеслимн и регулярное выражение, но не получается.

Файл пример прикладываю.

С уважением.

Автор - mark_twen_1975
Дата добавления - 17.03.2020 в 11:26
YouGreed Дата: Вторник, 17.03.2020, 12:08 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 553
Репутация: 116 ±
Замечаний: 0% ±

Excel 2010
mark_twen_1975,
Код
=СУММПРОИЗВ(((Sheet1!$C$2:$C$14=Sheet1!$C$2)+(Sheet1!$C$2:$C$14=Sheet1!$C$3))*(Sheet1!$A$2:$A$14=Main!$A2)*Sheet1!D$2:D$14)


Сначала объединяем 2 условия test1 и test2, потом, выбираем даты и добавляем значения
К сообщению приложен файл: Example-Sum_oth.xlsx(11.0 Kb)


Сообщение отредактировал YouGreed - Вторник, 17.03.2020, 12:09
 
Ответить
Сообщениеmark_twen_1975,
Код
=СУММПРОИЗВ(((Sheet1!$C$2:$C$14=Sheet1!$C$2)+(Sheet1!$C$2:$C$14=Sheet1!$C$3))*(Sheet1!$A$2:$A$14=Main!$A2)*Sheet1!D$2:D$14)


Сначала объединяем 2 условия test1 и test2, потом, выбираем даты и добавляем значения

Автор - YouGreed
Дата добавления - 17.03.2020 в 12:08
mark_twen_1975 Дата: Вторник, 17.03.2020, 13:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сначала объединяем 2 условия test1 и test2, потом, выбираем даты и добавляем значения

Можете уточнить? И скажите, эта функция в Гуглдокс называется SUMPRODUCT?
 
Ответить
Сообщение
Сначала объединяем 2 условия test1 и test2, потом, выбираем даты и добавляем значения

Можете уточнить? И скажите, эта функция в Гуглдокс называется SUMPRODUCT?

Автор - mark_twen_1975
Дата добавления - 17.03.2020 в 13:08
mark_twen_1975 Дата: Вторник, 17.03.2020, 13:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Я пытался сделать так:

Код
=СУММЕСЛИМН('Выгрузка'!D:D;'Выгрузка'!A:A;A:A;'Выгрузка'!C:C;REGEXMATCH('Выгрузка'!C:C;".*vk.*"))

Но не получилось. Не знаете, почему?


Сообщение отредактировал mark_twen_1975 - Вторник, 17.03.2020, 13:38
 
Ответить
СообщениеЯ пытался сделать так:

Код
=СУММЕСЛИМН('Выгрузка'!D:D;'Выгрузка'!A:A;A:A;'Выгрузка'!C:C;REGEXMATCH('Выгрузка'!C:C;".*vk.*"))

Но не получилось. Не знаете, почему?

Автор - mark_twen_1975
Дата добавления - 17.03.2020 в 13:09
китин Дата: Вторник, 17.03.2020, 13:09 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6215
Репутация: 957 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и тут тоже обсуждаем
mark_twen_1975,
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи тут тоже обсуждаем
mark_twen_1975,
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 17.03.2020 в 13:09
YouGreed Дата: Вторник, 17.03.2020, 13:14 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 553
Репутация: 116 ±
Замечаний: 0% ±

Excel 2010
mark_twen_1975,
Цитата
И скажите, эта функция в Гуглдокс называется SUMPRODUCT?
- Да.

Цитата
Можете уточнить?


Код
(Sheet1!$C$2:$C$14=Sheet1!$C$2)
- формируем список клиентов, признак test1
Код
(Sheet1!$C$2:$C$14=Sheet1!$C$3)
- формируем список клиентов, признак test2
Код
((Sheet1!$C$2:$C$14=Sheet1!$C$2)+(Sheet1!$C$2:$C$14=Sheet1!$C$3))
- совмещаем оба списка (получается {ИСТИНА:ИСТИНА:ЛОЖЬ и т.д.})
Код
(Sheet1!$A$2:$A$14=Main!$A2)
- формируем список нужных нам дат
Код
Sheet1!D$2:D$14
- умножаем на все это безобразие
Вся функция, суммирует наш массив и захлопывает в 1 значение
 
Ответить
Сообщениеmark_twen_1975,
Цитата
И скажите, эта функция в Гуглдокс называется SUMPRODUCT?
- Да.

Цитата
Можете уточнить?


Код
(Sheet1!$C$2:$C$14=Sheet1!$C$2)
- формируем список клиентов, признак test1
Код
(Sheet1!$C$2:$C$14=Sheet1!$C$3)
- формируем список клиентов, признак test2
Код
((Sheet1!$C$2:$C$14=Sheet1!$C$2)+(Sheet1!$C$2:$C$14=Sheet1!$C$3))
- совмещаем оба списка (получается {ИСТИНА:ИСТИНА:ЛОЖЬ и т.д.})
Код
(Sheet1!$A$2:$A$14=Main!$A2)
- формируем список нужных нам дат
Код
Sheet1!D$2:D$14
- умножаем на все это безобразие
Вся функция, суммирует наш массив и захлопывает в 1 значение

Автор - YouGreed
Дата добавления - 17.03.2020 в 13:14
китин Дата: Вторник, 17.03.2020, 13:18 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6215
Репутация: 957 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
YouGreed, а вы моё замечание видели?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеYouGreed, а вы моё замечание видели?

Автор - китин
Дата добавления - 17.03.2020 в 13:18
mark_twen_1975 Дата: Вторник, 17.03.2020, 13:42 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем спасибо. Сейчас попробую сделать.

китин, формулу оформил с тегом.
 
Ответить
СообщениеВсем спасибо. Сейчас попробую сделать.

китин, формулу оформил с тегом.

Автор - mark_twen_1975
Дата добавления - 17.03.2020 в 13:42
китин Дата: Вторник, 17.03.2020, 14:10 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 6215
Репутация: 957 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну и мои 5 копеек. За Гуглдокс не уверен
Код
=СУММПРОИЗВ(Sheet1!$D$2:$F$14*(Main!$A2=Sheet1!$A$2:$A$14)*(B$1=Sheet1!$D$1:$F$1)*(($L$1=Sheet1!$C$2:$C$14)+($L$2=Sheet1!$C$2:$C$14)))

в ячейках L1 и L2 выпадающие списки где можно выбирать фирмы
К сообщению приложен файл: Example-1-.xlsx(10.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену и мои 5 копеек. За Гуглдокс не уверен
Код
=СУММПРОИЗВ(Sheet1!$D$2:$F$14*(Main!$A2=Sheet1!$A$2:$A$14)*(B$1=Sheet1!$D$1:$F$1)*(($L$1=Sheet1!$C$2:$C$14)+($L$2=Sheet1!$C$2:$C$14)))

в ячейках L1 и L2 выпадающие списки где можно выбирать фирмы

Автор - китин
Дата добавления - 17.03.2020 в 14:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по многим условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!