Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как преобразовать один столбец в таблицу из трёх столбцов ? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как преобразовать один столбец в таблицу из трёх столбцов ? (Формулы/Formulas)
Как преобразовать один столбец в таблицу из трёх столбцов ?
Птах Дата: Понедельник, 24.08.2020, 18:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, форумчане.
Прошу Вас подсказать, каким образом Таблицу1, состоявшую из одного столбца, можно преобразовать в Таблицу2, в которой будет 3 столбца ?
В оригинале, в левом столбце более двух тысяч строк, и переносить это всё вручную слишком долго и муторно.
Возможно ли это сделать только с помощью формулы, без макросов ?
К сообщению приложен файл: 1310311.xlsx(9.1 Kb)
 
Ответить
СообщениеЗдравствуйте, форумчане.
Прошу Вас подсказать, каким образом Таблицу1, состоявшую из одного столбца, можно преобразовать в Таблицу2, в которой будет 3 столбца ?
В оригинале, в левом столбце более двух тысяч строк, и переносить это всё вручную слишком долго и муторно.
Возможно ли это сделать только с помощью формулы, без макросов ?

Автор - Птах
Дата добавления - 24.08.2020 в 18:04
bigor Дата: Понедельник, 24.08.2020, 19:45 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер

До одной универсальной не додумал еще :)
поэтому отдельно для первой строки
Код
=INDEX($A$2:$A$34;COLUMN(A1))
и для остальных строк
Код
=INDEX($A$2:$A$34;COLUMN(A2)+ROW(A1)*3)
К сообщению приложен файл: 1310311_1.xlsx(6.7 Kb)
 
Ответить
СообщениеДобрый вечер

До одной универсальной не додумал еще :)
поэтому отдельно для первой строки
Код
=INDEX($A$2:$A$34;COLUMN(A1))
и для остальных строк
Код
=INDEX($A$2:$A$34;COLUMN(A2)+ROW(A1)*3)

Автор - bigor
Дата добавления - 24.08.2020 в 19:45
прохожий2019 Дата: Понедельник, 24.08.2020, 19:53 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 382
Репутация: 64 ±
Замечаний: 0% ±

365 Beta Channel
одна универсальная
Код
=ИНДЕКС($A$2:$A$34;СТОЛБЕЦ(A1)+(СТРОКА(A1)-1)*3)
в новой эксельке
Код
=ИНДЕКС(A2:A34;ПОСЛЕД(СЧЁТЗ(A2:A34)/3;3))
К сообщению приложен файл: 6513934.xlsx(13.1 Kb)
 
Ответить
Сообщениеодна универсальная
Код
=ИНДЕКС($A$2:$A$34;СТОЛБЕЦ(A1)+(СТРОКА(A1)-1)*3)
в новой эксельке
Код
=ИНДЕКС(A2:A34;ПОСЛЕД(СЧЁТЗ(A2:A34)/3;3))

Автор - прохожий2019
Дата добавления - 24.08.2020 в 19:53
Птах Дата: Пятница, 28.08.2020, 16:57 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
До одной универсальной не додумал еще :)
поэтому отдельно для первой строки

Спасибо огромное за помощь. Да, всё работает.
 
Ответить
Сообщение
До одной универсальной не додумал еще :)
поэтому отдельно для первой строки

Спасибо огромное за помощь. Да, всё работает.

Автор - Птах
Дата добавления - 28.08.2020 в 16:57
Птах Дата: Пятница, 28.08.2020, 17:00 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата прохожий2019, 24.08.2020 в 19:53, в сообщении № 3 ()
одна универсальная

Спасибо!
Посидел, разобрался как оно работает.... чтоб в аналогичном случае не приставать с глупыми вопросами )).
 
Ответить
Сообщение
Цитата прохожий2019, 24.08.2020 в 19:53, в сообщении № 3 ()
одна универсальная

Спасибо!
Посидел, разобрался как оно работает.... чтоб в аналогичном случае не приставать с глупыми вопросами )).

Автор - Птах
Дата добавления - 28.08.2020 в 17:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как преобразовать один столбец в таблицу из трёх столбцов ? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!