Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/отображение чисел в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » отображение чисел в таблице (Формулы/Formulas)
отображение чисел в таблице
artastrelok Дата: Четверг, 05.11.2020, 21:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
добрый вечер. наверняка решение где то есть на форуме, но я за два дня решение найти не смог. если есть ссылка, скиньте.
есть столбец чисел, они должны отображаться в таблице в своем диапазоне.
у меня Excel 2010 xlsx, извините.
К сообщению приложен файл: 4653585.xlsx(9.3 Kb)
 
Ответить
Сообщениедобрый вечер. наверняка решение где то есть на форуме, но я за два дня решение найти не смог. если есть ссылка, скиньте.
есть столбец чисел, они должны отображаться в таблице в своем диапазоне.
у меня Excel 2010 xlsx, извините.

Автор - artastrelok
Дата добавления - 05.11.2020 в 21:43
bigor Дата: Четверг, 05.11.2020, 22:17 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Добрый

Если таблицу чуть подправить, убрать лишние пробелы, то можно немножко сократить формулу
Код
=IFERROR(INDEX($B$2:$B$5;SMALL(IF(($B$2:$B$5>=--LEFT(TRIM(D$1);2))*($B$2:$B$5<=--RIGHT(TRIM(D$1);2));ROW($A$2:$A$5)-1;"");ROW(A1)));"")
массивная
К сообщению приложен файл: 4653585_1.xlsx(7.6 Kb)
 
Ответить
СообщениеДобрый

Если таблицу чуть подправить, убрать лишние пробелы, то можно немножко сократить формулу
Код
=IFERROR(INDEX($B$2:$B$5;SMALL(IF(($B$2:$B$5>=--LEFT(TRIM(D$1);2))*($B$2:$B$5<=--RIGHT(TRIM(D$1);2));ROW($A$2:$A$5)-1;"");ROW(A1)));"")
массивная

Автор - bigor
Дата добавления - 05.11.2020 в 22:17
Nic70y Дата: Пятница, 06.11.2020, 08:53 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6602
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
не массивная
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА(D1)<=СЧЁТЕСЛИ($B$2:$B$5;"<="&ПСТР(D$1;ПОИСК("-";D$1)+1;15));НАИБОЛЬШИЙ($B$2:$B$5;СЧЁТЕСЛИ($B$2:$B$5;">="&ЛЕВБ(D$1;ПОИСК("-";D$1)-1))-СТРОКА(D1)+1);"");"")
К сообщению приложен файл: 22-18.xlsx(12.4 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениене массивная
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА(D1)<=СЧЁТЕСЛИ($B$2:$B$5;"<="&ПСТР(D$1;ПОИСК("-";D$1)+1;15));НАИБОЛЬШИЙ($B$2:$B$5;СЧЁТЕСЛИ($B$2:$B$5;">="&ЛЕВБ(D$1;ПОИСК("-";D$1)-1))-СТРОКА(D1)+1);"");"")

Автор - Nic70y
Дата добавления - 06.11.2020 в 08:53
bigor Дата: Пятница, 06.11.2020, 16:23 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
не массивная

Нужно где-то подкрутить
К сообщению приложен файл: 7563073.png(8.1 Kb)
 
Ответить
Сообщение
не массивная

Нужно где-то подкрутить

Автор - bigor
Дата добавления - 06.11.2020 в 16:23
Nic70y Дата: Пятница, 06.11.2020, 16:46 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6602
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
подкрутить
да, действительно
Код
=ЕСЛИ(СТРОКА(D1)<=СЧЁТЕСЛИМН($B$2:$B$5;">="&ЛЕВБ(D$1;ПОИСК("-";D$1)-1);$B$2:$B$5;"<="&ПСТР(D$1;ПОИСК("-";D$1)+1;15));НАИБОЛЬШИЙ($B$2:$B$5;СЧЁТЕСЛИ($B$2:$B$5;">="&ЛЕВБ(D$1;ПОИСК("-";D$1)-1))-СТРОКА(D1)+1);"")


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
подкрутить
да, действительно
Код
=ЕСЛИ(СТРОКА(D1)<=СЧЁТЕСЛИМН($B$2:$B$5;">="&ЛЕВБ(D$1;ПОИСК("-";D$1)-1);$B$2:$B$5;"<="&ПСТР(D$1;ПОИСК("-";D$1)+1;15));НАИБОЛЬШИЙ($B$2:$B$5;СЧЁТЕСЛИ($B$2:$B$5;">="&ЛЕВБ(D$1;ПОИСК("-";D$1)-1))-СТРОКА(D1)+1);"")

Автор - Nic70y
Дата добавления - 06.11.2020 в 16:46
artastrelok Дата: Суббота, 07.11.2020, 20:22 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
добрый вечер. всем спасибо за работу. я бы конечно такое написать не смог никогда. но я наверное не правильно объяснил какой результат хотелось бы видеть. в правом столбце позиций намного больше и будут данные добавляться. так же есть одинаковые цифры. и хотелось бы чтобы из левого столбца цифры в таблице отображались напротив своей строки. выложу образец, надеюсь будет более понятно.
К сообщению приложен файл: 3215842.xlsx(10.3 Kb)
 
Ответить
Сообщениедобрый вечер. всем спасибо за работу. я бы конечно такое написать не смог никогда. но я наверное не правильно объяснил какой результат хотелось бы видеть. в правом столбце позиций намного больше и будут данные добавляться. так же есть одинаковые цифры. и хотелось бы чтобы из левого столбца цифры в таблице отображались напротив своей строки. выложу образец, надеюсь будет более понятно.

Автор - artastrelok
Дата добавления - 07.11.2020 в 20:22
Nic70y Дата: Понедельник, 09.11.2020, 08:39 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 6602
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
ну так это намного проще
Код
=ЕСЛИ(И($C9>=--ЛЕВБ(E$8;ПОИСК("-";E$8)-1);$C9<=--ПСТР(E$8;ПОИСК("-";E$8)+1;15));$C9;"")
К сообщению приложен файл: 2656664.xlsx(10.8 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениену так это намного проще
Код
=ЕСЛИ(И($C9>=--ЛЕВБ(E$8;ПОИСК("-";E$8)-1);$C9<=--ПСТР(E$8;ПОИСК("-";E$8)+1;15));$C9;"")

Автор - Nic70y
Дата добавления - 09.11.2020 в 08:39
bigor Дата: Понедельник, 09.11.2020, 08:44 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Ну так даже не интересно :)
Код
=IF(AND($C9>=--LEFT(E$8;1);$C9<=--RIGHT(TRIM(E$8);2));$C9;"")
К сообщению приложен файл: 3215842_1.xlsx(8.5 Kb)
 
Ответить
СообщениеНу так даже не интересно :)
Код
=IF(AND($C9>=--LEFT(E$8;1);$C9<=--RIGHT(TRIM(E$8);2));$C9;"")

Автор - bigor
Дата добавления - 09.11.2020 в 08:44
artastrelok Дата: Понедельник, 09.11.2020, 13:49 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
добрый день. спасибо что помогли. теперь: столбец цифр слева должен распределяться в новой таблице, каждая цифра в своем столбце. ниже пример.
К сообщению приложен файл: 8295352.xlsx(11.2 Kb)
 
Ответить
Сообщениедобрый день. спасибо что помогли. теперь: столбец цифр слева должен распределяться в новой таблице, каждая цифра в своем столбце. ниже пример.

Автор - artastrelok
Дата добавления - 09.11.2020 в 13:49
китин Дата: Понедельник, 09.11.2020, 13:50 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 6319
Репутация: 970 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
artastrelok, - Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеartastrelok, - Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема

Автор - китин
Дата добавления - 09.11.2020 в 13:50
artastrelok Дата: Понедельник, 09.11.2020, 15:27 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
извиняюсь. не хотел плодить темы. всем спасибо.
 
Ответить
Сообщениеизвиняюсь. не хотел плодить темы. всем спасибо.

Автор - artastrelok
Дата добавления - 09.11.2020 в 15:27
artastrelok Дата: Понедельник, 09.11.2020, 15:35 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
в принципе тему наверное можно закрыть. только я не знаю как.
 
Ответить
Сообщениев принципе тему наверное можно закрыть. только я не знаю как.

Автор - artastrelok
Дата добавления - 09.11.2020 в 15:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » отображение чисел в таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!