Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ранжирование при наличии нескольких условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование при наличии нескольких условий (Формулы/Formulas)
Ранжирование при наличии нескольких условий
соня9158 Дата: Среда, 20.01.2021, 13:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!

не могу ни как подобрать формулу

Дано: необходимо рассчитать место по порядку отгруженной продукции за год при соблюдении условий в 1 квартале отгружено 15 и более, во втором квартале 20 и более, в третьем 5 и долее .При соблюдении трех условий не зависимо то количества отгрузки за год 1 место, если нет то считай места у всех остальных исходя от отгруженной продукции за год начиная со следующего по порядку числа от количества первых мест.

пытаюсь прописать формулу
Код
=ЕСЛИ(И(C3>=15;D3>=20;E3>=5);"1";РАНГ.РВ(B3;$B$3:$B$60;0))
при ранжировании данных, при соблюдении одного условий считает верно, но если идет соблюдение двух условий из трех уже не так считает, не знаю как прописать критерий, что если два истина из трех надо ранж значение лож.
Заранее благодарю!!!
К сообщению приложен файл: __2020.xls(40.5 Kb)


Сообщение отредактировал соня9158 - Среда, 20.01.2021, 14:08
 
Ответить
СообщениеЗдравствуйте!

не могу ни как подобрать формулу

Дано: необходимо рассчитать место по порядку отгруженной продукции за год при соблюдении условий в 1 квартале отгружено 15 и более, во втором квартале 20 и более, в третьем 5 и долее .При соблюдении трех условий не зависимо то количества отгрузки за год 1 место, если нет то считай места у всех остальных исходя от отгруженной продукции за год начиная со следующего по порядку числа от количества первых мест.

пытаюсь прописать формулу
Код
=ЕСЛИ(И(C3>=15;D3>=20;E3>=5);"1";РАНГ.РВ(B3;$B$3:$B$60;0))
при ранжировании данных, при соблюдении одного условий считает верно, но если идет соблюдение двух условий из трех уже не так считает, не знаю как прописать критерий, что если два истина из трех надо ранж значение лож.
Заранее благодарю!!!

Автор - соня9158
Дата добавления - 20.01.2021 в 13:54
соня9158 Дата: Среда, 20.01.2021, 14:10 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Сорри!!!
файл выложился без правильных заголовков
К сообщению приложен файл: 4035557.xls(40.5 Kb)
 
Ответить
СообщениеСорри!!!
файл выложился без правильных заголовков

Автор - соня9158
Дата добавления - 20.01.2021 в 14:10
Nic70y Дата: Среда, 20.01.2021, 14:13 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6751
Репутация: 1543 ±
Замечаний: 0% ±

Excel 2010
Сори! Уже написал формулу по 1-му файлу)
массивка:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B3;НАИБОЛЬШИЙ(ЕСЛИ((C$3:C$60<15)+(D$3:D$60<20)+(E$3:E$60<5);B$3:B$60);СТРОКА(B$3:B$60)-2);)+СУММ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5));1)
К сообщению приложен файл: 18.xls(50.0 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
СообщениеСори! Уже написал формулу по 1-му файлу)
массивка:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B3;НАИБОЛЬШИЙ(ЕСЛИ((C$3:C$60<15)+(D$3:D$60<20)+(E$3:E$60<5);B$3:B$60);СТРОКА(B$3:B$60)-2);)+СУММ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5));1)

Автор - Nic70y
Дата добавления - 20.01.2021 в 14:13
Serge_007 Дата: Среда, 20.01.2021, 14:23 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13707
Репутация: 2301 ±
Замечаний: ±

Excel 2010
Здравствуйте

РАНГ() использовал, но он не любит виртуальные массивы, поэтому с допстолбцом:
Код
=ЕСЛИ(СУММ((C3>=15)*(D3>=20)*(E3>=5))=1;1;РАНГ(I3;I$3:I$60)+СУММПРОИЗВ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5)))
К сообщению приложен файл: 20210120_9158.xls(47.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

РАНГ() использовал, но он не любит виртуальные массивы, поэтому с допстолбцом:
Код
=ЕСЛИ(СУММ((C3>=15)*(D3>=20)*(E3>=5))=1;1;РАНГ(I3;I$3:I$60)+СУММПРОИЗВ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5)))

Автор - Serge_007
Дата добавления - 20.01.2021 в 14:23
соня9158 Дата: Среда, 20.01.2021, 15:20 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное!

а можно объяснить последовательность в формуле, для понимания


Сообщение отредактировал Serge_007 - Среда, 20.01.2021, 17:04
 
Ответить
СообщениеСпасибо огромное!

а можно объяснить последовательность в формуле, для понимания

Автор - соня9158
Дата добавления - 20.01.2021 в 15:20
соня9158 Дата: Среда, 20.01.2021, 15:58 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Сори! Уже написал формулу по 1-му файлу)
массивка:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B3;НАИБОЛЬШИЙ(ЕСЛИ((C$3:C$60<15)+(D$3:D$60<20)+(E$3:E$60<5);B$3:B$60);СТРОКА(B$3:B$60)-2);)+СУММ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5));1)


Спасибо огромное!!!! не ожидала что так быстро придете на помощь!!!! пока еще не до конца поняла, но все в переди


Сообщение отредактировал Serge_007 - Среда, 20.01.2021, 17:05
 
Ответить
Сообщение
Сори! Уже написал формулу по 1-му файлу)
массивка:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B3;НАИБОЛЬШИЙ(ЕСЛИ((C$3:C$60<15)+(D$3:D$60<20)+(E$3:E$60<5);B$3:B$60);СТРОКА(B$3:B$60)-2);)+СУММ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5));1)


Спасибо огромное!!!! не ожидала что так быстро придете на помощь!!!! пока еще не до конца поняла, но все в переди

Автор - соня9158
Дата добавления - 20.01.2021 в 15:58
Serge_007 Дата: Среда, 20.01.2021, 17:12 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13707
Репутация: 2301 ±
Замечаний: ±

Excel 2010
можно объяснить последовательность в формуле

Эта часть формулы ЕСЛИ(СУММ((C3>=15)*(D3>=20)*(E3>=5))=1;1 возвращает 1, при выполнении всех трех условий (C3>=15)*(D3>=20)*(E3>=5)
Эта часть РАНГ(I3;I$3:I$60) производит ранжирование по допстолбцу, в котором исключены все 1
Эта часть СУММПРОИЗВ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5)) считает кол-во 1, после чего плюсует его к рангам, полученным на предыдущем этапе


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
можно объяснить последовательность в формуле

Эта часть формулы ЕСЛИ(СУММ((C3>=15)*(D3>=20)*(E3>=5))=1;1 возвращает 1, при выполнении всех трех условий (C3>=15)*(D3>=20)*(E3>=5)
Эта часть РАНГ(I3;I$3:I$60) производит ранжирование по допстолбцу, в котором исключены все 1
Эта часть СУММПРОИЗВ((C$3:C$60>=15)*(D$3:D$60>=20)*(E$3:E$60>=5)) считает кол-во 1, после чего плюсует его к рангам, полученным на предыдущем этапе

Автор - Serge_007
Дата добавления - 20.01.2021 в 17:12
соня9158 Дата: Среда, 20.01.2021, 17:40 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Благодарю!!!!
 
Ответить
СообщениеБлагодарю!!!!

Автор - соня9158
Дата добавления - 20.01.2021 в 17:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование при наличии нескольких условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!