Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Превратить несколько строк в одну строку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Превратить несколько строк в одну строку (Формулы/Formulas)
Превратить несколько строк в одну строку
Karik Дата: Четверг, 21.01.2021, 09:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Необходимо каждую строку с данными перенести в конец первой строки для возможности дальнейшего транспонирования.
К сообщению приложен файл: 5445690.xlsx(9.4 Kb)
 
Ответить
СообщениеДобрый день. Необходимо каждую строку с данными перенести в конец первой строки для возможности дальнейшего транспонирования.

Автор - Karik
Дата добавления - 21.01.2021 в 09:58
Nic70y Дата: Четверг, 21.01.2021, 10:21 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7744
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
и зачем такие сложности.
вариант формулами с 2-мя доп.ячейками
К сообщению приложен файл: 18.xlsx(11.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеи зачем такие сложности.
вариант формулами с 2-мя доп.ячейками

Автор - Nic70y
Дата добавления - 21.01.2021 в 10:21
Karik Дата: Четверг, 21.01.2021, 10:47 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

вариант формулами с 2-мя доп.ячейками

Большое спасибо!
 
Ответить
Сообщение
вариант формулами с 2-мя доп.ячейками

Большое спасибо!

Автор - Karik
Дата добавления - 21.01.2021 в 10:47
Serge_007 Дата: Четверг, 21.01.2021, 11:54 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15428
Репутация: 2539 ±
Замечаний: ±

Excel 2016
Karik, здравствуйте

Код
=ИНДЕКС(A$3:I$6;ЦЕЛОЕ((СТРОКА(A1)/ЧИСЛСТОЛБ(A2:I2)-0,1)+1);ЦЕЛОЕ(ОСТАТ((СТРОКА(A1)/ЧИСЛСТОЛБ(A2:I2))-0,1;1)*ЧИСЛСТОЛБ(A2:I2))+1)
К сообщению приложен файл: 20210121_Karik.xls(31.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеKarik, здравствуйте

Код
=ИНДЕКС(A$3:I$6;ЦЕЛОЕ((СТРОКА(A1)/ЧИСЛСТОЛБ(A2:I2)-0,1)+1);ЦЕЛОЕ(ОСТАТ((СТРОКА(A1)/ЧИСЛСТОЛБ(A2:I2))-0,1;1)*ЧИСЛСТОЛБ(A2:I2))+1)

Автор - Serge_007
Дата добавления - 21.01.2021 в 11:54
Egyptian Дата: Пятница, 22.01.2021, 18:18 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Еще вариант.
Код
=IFERROR(INDEX($A$3:$I$6,AGGREGATE(15,6,ROW($A$1:$A$6)/($A$2:$I$2=$A13),COUNTIF($A$13:A13,$A13)),MATCH($A13,$A$2:$I$2,)),"")
К сообщению приложен файл: 0725860.xls(36.0 Kb)
 
Ответить
СообщениеЕще вариант.
Код
=IFERROR(INDEX($A$3:$I$6,AGGREGATE(15,6,ROW($A$1:$A$6)/($A$2:$I$2=$A13),COUNTIF($A$13:A13,$A13)),MATCH($A13,$A$2:$I$2,)),"")

Автор - Egyptian
Дата добавления - 22.01.2021 в 18:18
jakim Дата: Пятница, 22.01.2021, 20:30 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Формула для данных

Код
=IFERROR(INDEX($A$3:$P$6;CEILING(ROWS($11:11)/COUNTA(A$2:P$2);1);MOD(ROWS($11:11)-1;COUNTA(A$2:P$2))+1);"")

для показателей

Код
=IF(B11<>"";INDEX(A$2:P$2;;MOD(ROWS(11:$11)-1;COUNTA(A$2:P$2))+1);"")
К сообщению приложен файл: 0725860.xlsx(10.8 Kb)
 
Ответить
Сообщение
Формула для данных

Код
=IFERROR(INDEX($A$3:$P$6;CEILING(ROWS($11:11)/COUNTA(A$2:P$2);1);MOD(ROWS($11:11)-1;COUNTA(A$2:P$2))+1);"")

для показателей

Код
=IF(B11<>"";INDEX(A$2:P$2;;MOD(ROWS(11:$11)-1;COUNTA(A$2:P$2))+1);"")

Автор - jakim
Дата добавления - 22.01.2021 в 20:30
Egyptian Дата: Пятница, 22.01.2021, 21:43 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Добавил формулу для извлечения данных из таблицы в строку по условиям в ячейках А2:I2. Вдруг понадобится.
Код
=IFERROR(INDEX($A$3:$I$6,AGGREGATE(15,6,ROW($A$1:$A$50)/($A$2:$I$2=INDEX($A$2:$I$2,MOD(COLUMN(A1)-1,ROWS($A$3:$A$11))+1)),INT((COLUMNS($A2:A2)-1)/9)+1),MATCH(INDEX($A$2:$I$2,MOD(COLUMN(A1)-1,ROWS($A$3:$A$11))+1),$A$2:$I$2,)),"")

Увы, массивная.
К сообщению приложен файл: table.xls(44.0 Kb)


Сообщение отредактировал Egyptian - Пятница, 22.01.2021, 22:02
 
Ответить
СообщениеДобавил формулу для извлечения данных из таблицы в строку по условиям в ячейках А2:I2. Вдруг понадобится.
Код
=IFERROR(INDEX($A$3:$I$6,AGGREGATE(15,6,ROW($A$1:$A$50)/($A$2:$I$2=INDEX($A$2:$I$2,MOD(COLUMN(A1)-1,ROWS($A$3:$A$11))+1)),INT((COLUMNS($A2:A2)-1)/9)+1),MATCH(INDEX($A$2:$I$2,MOD(COLUMN(A1)-1,ROWS($A$3:$A$11))+1),$A$2:$I$2,)),"")

Увы, массивная.

Автор - Egyptian
Дата добавления - 22.01.2021 в 21:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Превратить несколько строк в одну строку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!