Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос части текста из ячейки в ячейку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос части текста из ячейки в ячейку (Формулы/Formulas)
Перенос части текста из ячейки в ячейку
User799 Дата: Понедельник, 08.03.2021, 14:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!

Нашел на форуме тему с вопросом, похожим на мой - позаимствовал оттуда формулу. Она подошла, но не идеально - нужно донастроить.

Описание моего случая:
В ячейках в столбце А у меня находятся описания книг, как правило, состоящие из нескольких абзацев: цитата, о чем книга, кто автор. В столбец В мне надо переместить только информацию об авторе. Она не всегда есть в исходном столбце (в этом случае необходимо оставить соответствующую ячейку в столбце В пустой), но когда есть, то имеет постоянные признаки:
1. Абзац, который требуется перенести, всегда начинается с заголовка "Кто автор" (сам заголовок переносить не нужно);
2. Абзац с нужными сведениями числится последним в ячейке (что упрощает задачу составления формулы).

Задача:
Перенести текст со слов "Кто автор" из одной ячейки в другую. Если искомое значение в исходной ячейке отсутствует, то заполняемую ячейку необходимо оставить пустой.

Файл с примером прилагаю.

Прошу помочь.
К сообщению приложен файл: 4117404.xls(61.5 Kb)
 
Ответить
СообщениеДобрый день!

Нашел на форуме тему с вопросом, похожим на мой - позаимствовал оттуда формулу. Она подошла, но не идеально - нужно донастроить.

Описание моего случая:
В ячейках в столбце А у меня находятся описания книг, как правило, состоящие из нескольких абзацев: цитата, о чем книга, кто автор. В столбец В мне надо переместить только информацию об авторе. Она не всегда есть в исходном столбце (в этом случае необходимо оставить соответствующую ячейку в столбце В пустой), но когда есть, то имеет постоянные признаки:
1. Абзац, который требуется перенести, всегда начинается с заголовка "Кто автор" (сам заголовок переносить не нужно);
2. Абзац с нужными сведениями числится последним в ячейке (что упрощает задачу составления формулы).

Задача:
Перенести текст со слов "Кто автор" из одной ячейки в другую. Если искомое значение в исходной ячейке отсутствует, то заполняемую ячейку необходимо оставить пустой.

Файл с примером прилагаю.

Прошу помочь.

Автор - User799
Дата добавления - 08.03.2021 в 14:51
Pelena Дата: Понедельник, 08.03.2021, 15:00 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17442
Репутация: 3876 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ПСТР(A1;ПОИСК("Кто автор";A1)+9;ДЛСТР(A1));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ПСТР(A1;ПОИСК("Кто автор";A1)+9;ДЛСТР(A1));"")

Автор - Pelena
Дата добавления - 08.03.2021 в 15:00
User799 Дата: Понедельник, 08.03.2021, 15:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Спасибо. А если учесть в формуле пустую строку после слов "Кто автор", то как она будет выглядеть?

Код
=ЕСЛИОШИБКА(ПСТР(Y3756;ПОИСК("Кто автор";Y3756)+13;ДЛСТР(Y3756));"")


Так правильно?

И еще уточнение:
Как изменится формула, если добавить в искомые значения, помимо "Кто автор", еще "Кто авторы", "Об авторах" и "Об авторе"?


Сообщение отредактировал User799 - Понедельник, 08.03.2021, 16:08
 
Ответить
СообщениеPelena, Спасибо. А если учесть в формуле пустую строку после слов "Кто автор", то как она будет выглядеть?

Код
=ЕСЛИОШИБКА(ПСТР(Y3756;ПОИСК("Кто автор";Y3756)+13;ДЛСТР(Y3756));"")


Так правильно?

И еще уточнение:
Как изменится формула, если добавить в искомые значения, помимо "Кто автор", еще "Кто авторы", "Об авторах" и "Об авторе"?

Автор - User799
Дата добавления - 08.03.2021 в 15:56
gling Дата: Понедельник, 08.03.2021, 22:01 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Здравствуйте.
Попробуйте монстрика
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("кто автор";A1);99);СИМВОЛ(10);ПОВТОР(" ";99));СИМВОЛ(151);ПОВТОР(" ";99));99;199));СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("об автор";A1);99);СИМВОЛ(10);ПОВТОР(" ";99));СИМВОЛ(151);ПОВТОР(" ";99));99;199)));"")
К сообщению приложен файл: 3808294.xls(63.0 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 08.03.2021, 22:06
 
Ответить
СообщениеЗдравствуйте.
Попробуйте монстрика
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("кто автор";A1);99);СИМВОЛ(10);ПОВТОР(" ";99));СИМВОЛ(151);ПОВТОР(" ";99));99;199));СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("об автор";A1);99);СИМВОЛ(10);ПОВТОР(" ";99));СИМВОЛ(151);ПОВТОР(" ";99));99;199)));"")

Автор - gling
Дата добавления - 08.03.2021 в 22:01
User799 Дата: Понедельник, 08.03.2021, 22:11 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, вечер добрый!
Попробовал - не совсем то, к сожалению. Он много лишнего режет (см. прилагаемый файл).
На всякий случаю уточню задачу: необходимо перенести не только ФИО автора, а весь абзац о нем.
К сообщению приложен файл: 8032270.xlsx(12.1 Kb)


Сообщение отредактировал User799 - Понедельник, 08.03.2021, 22:13
 
Ответить
Сообщениеgling, вечер добрый!
Попробовал - не совсем то, к сожалению. Он много лишнего режет (см. прилагаемый файл).
На всякий случаю уточню задачу: необходимо перенести не только ФИО автора, а весь абзац о нем.

Автор - User799
Дата добавления - 08.03.2021 в 22:11
gling Дата: Понедельник, 08.03.2021, 22:44 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Может тогда так?
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ПСТР(ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1)));ДЛСТР(A1));ПСТР(ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1)));ДЛСТР(A1)));"")
то-же самое но немного другая формула
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1));СИМВОЛ(10);ПОВТОР(" ";99));99;ДЛСТР(A1)));СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1));СИМВОЛ(10);ПОВТОР(" ";99));99;ДЛСТР(A1))));"")


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 08.03.2021, 22:49
 
Ответить
СообщениеМожет тогда так?
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ПСТР(ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1)));ДЛСТР(A1));ПСТР(ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1)));ДЛСТР(A1)));"")
то-же самое но немного другая формула
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1));СИМВОЛ(10);ПОВТОР(" ";99));99;ДЛСТР(A1)));СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1));СИМВОЛ(10);ПОВТОР(" ";99));99;ДЛСТР(A1))));"")

Автор - gling
Дата добавления - 08.03.2021 в 22:44
User799 Дата: Понедельник, 08.03.2021, 22:54 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, все ок. Только формула удаляет абзацы. Если можно легко добиться отмены этого эффекта, будет совсем хорошо. Но, в принципе, уже очень неплохо.
Благодарю за помощь!


Сообщение отредактировал User799 - Понедельник, 08.03.2021, 23:00
 
Ответить
Сообщениеgling, все ок. Только формула удаляет абзацы. Если можно легко добиться отмены этого эффекта, будет совсем хорошо. Но, в принципе, уже очень неплохо.
Благодарю за помощь!

Автор - User799
Дата добавления - 08.03.2021 в 22:54
gling Дата: Понедельник, 08.03.2021, 23:32 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Первая формула не удаляет абзац. Смотрите ячейку D1.
К сообщению приложен файл: 5112223.xlsx(12.6 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 08.03.2021, 23:34
 
Ответить
СообщениеПервая формула не удаляет абзац. Смотрите ячейку D1.

Автор - gling
Дата добавления - 08.03.2021 в 23:32
User799 Дата: Вторник, 09.03.2021, 12:07 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Первая формула вместе с абзацем оставляет пустую строку перед текстом. Пример прилагаю.
К сообщению приложен файл: 7087338.xlsx(10.3 Kb)
 
Ответить
СообщениеПервая формула вместе с абзацем оставляет пустую строку перед текстом. Пример прилагаю.

Автор - User799
Дата добавления - 09.03.2021 в 12:07
Serge_007 Дата: Вторник, 09.03.2021, 12:12 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Первая формула вместе с абзацем оставляет пустую строку перед текстом
Код
=ПОДСТАВИТЬ(ЕСЛИОШИБКА(ЕСЛИОШИБКА(ПСТР(ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1)));ДЛСТР(A1));ПСТР(ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1)));ДЛСТР(A1)));"");СИМВОЛ(10);)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Первая формула вместе с абзацем оставляет пустую строку перед текстом
Код
=ПОДСТАВИТЬ(ЕСЛИОШИБКА(ЕСЛИОШИБКА(ПСТР(ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("кто автор";A1);ДЛСТР(A1)));ДЛСТР(A1));ПСТР(ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1));ПОИСК(СИМВОЛ(10);ПСТР(A1;ПОИСК("об автор";A1);ДЛСТР(A1)));ДЛСТР(A1)));"");СИМВОЛ(10);)

Автор - Serge_007
Дата добавления - 09.03.2021 в 12:12
User799 Дата: Вторник, 09.03.2021, 12:32 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
То что надо hands
У меня бы жизнь ушла, чтобы такие цепи из формул построить)
Спасибо всем за помощь, тему можно закрывать - проблема решена.
 
Ответить
СообщениеТо что надо hands
У меня бы жизнь ушла, чтобы такие цепи из формул построить)
Спасибо всем за помощь, тему можно закрывать - проблема решена.

Автор - User799
Дата добавления - 09.03.2021 в 12:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос части текста из ячейки в ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!