Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Динамический календарь проекта - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамический календарь проекта (Формулы/Formulas)
Динамический календарь проекта
Гаэтана Дата: Среда, 05.05.2021, 00:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый вечер!Помогите,пожалуста:
файл примера во вложении,где
начальным условием задается день старта, на его основе строится календарь с днями недели.И есть этапы проекта с указанием периодов.
Как можно формулой прописать чтобы заполнялось указанное количество дней с учетом перерыва на выходные,и начинался второй этап строкой ниже.
Пример отметила цифрой 1
К сообщению приложен файл: __-1-.xlsx(19.7 Kb)


Gaetana
 
Ответить
СообщениеДобрый вечер!Помогите,пожалуста:
файл примера во вложении,где
начальным условием задается день старта, на его основе строится календарь с днями недели.И есть этапы проекта с указанием периодов.
Как можно формулой прописать чтобы заполнялось указанное количество дней с учетом перерыва на выходные,и начинался второй этап строкой ниже.
Пример отметила цифрой 1

Автор - Гаэтана
Дата добавления - 05.05.2021 в 00:10
Светлый Дата: Среда, 05.05.2021, 08:02 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1639
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый день!
Устроит ли такая формула?
Код
=ЕСЛИ(И(ИЛИ(СУММ($C$5:C5)>=СУММ($B4:$B$5);СТРОКА()=СТРОКА(D$5));СУММ($C5:C5)<$B5;ОСТАТ(D$4;7)>1);1;"")
(кроме СБ, Вскр.,) - надо либо усложнять формулу, либо дополнительный столбец создавать.
*Формула будет проверять в столбце C наличие "Пн.", "Вт.",..."Вс." и исключать эти дни из распределения. То есть, при наличии "(кроме Сб., Вс.)" не будет ставить на субботу и воскресенье.
Код
=ЕСЛИ(И(ИЛИ(СУММ($C$5:C5)>=СУММ($B4:$B$5);СТРОКА()=СТРОКА(D$5));СУММ($C5:C5)<$B5;ЕОШ(НАЙТИ(ПСТР("СбВсПнВтСрЧтПт";ОСТАТ(D$4;7)*2+1;2)&".";$C5)));1;"")
Файл подкорректировал и перезалил.
К сообщению приложен файл: Gaetana-1.xlsx(31.7 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 05.05.2021, 08:33
 
Ответить
СообщениеДобрый день!
Устроит ли такая формула?
Код
=ЕСЛИ(И(ИЛИ(СУММ($C$5:C5)>=СУММ($B4:$B$5);СТРОКА()=СТРОКА(D$5));СУММ($C5:C5)<$B5;ОСТАТ(D$4;7)>1);1;"")
(кроме СБ, Вскр.,) - надо либо усложнять формулу, либо дополнительный столбец создавать.
*Формула будет проверять в столбце C наличие "Пн.", "Вт.",..."Вс." и исключать эти дни из распределения. То есть, при наличии "(кроме Сб., Вс.)" не будет ставить на субботу и воскресенье.
Код
=ЕСЛИ(И(ИЛИ(СУММ($C$5:C5)>=СУММ($B4:$B$5);СТРОКА()=СТРОКА(D$5));СУММ($C5:C5)<$B5;ЕОШ(НАЙТИ(ПСТР("СбВсПнВтСрЧтПт";ОСТАТ(D$4;7)*2+1;2)&".";$C5)));1;"")
Файл подкорректировал и перезалил.

Автор - Светлый
Дата добавления - 05.05.2021 в 08:02
Гаэтана Дата: Среда, 05.05.2021, 09:32 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Классно!Спасибо огромное!!!


Gaetana
 
Ответить
СообщениеКлассно!Спасибо огромное!!!

Автор - Гаэтана
Дата добавления - 05.05.2021 в 09:32
Гаэтана Дата: Среда, 05.05.2021, 10:04 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Светлый, спасибо огромное.А можно изменить формулу,чтобы он прописывал порядковый номер дня этапа.Т.е. какой день 1,2,3,4,5.....?


Gaetana
 
Ответить
СообщениеСветлый, спасибо огромное.А можно изменить формулу,чтобы он прописывал порядковый номер дня этапа.Т.е. какой день 1,2,3,4,5.....?

Автор - Гаэтана
Дата добавления - 05.05.2021 в 10:04
Светлый Дата: Среда, 05.05.2021, 11:47 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1639
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013, 2016
Цитата Гаэтана, 05.05.2021 в 10:04, в сообщении № 4 ()
порядковый номер дня этапа
Чтобы каждый этап (каждая строка) начинался с 1 ?
*Вот так устроит?
Код
=ЕСЛИ(И(ИЛИ(СЧЁТЕСЛИ($C$5:C5;">0")>=СУММ($B4:$B$5);СТРОКА()=СТРОКА(D$5));СЧЁТЕСЛИ($C5:C5;">0")<$B5;ЕОШ(НАЙТИ(ПСТР("СбВсПнВтСрЧтПт";ОСТАТ(D$4;7)*2+1;2)&".";$C5)));СЧЁТЕСЛИ($B5:C5;">0");"")
*Покороче:
Код
=ЕСЛИ(И(СЧЁТЕСЛИ($C$5:C5;">0")>=СУММ($B$4:$B4);СЧЁТЕСЛИ($C5:C5;">0")<$B5;ЕОШ(НАЙТИ(ПСТР("СбВсПнВтСрЧтПт";ОСТАТ(D$4;7)*2+1;2)&".";$C5)));СЧЁТЕСЛИ($B5:C5;">0");"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 05.05.2021, 12:25
 
Ответить
Сообщение
Цитата Гаэтана, 05.05.2021 в 10:04, в сообщении № 4 ()
порядковый номер дня этапа
Чтобы каждый этап (каждая строка) начинался с 1 ?
*Вот так устроит?
Код
=ЕСЛИ(И(ИЛИ(СЧЁТЕСЛИ($C$5:C5;">0")>=СУММ($B4:$B$5);СТРОКА()=СТРОКА(D$5));СЧЁТЕСЛИ($C5:C5;">0")<$B5;ЕОШ(НАЙТИ(ПСТР("СбВсПнВтСрЧтПт";ОСТАТ(D$4;7)*2+1;2)&".";$C5)));СЧЁТЕСЛИ($B5:C5;">0");"")
*Покороче:
Код
=ЕСЛИ(И(СЧЁТЕСЛИ($C$5:C5;">0")>=СУММ($B$4:$B4);СЧЁТЕСЛИ($C5:C5;">0")<$B5;ЕОШ(НАЙТИ(ПСТР("СбВсПнВтСрЧтПт";ОСТАТ(D$4;7)*2+1;2)&".";$C5)));СЧЁТЕСЛИ($B5:C5;">0");"")

Автор - Светлый
Дата добавления - 05.05.2021 в 11:47
Гаэтана Дата: Среда, 05.05.2021, 12:55 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Светлый, да,да)))Спасибо.сама бы никогда не додумалась до этих формул!!!


Gaetana
 
Ответить
СообщениеСветлый, да,да)))Спасибо.сама бы никогда не додумалась до этих формул!!!

Автор - Гаэтана
Дата добавления - 05.05.2021 в 12:55
Гаэтана Дата: Среда, 09.06.2021, 10:25 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Светлый, добрый день!Не поможете прописать обратную логику для условий в желтой заливке?рассчитывается дата старта (в примере 30.08)и желтые этапы должны заканчиваться с условием "за ... дней/недель до старта"
К сообщению приложен файл: 08.06___.xlsx(48.5 Kb)


Gaetana
 
Ответить
СообщениеСветлый, добрый день!Не поможете прописать обратную логику для условий в желтой заливке?рассчитывается дата старта (в примере 30.08)и желтые этапы должны заканчиваться с условием "за ... дней/недель до старта"

Автор - Гаэтана
Дата добавления - 09.06.2021 в 10:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамический календарь проекта (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!