Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставить номера из 2-х таблиц 3-ю с проверкой условия - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставить номера из 2-х таблиц 3-ю с проверкой условия (Формулы/Formulas)
Вставить номера из 2-х таблиц 3-ю с проверкой условия
yaweg87 Дата: Понедельник, 27.09.2021, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.

Есть две таблицы: "Таблица 1" (A2:A11) и "Таблица 2" (A14:A20). Номера в каждой уникальные, но в 1-й и 2-й могут повторяться.
В таблице C2:C20 допустимые значения.

Необходимо все номера из таблиц 1 и 2 (если они есть в списке допустимых значений C2:C20) вставить без дублей в "Таблицу 3" (E2:E20) с ​возможностью сортировки.

Пока получилось

Для ручного копирования:
в столбце "B" "Таблицы 2" помечаются новые значения, отсутствующие в "Таблице 1"
в столбце "F" "Таблицы 3" помечаются номера, которых нет в "списке допустимых" и надо удалить

или
В "I2:I20" массив всех номеров из 1-2 и в "К" проверка допустимости.

Помогите, пожалуйста, автоматизировать процесс. Спасибо.
К сообщению приложен файл: 4624592.xlsx(12.0 Kb)
 
Ответить
СообщениеДобрый день.

Есть две таблицы: "Таблица 1" (A2:A11) и "Таблица 2" (A14:A20). Номера в каждой уникальные, но в 1-й и 2-й могут повторяться.
В таблице C2:C20 допустимые значения.

Необходимо все номера из таблиц 1 и 2 (если они есть в списке допустимых значений C2:C20) вставить без дублей в "Таблицу 3" (E2:E20) с ​возможностью сортировки.

Пока получилось

Для ручного копирования:
в столбце "B" "Таблицы 2" помечаются новые значения, отсутствующие в "Таблице 1"
в столбце "F" "Таблицы 3" помечаются номера, которых нет в "списке допустимых" и надо удалить

или
В "I2:I20" массив всех номеров из 1-2 и в "К" проверка допустимости.

Помогите, пожалуйста, автоматизировать процесс. Спасибо.

Автор - yaweg87
Дата добавления - 27.09.2021 в 11:22
Светлый Дата: Понедельник, 27.09.2021, 12:42 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый день!
Без сортировки формула массива:
Код
=ЕСЛИОШИБКА(--ИНДЕКС(A:A;МИН(ЕСЛИ(СЧЁТЕСЛИ(C$2:C$20;A$2:A$20)*(СЧЁТЕСЛИ(E$1:E1;A$2:A$20)=0);СТРОКА(A$2:A$20))));"")
С сортировкой:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(C$2:C$20;A$2:A$20)*(СЧЁТЕСЛИ(G$1:G1;A$2:A$20)=0);A$2:A$20);1);"")
*Можно ещё так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;АГРЕГАТ(15;6;ПОИСКПОЗ(C$2:C$20;A:A;);СТРОКА(L1)));"")
К сообщению приложен файл: 4624592-1.xlsx(12.6 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 27.09.2021, 13:19
 
Ответить
СообщениеДобрый день!
Без сортировки формула массива:
Код
=ЕСЛИОШИБКА(--ИНДЕКС(A:A;МИН(ЕСЛИ(СЧЁТЕСЛИ(C$2:C$20;A$2:A$20)*(СЧЁТЕСЛИ(E$1:E1;A$2:A$20)=0);СТРОКА(A$2:A$20))));"")
С сортировкой:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(C$2:C$20;A$2:A$20)*(СЧЁТЕСЛИ(G$1:G1;A$2:A$20)=0);A$2:A$20);1);"")
*Можно ещё так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;АГРЕГАТ(15;6;ПОИСКПОЗ(C$2:C$20;A:A;);СТРОКА(L1)));"")

Автор - Светлый
Дата добавления - 27.09.2021 в 12:42
alexa1965 Дата: Понедельник, 27.09.2021, 12:59 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 248
Репутация: 19 ±
Замечаний: 0% ±

2003> 2010> 2016
Добрый день! Для столбца В таблицы 2
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A14;A$2:A$11;1)=A14;"";"Новый");"")
как вариант попроще


Главное не быть балабастиком
 
Ответить
СообщениеДобрый день! Для столбца В таблицы 2
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A14;A$2:A$11;1)=A14;"";"Новый");"")
как вариант попроще

Автор - alexa1965
Дата добавления - 27.09.2021 в 12:59
yaweg87 Дата: Понедельник, 27.09.2021, 14:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Цитата Светлый, 27.09.2021 в 12:42, в сообщении № 2 ()
С сортировкой:

Я наверно неправильно выразился. Но под сортировкой подразумевалось не выстроенные подряд номера, а в принципе возможность сортировать.
Используя табличку G2:G20 получилось сделать то, что я хотел. Спасибо. hands

M2:N20 сортирует и сверху вниз и снизу вверх. Если нельзя никак улучшить, то оставлю так.

как вариант попроще


И тебе спасибо. Учту. thumb
К сообщению приложен файл: 4624592-2.xlsx(13.7 Kb)
 
Ответить
Сообщение
Цитата Светлый, 27.09.2021 в 12:42, в сообщении № 2 ()
С сортировкой:

Я наверно неправильно выразился. Но под сортировкой подразумевалось не выстроенные подряд номера, а в принципе возможность сортировать.
Используя табличку G2:G20 получилось сделать то, что я хотел. Спасибо. hands

M2:N20 сортирует и сверху вниз и снизу вверх. Если нельзя никак улучшить, то оставлю так.

как вариант попроще


И тебе спасибо. Учту. thumb

Автор - yaweg87
Дата добавления - 27.09.2021 в 14:41
yaweg87 Дата: Понедельник, 27.09.2021, 15:13 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

И как изменить формулу, чтобы она брала табличку еще и с "Лист 1" A2:А20 ? :shy:
К сообщению приложен файл: 4624592-3.xlsx(13.4 Kb)
 
Ответить
СообщениеИ как изменить формулу, чтобы она брала табличку еще и с "Лист 1" A2:А20 ? :shy:

Автор - yaweg87
Дата добавления - 27.09.2021 в 15:13
Светлый Дата: Понедельник, 27.09.2021, 20:47 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
Массивная:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(A:A;C$2:C$20)+СЧЁТЕСЛИ(Лист1!A:A;C$2:C$20);C$2:C$20);СТРОКА(L1));"")
К сообщению приложен файл: 4624592-4.xlsx(13.5 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМассивная:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(A:A;C$2:C$20)+СЧЁТЕСЛИ(Лист1!A:A;C$2:C$20);C$2:C$20);СТРОКА(L1));"")

Автор - Светлый
Дата добавления - 27.09.2021 в 20:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставить номера из 2-х таблиц 3-ю с проверкой условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!