Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение услуги в цифрах каждый первый понедельник месяца - Мир MS Excel

Старая форма входа
  • Страница 1 из 3
  • 1
  • 2
  • 3
  • »
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение услуги в цифрах каждый первый понедельник месяца (Формулы/Formulas)
Отображение услуги в цифрах каждый первый понедельник месяца
Смольный Дата: Среда, 29.09.2021, 10:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Добрый день. В прикрепленном файле, есть услуга оплата ЖКУ, она выполняется только раз в месяц, как сделать чтоб из месяца в месяц это услуга в цифрах отображалась в ячейке каждый первый понедельник.
К сообщению приложен файл: 7071621.xlsx(11.9 Kb)


Сообщение отредактировал Смольный - Среда, 29.09.2021, 12:12
 
Ответить
СообщениеДобрый день. В прикрепленном файле, есть услуга оплата ЖКУ, она выполняется только раз в месяц, как сделать чтоб из месяца в месяц это услуга в цифрах отображалась в ячейке каждый первый понедельник.

Автор - Смольный
Дата добавления - 29.09.2021 в 10:22
Светлый Дата: Среда, 29.09.2021, 10:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1739
Репутация: 473 ±
Замечаний: 0% ±

Excel 2013, 2016
Поменяйте название темы.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 29.09.2021, 10:42
 
Ответить
СообщениеПоменяйте название темы.

Автор - Светлый
Дата добавления - 29.09.2021 в 10:40
Смольный Дата: Среда, 29.09.2021, 12:12 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Светлый, так нормально?
 
Ответить
СообщениеСветлый, так нормально?

Автор - Смольный
Дата добавления - 29.09.2021 в 12:12
Nic70y Дата: Среда, 29.09.2021, 12:48 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Цитата Смольный, 29.09.2021 в 10:22, в сообщении № 1 ()
услуга в цифрах
в каких цифрах?
вдруг правильно
Код
=ЕСЛИ(ПОИСКПОЗ("Пн";$E$2:$L$2;)=СТОЛБЕЦ(A1);$C$6;"")
К сообщению приложен файл: 27.xlsx(11.9 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Цитата Смольный, 29.09.2021 в 10:22, в сообщении № 1 ()
услуга в цифрах
в каких цифрах?
вдруг правильно
Код
=ЕСЛИ(ПОИСКПОЗ("Пн";$E$2:$L$2;)=СТОЛБЕЦ(A1);$C$6;"")

Автор - Nic70y
Дата добавления - 29.09.2021 в 12:48
Смольный Дата: Среда, 29.09.2021, 13:22 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, цифры для каждой услуги разные, подскажите как цифры в ячейке менять, не могу понять, так же редко но есть услуги которые выполняются 2 раза в месяц, к примеру второй и четвертый вторник месяца, можете по подробней объяснить как это делается.
 
Ответить
СообщениеNic70y, цифры для каждой услуги разные, подскажите как цифры в ячейке менять, не могу понять, так же редко но есть услуги которые выполняются 2 раза в месяц, к примеру второй и четвертый вторник месяца, можете по подробней объяснить как это делается.

Автор - Смольный
Дата добавления - 29.09.2021 в 13:22
Nic70y Дата: Среда, 29.09.2021, 13:26 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Цитата Смольный, 29.09.2021 в 13:22, в сообщении № 5 ()
подскажите как цифры в ячейке менять
в какой ячейке?


ЮMoney 41001841029809
 
Ответить
Сообщение
Цитата Смольный, 29.09.2021 в 13:22, в сообщении № 5 ()
подскажите как цифры в ячейке менять
в какой ячейке?

Автор - Nic70y
Дата добавления - 29.09.2021 в 13:26
Смольный Дата: Среда, 29.09.2021, 13:30 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, с цифрами разобрался, как обыграть чтоб была возможность 2 и 4 вторник(не важен день недели) месяца
 
Ответить
СообщениеNic70y, с цифрами разобрался, как обыграть чтоб была возможность 2 и 4 вторник(не важен день недели) месяца

Автор - Смольный
Дата добавления - 29.09.2021 в 13:30
Nic70y Дата: Среда, 29.09.2021, 13:54 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(СЧЁТЕСЛИ($E$2:E$2;"Вт")*(E$2="Вт");"2/4"));"здесь те цифры";"")


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(СЧЁТЕСЛИ($E$2:E$2;"Вт")*(E$2="Вт");"2/4"));"здесь те цифры";"")

Автор - Nic70y
Дата добавления - 29.09.2021 в 13:54
Смольный Дата: Среда, 29.09.2021, 14:57 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, работает, супер. И последнее, извиняюсь за назойливость, какая формула для услуг предоставляемые два/три раза в неделю?
 
Ответить
СообщениеNic70y, работает, супер. И последнее, извиняюсь за назойливость, какая формула для услуг предоставляемые два/три раза в неделю?

Автор - Смольный
Дата добавления - 29.09.2021 в 14:57
Nic70y Дата: Среда, 29.09.2021, 16:12 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Цитата Смольный, 29.09.2021 в 14:57, в сообщении № 9 ()
два/три раза в неделю
не конкретное определение - не могу ответить


ЮMoney 41001841029809
 
Ответить
Сообщение
Цитата Смольный, 29.09.2021 в 14:57, в сообщении № 9 ()
два/три раза в неделю
не конкретное определение - не могу ответить

Автор - Nic70y
Дата добавления - 29.09.2021 в 16:12
Смольный Дата: Среда, 29.09.2021, 17:32 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, есть услуги которые проводятся по понедельникам, средам и пятницам, каждую неделю месяца. а есть услуги которые проводятся по вторникам и четвергам каждого месяца
 
Ответить
СообщениеNic70y, есть услуги которые проводятся по понедельникам, средам и пятницам, каждую неделю месяца. а есть услуги которые проводятся по вторникам и четвергам каждого месяца

Автор - Смольный
Дата добавления - 29.09.2021 в 17:32
Светлый Дата: Среда, 29.09.2021, 22:56 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 1739
Репутация: 473 ±
Замечаний: 0% ±

Excel 2013, 2016
У меня была такая формула:
Код
=Ч(ПОИСКПОЗ("Пн";$E$2:$AI$2;)=E$3)

Можно для каждой услуги задать в отдельных столбцах день недели и его номер, когда надо эту услугу включать.
Например,
1 Пн - это первый понедельник месяца
0 Вт - это все вторники месяца
9 Пт - это последняя пятница месяца
Тогда для каждой услуги уже можно будет вычислить день её применения.
*Для одного дня недели для одной услуги.
**Все дни недели месяца из заданных перечисленных. Только для "0". Файл перезалил.
***Перенёс условия в столбец A. Файл перезалил.
К сообщению приложен файл: 7071621-1.xlsx(15.5 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 29.09.2021, 23:52
 
Ответить
СообщениеУ меня была такая формула:
Код
=Ч(ПОИСКПОЗ("Пн";$E$2:$AI$2;)=E$3)

Можно для каждой услуги задать в отдельных столбцах день недели и его номер, когда надо эту услугу включать.
Например,
1 Пн - это первый понедельник месяца
0 Вт - это все вторники месяца
9 Пт - это последняя пятница месяца
Тогда для каждой услуги уже можно будет вычислить день её применения.
*Для одного дня недели для одной услуги.
**Все дни недели месяца из заданных перечисленных. Только для "0". Файл перезалил.
***Перенёс условия в столбец A. Файл перезалил.

Автор - Светлый
Дата добавления - 29.09.2021 в 22:56
Смольный Дата: Четверг, 30.09.2021, 08:43 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Светлый, Добрый день, посмотрел я Ваш пример, это еще удобней чем у меня, так как бывает что дни посещений нужно менять и не надо лезть в формулу, одно но, можно ли чтоб формула вместо цифр 1 брала значения норма часов в столбце С
 
Ответить
СообщениеСветлый, Добрый день, посмотрел я Ваш пример, это еще удобней чем у меня, так как бывает что дни посещений нужно менять и не надо лезть в формулу, одно но, можно ли чтоб формула вместо цифр 1 брала значения норма часов в столбце С

Автор - Смольный
Дата добавления - 30.09.2021 в 08:43
Nic70y Дата: Четверг, 30.09.2021, 10:16 | Сообщение № 14
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
по файлу от Светлый, немного по другому
К сообщению приложен файл: 8214068.xlsx(15.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениепо файлу от Светлый, немного по другому

Автор - Nic70y
Дата добавления - 30.09.2021 в 10:16
Светлый Дата: Четверг, 30.09.2021, 12:40 | Сообщение № 15
Группа: Друзья
Ранг: Старожил
Сообщений: 1739
Репутация: 473 ±
Замечаний: 0% ±

Excel 2013, 2016
Упростил формулу, как у Nic70y, но сделал выбор до трёх номеров недель, причём дней недели в этих неделях может быть задано несколько.
Например: 13 Пн, Ср - это первый и третий понедельники и первая и третья среды.
Код
=ЕСЛИ(ЕСЛИ(ЕЧИСЛО(-ЛЕВБ($A5;ЗНАК(ПОИСК(E$2;$A5))));ИЛИ(ПСТР($A5;{1;2;3};1)=СЧЁТЕСЛИ($E$2:E$2;E$2)&"");ЕЧИСЛО(ПОИСК(E$2;$A5)));$C5;"")
Последний день недели в месяце формула не считает.
*Ещё сократил формулу:
Код
=ЕСЛИ(ЕСЛИ(ЕЧИСЛО(-ЛЕВБ($A5;ПОИСК(E$2;$A5)>0));ИЛИ(ПСТР($A5;{1;2;3};1)=СЧЁТЕСЛИ($E$2:E$2;E$2)&"");ЕЧИСЛО(ПОИСК(E$2;$A5)));$C5;"")
К сообщению приложен файл: 7071621-2.xlsx(13.9 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 30.09.2021, 12:45
 
Ответить
СообщениеУпростил формулу, как у Nic70y, но сделал выбор до трёх номеров недель, причём дней недели в этих неделях может быть задано несколько.
Например: 13 Пн, Ср - это первый и третий понедельники и первая и третья среды.
Код
=ЕСЛИ(ЕСЛИ(ЕЧИСЛО(-ЛЕВБ($A5;ЗНАК(ПОИСК(E$2;$A5))));ИЛИ(ПСТР($A5;{1;2;3};1)=СЧЁТЕСЛИ($E$2:E$2;E$2)&"");ЕЧИСЛО(ПОИСК(E$2;$A5)));$C5;"")
Последний день недели в месяце формула не считает.
*Ещё сократил формулу:
Код
=ЕСЛИ(ЕСЛИ(ЕЧИСЛО(-ЛЕВБ($A5;ПОИСК(E$2;$A5)>0));ИЛИ(ПСТР($A5;{1;2;3};1)=СЧЁТЕСЛИ($E$2:E$2;E$2)&"");ЕЧИСЛО(ПОИСК(E$2;$A5)));$C5;"")

Автор - Светлый
Дата добавления - 30.09.2021 в 12:40
Смольный Дата: Четверг, 30.09.2021, 13:09 | Сообщение № 16
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Огромное спасибо Вам, Вы даже не представляете какой ручной труд специалистов автоматизировали. Есть еще, последний штрих в этом графики, но я понял по правилам форума нужно оформлять новую тему.
 
Ответить
СообщениеОгромное спасибо Вам, Вы даже не представляете какой ручной труд специалистов автоматизировали. Есть еще, последний штрих в этом графики, но я понял по правилам форума нужно оформлять новую тему.

Автор - Смольный
Дата добавления - 30.09.2021 в 13:09
Смольный Дата: Четверг, 14.10.2021, 08:12 | Сообщение № 17
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

И снова здравствуйте, сегодня выяснилось что бывают услуги, которые оказываются несколько раз в день и так же эти услуги не каждый день недели. у кого то 3 раза в день и пять дней в неделю, у кого то два раза в день и три раза в неделю. Можно ли такое внести в график, прикрепленный к сообщению? P.S. так же количество дневных услуг должны учитываться в столбце AK
К сообщению приложен файл: 5486179.xlsm(32.9 Kb)


Сообщение отредактировал Смольный - Четверг, 14.10.2021, 08:13
 
Ответить
СообщениеИ снова здравствуйте, сегодня выяснилось что бывают услуги, которые оказываются несколько раз в день и так же эти услуги не каждый день недели. у кого то 3 раза в день и пять дней в неделю, у кого то два раза в день и три раза в неделю. Можно ли такое внести в график, прикрепленный к сообщению? P.S. так же количество дневных услуг должны учитываться в столбце AK

Автор - Смольный
Дата добавления - 14.10.2021 в 08:12
Nic70y Дата: Четверг, 14.10.2021, 10:34 | Сообщение № 18
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
вариант с доп.столбцом AL, его можно просто скрыть.
так хотели?
К сообщению приложен файл: 16.xlsm(30.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант с доп.столбцом AL, его можно просто скрыть.
так хотели?

Автор - Nic70y
Дата добавления - 14.10.2021 в 10:34
Смольный Дата: Четверг, 14.10.2021, 11:38 | Сообщение № 19
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, можно и так в принципе, лучше со скрытием столбца
 
Ответить
СообщениеNic70y, можно и так в принципе, лучше со скрытием столбца

Автор - Смольный
Дата добавления - 14.10.2021 в 11:38
Смольный Дата: Четверг, 14.10.2021, 13:10 | Сообщение № 20
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, можно ли сделать это в другом месте. как показано на картинке.
К сообщению приложен файл: 3701904.png(15.3 Kb)
 
Ответить
СообщениеNic70y, можно ли сделать это в другом месте. как показано на картинке.

Автор - Смольный
Дата добавления - 14.10.2021 в 13:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение услуги в цифрах каждый первый понедельник месяца (Формулы/Formulas)
  • Страница 1 из 3
  • 1
  • 2
  • 3
  • »
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!