Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление числа после запятой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление числа после запятой (Формулы/Formulas)
Округление числа после запятой
skk7480087 Дата: Четверг, 17.03.2022, 12:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Всем здравствуйте!
Товарищи эксперты по Exel нужна ваша помощь.
Имеется таблица с формулами типа =А1*В1, результат получается с округляется до сотых.
Нужно сделать округление если ответ 17,88 то округлении происходит до 17,90 или если ответ 10,01 то округление происходит 10,00

Вижу условие так - если после запятой во втором разряде число до от 1 до 4 то округлении к нулю в меньшую сторону, а если от 5 до 9 то округлении в большую сторону.

Например:
10,01 = 10,00
10,02 = 10,00
10,03 = 10,00
10,04 = 10,00

10,05 = 10,10
10,06 = 10,10
10,07 = 10,10
10,08 = 10,10
10,09 = 10,10

Заранее спасибо всем откликнувшимся!
 
Ответить
СообщениеВсем здравствуйте!
Товарищи эксперты по Exel нужна ваша помощь.
Имеется таблица с формулами типа =А1*В1, результат получается с округляется до сотых.
Нужно сделать округление если ответ 17,88 то округлении происходит до 17,90 или если ответ 10,01 то округление происходит 10,00

Вижу условие так - если после запятой во втором разряде число до от 1 до 4 то округлении к нулю в меньшую сторону, а если от 5 до 9 то округлении в большую сторону.

Например:
10,01 = 10,00
10,02 = 10,00
10,03 = 10,00
10,04 = 10,00

10,05 = 10,10
10,06 = 10,10
10,07 = 10,10
10,08 = 10,10
10,09 = 10,10

Заранее спасибо всем откликнувшимся!

Автор - skk7480087
Дата добавления - 17.03.2022 в 12:24
Serge_007 Дата: Четверг, 17.03.2022, 12:29 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15153
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Здравствуйте

если после запятой во втором разряде число до от 1 до 4 то округлении к нулю в меньшую сторону, а если от 5 до 9 то округлении в большую сторону
Код
=ОКРУГЛ(A1;1)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

если после запятой во втором разряде число до от 1 до 4 то округлении к нулю в меньшую сторону, а если от 5 до 9 то округлении в большую сторону
Код
=ОКРУГЛ(A1;1)

Автор - Serge_007
Дата добавления - 17.03.2022 в 12:29
Nic70y Дата: Четверг, 17.03.2022, 12:30 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7520
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
Код
=ОКРУГЛ(A1*B1;1)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ОКРУГЛ(A1*B1;1)

Автор - Nic70y
Дата добавления - 17.03.2022 в 12:30
skk7480087 Дата: Четверг, 17.03.2022, 13:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Nic70y,
Спасибо большое!, все получается.

А можно сделать, если ответ например получается 10,05 то он 5 не округлял а оставлял как есть

Например:
10,01 = 10,00
10,02 = 10,00
10,03 = 10,00
10,04 = 10,00

10,05 = 10,05
10,06 = 10,10
10,07 = 10,10
10,08 = 10,10
10,09 = 10,10


Сообщение отредактировал skk7480087 - Четверг, 17.03.2022, 13:30
 
Ответить
СообщениеNic70y,
Спасибо большое!, все получается.

А можно сделать, если ответ например получается 10,05 то он 5 не округлял а оставлял как есть

Например:
10,01 = 10,00
10,02 = 10,00
10,03 = 10,00
10,04 = 10,00

10,05 = 10,05
10,06 = 10,10
10,07 = 10,10
10,08 = 10,10
10,09 = 10,10

Автор - skk7480087
Дата добавления - 17.03.2022 в 13:12
Serge_007 Дата: Четверг, 17.03.2022, 13:43 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15153
Репутация: 2503 ±
Замечаний: ±

Excel 2016
если ответ например получается 10,05 то он 5 не округлял а оставлял как есть
Код
=ЕСЛИ(--ПРАВБ(A1)=5;A1;ОКРУГЛ(A1;1))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
если ответ например получается 10,05 то он 5 не округлял а оставлял как есть
Код
=ЕСЛИ(--ПРАВБ(A1)=5;A1;ОКРУГЛ(A1;1))

Автор - Serge_007
Дата добавления - 17.03.2022 в 13:43
Nic70y Дата: Четверг, 17.03.2022, 13:59 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7520
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
Код
=ОКРУГЛ(A1*B1;1+(ОКРУГЛ(ОСТАТ(A1*B1;1);2)-0,05=0))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ОКРУГЛ(A1*B1;1+(ОКРУГЛ(ОСТАТ(A1*B1;1);2)-0,05=0))

Автор - Nic70y
Дата добавления - 17.03.2022 в 13:59
skk7480087 Дата: Четверг, 17.03.2022, 14:35 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Nic70y,

К сожалению округляет только до 0, а 0,05 сотых не оставляет
 
Ответить
СообщениеNic70y,

К сожалению округляет только до 0, а 0,05 сотых не оставляет

Автор - skk7480087
Дата добавления - 17.03.2022 в 14:35
Serge_007 Дата: Четверг, 17.03.2022, 14:40 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 15153
Репутация: 2503 ±
Замечаний: ±

Excel 2016
skk7480087, и моя формула, и формула Николая, возвращают одинаковый и корректный результат (см. вложение)
К сообщению приложен файл: 20220317_skk748.xls(61.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеskk7480087, и моя формула, и формула Николая, возвращают одинаковый и корректный результат (см. вложение)

Автор - Serge_007
Дата добавления - 17.03.2022 в 14:40
skk7480087 Дата: Четверг, 17.03.2022, 15:13 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Serge_007,
Я ввожу формулу
Код
=ОКРУГЛ(2,5*4,3;1+(ОКРУГЛ(ОСТАТ(2,5*4,3;1);2)-0,05=0))
- формула уже со значениями
Ответ выдает 10,8, а должен быть 10,75
Получается он округляет на пяти сотых, а нужно что бы ответы только с пятью сотыми оставлял, а если больше или меньше пяти сотых тогда округление в большую либо меньшую сторону.
В файле который Вы прикрепили так и происходит как я описал


Сообщение отредактировал Serge_007 - Четверг, 17.03.2022, 15:21
 
Ответить
СообщениеSerge_007,
Я ввожу формулу
Код
=ОКРУГЛ(2,5*4,3;1+(ОКРУГЛ(ОСТАТ(2,5*4,3;1);2)-0,05=0))
- формула уже со значениями
Ответ выдает 10,8, а должен быть 10,75
Получается он округляет на пяти сотых, а нужно что бы ответы только с пятью сотыми оставлял, а если больше или меньше пяти сотых тогда округление в большую либо меньшую сторону.
В файле который Вы прикрепили так и происходит как я описал

Автор - skk7480087
Дата добавления - 17.03.2022 в 15:13
Serge_007 Дата: Четверг, 17.03.2022, 15:19 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 15153
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Ответ выдает 10,8, а должен быть 10,75
Моя формула возвращает 10,75 (см. вложение)
Код
=ЕСЛИ(--ПРАВБ(A1)=5;A1;ОКРУГЛ(A1;1))
К сообщению приложен файл: 1133593.xls(62.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Ответ выдает 10,8, а должен быть 10,75
Моя формула возвращает 10,75 (см. вложение)
Код
=ЕСЛИ(--ПРАВБ(A1)=5;A1;ОКРУГЛ(A1;1))

Автор - Serge_007
Дата добавления - 17.03.2022 в 15:19
Nic70y Дата: Четверг, 17.03.2022, 15:27 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 7520
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
Код
=ОКРУГЛ(2,5*4,3;1+(ОКРУГЛ(ОСТАТ(2,5*4,3;0,1);2)-0,05=0))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ОКРУГЛ(2,5*4,3;1+(ОКРУГЛ(ОСТАТ(2,5*4,3;0,1);2)-0,05=0))

Автор - Nic70y
Дата добавления - 17.03.2022 в 15:27
Фомулист Дата: Четверг, 17.03.2022, 16:49 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 355
Репутация: 9 ±
Замечаний: 60% ±

Excel 2003
Моя формула

Сергей, в формуле не должно быть A1
формула уже со значениями


Терпение и труд всё перетрут!
 
Ответить
Сообщение
Моя формула

Сергей, в формуле не должно быть A1
формула уже со значениями

Автор - Фомулист
Дата добавления - 17.03.2022 в 16:49
Serge_007 Дата: Четверг, 17.03.2022, 17:10 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 15153
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Цитата Фомулист, 17.03.2022 в 16:49, в сообщении № 12 ()
в формуле не должно быть A1
Да что Вы говорите! Какой ужос! :D
Вы ввели санкции на использование ячейки А1? deal
Теперь 2,5*4,3 больше нельзя вводить в ячейку?
2,5*4,3 непосредственно в формуле и 2,5*4,3 в ячейке будут возвращать разные результаты? Пичалька... :(


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата Фомулист, 17.03.2022 в 16:49, в сообщении № 12 ()
в формуле не должно быть A1
Да что Вы говорите! Какой ужос! :D
Вы ввели санкции на использование ячейки А1? deal
Теперь 2,5*4,3 больше нельзя вводить в ячейку?
2,5*4,3 непосредственно в формуле и 2,5*4,3 в ячейке будут возвращать разные результаты? Пичалька... :(

Автор - Serge_007
Дата добавления - 17.03.2022 в 17:10
Фомулист Дата: Четверг, 17.03.2022, 17:20 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 355
Репутация: 9 ±
Замечаний: 60% ±

Excel 2003
Serge_007, Я просто думал, что юзеру принципиально, чтобы в формуле были именно числа без всяких ячеек :D


Терпение и труд всё перетрут!
 
Ответить
СообщениеSerge_007, Я просто думал, что юзеру принципиально, чтобы в формуле были именно числа без всяких ячеек :D

Автор - Фомулист
Дата добавления - 17.03.2022 в 17:20
skk7480087 Дата: Четверг, 17.03.2022, 17:22 | Сообщение № 15
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Товарищи Всем ОГРОМНОЕ СПАСИБО, все получилось!!!
 
Ответить
СообщениеТоварищи Всем ОГРОМНОЕ СПАСИБО, все получилось!!!

Автор - skk7480087
Дата добавления - 17.03.2022 в 17:22
Serge_007 Дата: Четверг, 17.03.2022, 17:37 | Сообщение № 16
Группа: Админы
Ранг: Местный житель
Сообщений: 15153
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Цитата Фомулист, 17.03.2022 в 17:20, в сообщении № 14 ()
юзеру принципиально, чтобы в формуле были именно числа без всяких ячеек
Ну так пусть, в таком случае, юзер заменит в формуле ссылку на ячейку на нужные ему числа
Помощь на форуме заключается в написании рабочей формулы, а не в чтении мыслей ТС на предмет "рюшечек"


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата Фомулист, 17.03.2022 в 17:20, в сообщении № 14 ()
юзеру принципиально, чтобы в формуле были именно числа без всяких ячеек
Ну так пусть, в таком случае, юзер заменит в формуле ссылку на ячейку на нужные ему числа
Помощь на форуме заключается в написании рабочей формулы, а не в чтении мыслей ТС на предмет "рюшечек"

Автор - Serge_007
Дата добавления - 17.03.2022 в 17:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление числа после запятой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!