Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск всех значений через ВПР и заполнение графика работы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск всех значений через ВПР и заполнение графика работы (Формулы/Formulas)
Поиск всех значений через ВПР и заполнение графика работы
angelofdead Дата: Понедельник, 22.08.2022, 16:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. На производстве поставили задачу, оценить занятость производственных мощностей. Для Этого по каждому станку нужно по выполненной работе нужно заполнить график работы. Для первых значений у меня получилось это сделать, а для последующих решений пока не нашел, кол-во работ каждого станка в сутки может меняться. Кол-во станков, которые работали за прошедшие сутки тоже может меняться. В конечном итоге хотелось бы видеть график с работами по каждому станку, за сутки. Прошу помочь решить данную задачу.
К сообщению приложен файл: _XLSX.xlsx(16.4 Kb)
 
Ответить
СообщениеДобрый день. На производстве поставили задачу, оценить занятость производственных мощностей. Для Этого по каждому станку нужно по выполненной работе нужно заполнить график работы. Для первых значений у меня получилось это сделать, а для последующих решений пока не нашел, кол-во работ каждого станка в сутки может меняться. Кол-во станков, которые работали за прошедшие сутки тоже может меняться. В конечном итоге хотелось бы видеть график с работами по каждому станку, за сутки. Прошу помочь решить данную задачу.

Автор - angelofdead
Дата добавления - 22.08.2022 в 16:12
Nic70y Дата: Понедельник, 22.08.2022, 16:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(СЧЁТЕСЛИМН('исходные данне'!$A$2:$A$5;B$1;'исходные данне'!$B$2:$B$5;"<="&$A2;'исходные данне'!$C$2:$C$5;">="&$A2);"+";"")
К сообщению приложен файл: 28.xlsx(16.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИМН('исходные данне'!$A$2:$A$5;B$1;'исходные данне'!$B$2:$B$5;"<="&$A2;'исходные данне'!$C$2:$C$5;">="&$A2);"+";"")

Автор - Nic70y
Дата добавления - 22.08.2022 в 16:27
angelofdead Дата: Понедельник, 22.08.2022, 16:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо, работает. Сам не вспомнил про эту функции. А еще может быть подскажите, чтобы можно было вывести не просто символ "+" в общий график, а информацию о работе, выполненной на данном станке?
К сообщению приложен файл: 0289976.xlsx(15.7 Kb)


Сообщение отредактировал angelofdead - Понедельник, 22.08.2022, 16:51
 
Ответить
СообщениеNic70y, спасибо, работает. Сам не вспомнил про эту функции. А еще может быть подскажите, чтобы можно было вывести не просто символ "+" в общий график, а информацию о работе, выполненной на данном станке?

Автор - angelofdead
Дата добавления - 22.08.2022 в 16:41
Nic70y Дата: Вторник, 23.08.2022, 07:39 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
здесь уже формула по массивнее.
вариант - формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('исходные данне'!$D$2:$D$5;МАКС(('исходные данне'!$A$2:$A$5=B$1)*('исходные данне'!$B$2:$B$5<=$A2)*('исходные данне'!$C$2:$C$5>=$A2)*СТРОКА('исходные данне'!$C$2:$C$5)-1));"")
К сообщению приложен файл: 29.xlsx(20.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениездесь уже формула по массивнее.
вариант - формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('исходные данне'!$D$2:$D$5;МАКС(('исходные данне'!$A$2:$A$5=B$1)*('исходные данне'!$B$2:$B$5<=$A2)*('исходные данне'!$C$2:$C$5>=$A2)*СТРОКА('исходные данне'!$C$2:$C$5)-1));"")

Автор - Nic70y
Дата добавления - 23.08.2022 в 07:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск всех значений через ВПР и заполнение графика работы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!