Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Наибольшое значение в определенном интервале - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Наибольшое значение в определенном интервале (Формулы/Formulas)
Наибольшое значение в определенном интервале
ПАМ Дата: Среда, 14.12.2022, 18:53 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 241
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010, Excel 2016
Здравствуйте, уважаемые знатоки и любители Экселя!

Одна из моих раннее заданных тем http://www.excelworld.ru/forum/2-47500-2 очень будет похожа на эту. Похоже я не до конца в ней разобрался. Поэтому прошу помочь пожалуйста.

Проблема в том, что мне нужно, исходя из заданных часов (ячейки K2-V2) найти максимумы факта (столбец E), согласно заданных часов (ячейки K2-V2) и, главное, столбца F (обязательно в рабочий день).
Максимумы можно записать в ячейках (K3-V3).

Заранее спасибо всем, кто откликнется.

[offtop][p.s.] Уважаемая Администрация Форума, прекрасно знаю, что по правилам нужно оформлять гиперссылку, но как? пока также не понял, буду рад научиться. Прошу меня извинить.
К сообщению приложен файл: __.xlsx(98.4 Kb)


Сообщение отредактировал ПАМ - Среда, 14.12.2022, 18:54
 
Ответить
СообщениеЗдравствуйте, уважаемые знатоки и любители Экселя!

Одна из моих раннее заданных тем http://www.excelworld.ru/forum/2-47500-2 очень будет похожа на эту. Похоже я не до конца в ней разобрался. Поэтому прошу помочь пожалуйста.

Проблема в том, что мне нужно, исходя из заданных часов (ячейки K2-V2) найти максимумы факта (столбец E), согласно заданных часов (ячейки K2-V2) и, главное, столбца F (обязательно в рабочий день).
Максимумы можно записать в ячейках (K3-V3).

Заранее спасибо всем, кто откликнется.

[offtop][p.s.] Уважаемая Администрация Форума, прекрасно знаю, что по правилам нужно оформлять гиперссылку, но как? пока также не понял, буду рад научиться. Прошу меня извинить.

Автор - ПАМ
Дата добавления - 14.12.2022 в 18:53
gling Дата: Среда, 14.12.2022, 19:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
Так должно быть?
Код
=СУММПРОИЗВ(МАКС(($D$3:$D$746=K2)*($C$3:$C$746=1)*$E$3:$E$746))
К сообщению приложен файл: -4-.xlsx(101.4 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Так должно быть?
Код
=СУММПРОИЗВ(МАКС(($D$3:$D$746=K2)*($C$3:$C$746=1)*$E$3:$E$746))

Автор - gling
Дата добавления - 14.12.2022 в 19:12
ПАМ Дата: Среда, 14.12.2022, 19:24 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 241
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010, Excel 2016
gling, Здравствуйте. Пока не совсем разобрался в Вашей формуле. Но возможно не правильно так как я проверил фильтрами и 8 час максимум 870, а в вашем примере 793
К сообщению приложен файл: -4-1.xlsx(99.0 Kb)
 
Ответить
Сообщениеgling, Здравствуйте. Пока не совсем разобрался в Вашей формуле. Но возможно не правильно так как я проверил фильтрами и 8 час максимум 870, а в вашем примере 793

Автор - ПАМ
Дата добавления - 14.12.2022 в 19:24
gling Дата: Среда, 14.12.2022, 19:38 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Да согласен спутал столбец РабДень с днем месяца. Замените C на F.
Код
=СУММПРОИЗВ(МАКС(($D$3:$D$746=K2)*($F$3:$F$746=1)*$E$3:$E$746))


ЯД-41001506838083
 
Ответить
СообщениеДа согласен спутал столбец РабДень с днем месяца. Замените C на F.
Код
=СУММПРОИЗВ(МАКС(($D$3:$D$746=K2)*($F$3:$F$746=1)*$E$3:$E$746))

Автор - gling
Дата добавления - 14.12.2022 в 19:38
ПАМ Дата: Среда, 14.12.2022, 21:28 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 241
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010, Excel 2016
gling, Огромное спасибо.
 
Ответить
Сообщениеgling, Огромное спасибо.

Автор - ПАМ
Дата добавления - 14.12.2022 в 21:28
Serge_007 Дата: Четверг, 15.12.2022, 09:16 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15647
Репутация: 2575 ±
Замечаний: ±

Excel 2016
как? пока также не понял, буду рад научиться
Как оформлять сообщения?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
как? пока также не понял, буду рад научиться
Как оформлять сообщения?

Автор - Serge_007
Дата добавления - 15.12.2022 в 09:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Наибольшое значение в определенном интервале (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!